aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-03-22 20:50:13 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-03-22 20:50:13 +0000
commit8e41d668bef02360fead5ad769b3970d2bcb88aa (patch)
treeab0dde25cdbc60a6b55284c62d8f746bd7de8f32 /comms
parent274b7984dceeafd56c8d8e1a97aa2dcc2ce427c8 (diff)
downloadports-8e41d668bef02360fead5ad769b3970d2bcb88aa.tar.gz
ports-8e41d668bef02360fead5ad769b3970d2bcb88aa.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/gnokii/files/patch-common-devices-unixbluetooth.c4
-rw-r--r--comms/gnokii/files/patch-configure4
-rw-r--r--comms/gnokii/files/patch-gnokii-Makefile.in11
-rw-r--r--comms/gnokii/files/patch-gnokiid-Makefile.in15
-rw-r--r--comms/gnokii/files/patch-smsd-Makefile.in15
-rw-r--r--comms/gnokii/files/patch-xgnokii-Makefile.in15
6 files changed, 51 insertions, 13 deletions
diff --git a/comms/gnokii/files/patch-common-devices-unixbluetooth.c b/comms/gnokii/files/patch-common-devices-unixbluetooth.c
index 7b2074e39925..5bb9bb09a702 100644
--- a/comms/gnokii/files/patch-common-devices-unixbluetooth.c
+++ b/comms/gnokii/files/patch-common-devices-unixbluetooth.c
@@ -1,11 +1,11 @@
--- common/devices/unixbluetooth.c.orig 2008-10-05 12:14:31.000000000 +0200
-+++ common/devices/unixbluetooth.c 2008-11-04 22:30:35.000000000 +0100
++++ common/devices/unixbluetooth.c 2009-02-17 17:03:58.000000000 +0100
@@ -54,6 +54,8 @@
#include <netgraph/bluetooth/include/ng_hci.h>
#include <netgraph/bluetooth/include/ng_l2cap.h>
#include <netgraph/bluetooth/include/ng_btsocket.h>
+#include <bluetooth.h>
-+#include <sdp.h>
++#include </usr/include/sdp.h>
#define BTPROTO_RFCOMM BLUETOOTH_PROTO_RFCOMM
#define BDADDR_ANY NG_HCI_BDADDR_ANY
diff --git a/comms/gnokii/files/patch-configure b/comms/gnokii/files/patch-configure
index 3af7f0e0bb74..b76c8a4185a7 100644
--- a/comms/gnokii/files/patch-configure
+++ b/comms/gnokii/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig 2008-10-06 08:57:27.000000000 +0200
-+++ configure 2008-11-01 00:28:22.000000000 +0100
++++ configure 2009-02-26 17:21:58.000000000 +0100
@@ -1057,7 +1057,7 @@
psdir='${docdir}'
libdir='${exec_prefix}/lib'
@@ -110,7 +110,7 @@
echo "${ECHO_T}$ac_cv_lib_bluetooth_bt_aton" >&6; }
if test $ac_cv_lib_bluetooth_bt_aton = yes; then
- BLUETOOTH_LIBS="$LIBS -lbluetooth"
-+ BLUETOOTH_LIBS="$LIBS -lsdp -lbluetooth"
++ BLUETOOTH_LIBS="-lsdp -lbluetooth $LIBS"
cat >>confdefs.h <<\_ACEOF
#define HAVE_BT_ATON
_ACEOF
diff --git a/comms/gnokii/files/patch-gnokii-Makefile.in b/comms/gnokii/files/patch-gnokii-Makefile.in
new file mode 100644
index 000000000000..9e75758b50a2
--- /dev/null
+++ b/comms/gnokii/files/patch-gnokii-Makefile.in
@@ -0,0 +1,11 @@
+--- gnokii/Makefile.in.orig 2009-02-26 17:09:49.000000000 +0100
++++ gnokii/Makefile.in 2009-02-26 17:20:21.000000000 +0100
+@@ -57,7 +57,7 @@
+ gnokii-gnokii-security.$(OBJEXT) \
+ gnokii-gnokii-settings.$(OBJEXT) gnokii-gnokii-sms.$(OBJEXT) \
+ gnokii-gnokii-todo.$(OBJEXT) gnokii-gnokii-utils.$(OBJEXT) \
+- gnokii-gnokii-wap.$(OBJEXT)
++ gnokii-gnokii-wap.$(OBJEXT) /usr/lib/libsdp.so
+ gnokii_OBJECTS = $(am_gnokii_OBJECTS)
+ am__DEPENDENCIES_1 =
+ gnokii_DEPENDENCIES = $(top_builddir)/common/libgnokii.la \
diff --git a/comms/gnokii/files/patch-gnokiid-Makefile.in b/comms/gnokii/files/patch-gnokiid-Makefile.in
index e816577a9e2b..e688fc352ea4 100644
--- a/comms/gnokii/files/patch-gnokiid-Makefile.in
+++ b/comms/gnokii/files/patch-gnokiid-Makefile.in
@@ -1,6 +1,15 @@
---- gnokiid/Makefile.in.orig 2008-05-03 21:21:29.000000000 +0200
-+++ gnokiid/Makefile.in 2008-05-29 22:14:16.000000000 +0200
-@@ -322,8 +322,8 @@
+--- gnokiid/Makefile.in.orig 2008-10-06 08:57:16.000000000 +0200
++++ gnokiid/Makefile.in 2009-02-26 17:26:31.000000000 +0100
+@@ -48,7 +48,7 @@
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS)
+ am_gnokiid_OBJECTS = gnokiid-gnokiid.$(OBJEXT)
+-gnokiid_OBJECTS = $(am_gnokiid_OBJECTS)
++gnokiid_OBJECTS = $(am_gnokiid_OBJECTS) /usr/lib/libsdp.so
+ am__DEPENDENCIES_1 =
+ gnokiid_DEPENDENCIES = $(top_builddir)/common/libgnokii.la \
+ $(top_builddir)/common/data/libDATA.la $(am__DEPENDENCIES_1)
+@@ -326,8 +326,8 @@
|| test -f $$p1 \
; then \
f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
diff --git a/comms/gnokii/files/patch-smsd-Makefile.in b/comms/gnokii/files/patch-smsd-Makefile.in
index f8d7655d67aa..83601dce019e 100644
--- a/comms/gnokii/files/patch-smsd-Makefile.in
+++ b/comms/gnokii/files/patch-smsd-Makefile.in
@@ -1,6 +1,15 @@
---- smsd/Makefile.in.orig 2008-05-03 21:21:32.000000000 +0200
-+++ smsd/Makefile.in 2008-05-29 22:16:37.000000000 +0200
-@@ -416,8 +416,8 @@
+--- smsd/Makefile.in.orig 2008-10-06 08:57:19.000000000 +0200
++++ smsd/Makefile.in 2009-02-26 17:35:49.000000000 +0100
+@@ -86,7 +86,7 @@
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS)
+ am_smsd_OBJECTS = smsd.$(OBJEXT) lowlevel.$(OBJEXT)
+-smsd_OBJECTS = $(am_smsd_OBJECTS)
++smsd_OBJECTS = $(am_smsd_OBJECTS) /usr/lib/libsdp.so
+ smsd_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(top_builddir)/common/libgnokii.la
+ DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/include
+@@ -421,8 +421,8 @@
|| test -f $$p1 \
; then \
f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
diff --git a/comms/gnokii/files/patch-xgnokii-Makefile.in b/comms/gnokii/files/patch-xgnokii-Makefile.in
index afa95721373d..75dd784cc69c 100644
--- a/comms/gnokii/files/patch-xgnokii-Makefile.in
+++ b/comms/gnokii/files/patch-xgnokii-Makefile.in
@@ -1,6 +1,15 @@
---- xgnokii/Makefile.in.orig 2008-02-23 17:19:30.000000000 +0100
-+++ xgnokii/Makefile.in 2008-02-23 17:19:58.000000000 +0100
-@@ -351,7 +351,8 @@
+--- xgnokii/Makefile.in.orig 2008-10-06 08:57:20.000000000 +0200
++++ xgnokii/Makefile.in 2009-02-26 17:33:22.000000000 +0100
+@@ -62,7 +62,7 @@
+ xgnokii-xgnokii_xring.$(OBJEXT) \
+ xgnokii-xgnokii_lowlevel.$(OBJEXT) \
+ xgnokii-xgnokii_data.$(OBJEXT)
+-xgnokii_OBJECTS = $(am_xgnokii_OBJECTS)
++xgnokii_OBJECTS = $(am_xgnokii_OBJECTS) /usr/lib/libsdp.so
+ am__DEPENDENCIES_1 =
+ xgnokii_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(top_builddir)/common/libgnokii.la \
+@@ -360,7 +360,8 @@
#FIXME install help
HELP_DIR = docs/help
pkgconfig_DATA = xgnokii.pc