aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-30 21:50:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-30 21:50:00 +0000
commit945d6d36700902fa63fc4782d21a05e744bb1e4d (patch)
tree61d27c6e9204cc3796dab4643bc6f08af7a4db96 /comms
parente7c8e4d664c94d58d78aa6fa86958114ad4ee9d4 (diff)
downloadports-945d6d36700902fa63fc4782d21a05e744bb1e4d.tar.gz
ports-945d6d36700902fa63fc4782d21a05e744bb1e4d.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/gpsk31/Makefile19
-rw-r--r--comms/gpsk31/distinfo2
-rw-r--r--comms/gpsk31/files/patch-call_dialog10
-rw-r--r--comms/gpsk31/files/patch-linux-sondcard33
-rw-r--r--comms/gpsk31/files/patch-src_server-main.C10
-rw-r--r--comms/gpsk31/pkg-descr2
-rw-r--r--comms/gpsk31/pkg-plist4
8 files changed, 81 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index e861ea302fbd..450bdc3b74dc 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -30,6 +30,7 @@
SUBDIR += gmfsk
SUBDIR += gnokii
SUBDIR += gpredict
+ SUBDIR += gpsk31
SUBDIR += grig
SUBDIR += gscmxx
SUBDIR += gsmlib
diff --git a/comms/gpsk31/Makefile b/comms/gpsk31/Makefile
new file mode 100644
index 000000000000..db1f565da22c
--- /dev/null
+++ b/comms/gpsk31/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: gpsk31
+# Date created: 2005-05-27
+# Whom: Søren Straarup <xride@x12.dk>
+#
+# $FreeBSD$
+
+PORTNAME= gpsk31
+PORTVERSION= 0.2.4a
+CATEGORIES= comms
+MASTER_SITES= http://ftp.iasi.roedu.net/mirrors/ftp.1409.org/gpsk31/
+
+MAINTAINER= xride@x12.dk
+COMMENT= A gtk psk31 client
+
+USE_GNOME= gtk12
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+
+.include <bsd.port.mk>
diff --git a/comms/gpsk31/distinfo b/comms/gpsk31/distinfo
new file mode 100644
index 000000000000..1b6c1a73281d
--- /dev/null
+++ b/comms/gpsk31/distinfo
@@ -0,0 +1,2 @@
+MD5 (gpsk31-0.2.4a.tar.gz) = da91b3a9e81d2f3c4c5ec40d3057ca35
+SIZE (gpsk31-0.2.4a.tar.gz) = 112009
diff --git a/comms/gpsk31/files/patch-call_dialog b/comms/gpsk31/files/patch-call_dialog
new file mode 100644
index 000000000000..1fade7eda5c3
--- /dev/null
+++ b/comms/gpsk31/files/patch-call_dialog
@@ -0,0 +1,10 @@
+--- src/call_dialog.C.orig Sun May 8 14:07:32 2005
++++ src/call_dialog.C Sun May 8 14:08:01 2005
+@@ -27,6 +27,7 @@
+
+ #include <gtk/gtk.h>
+ #include <ctype.h>
++#include <string.h>
+ #include "main_screen.h"
+ #include "call_dialog.h"
+ #include "menu.h"
diff --git a/comms/gpsk31/files/patch-linux-sondcard b/comms/gpsk31/files/patch-linux-sondcard
new file mode 100644
index 000000000000..3721fe13c647
--- /dev/null
+++ b/comms/gpsk31/files/patch-linux-sondcard
@@ -0,0 +1,33 @@
+--- src/main.C.orig Sun May 8 14:01:27 2005
++++ src/main.C Sun May 8 14:01:43 2005
+@@ -29,7 +29,7 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <stdio.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+--- src/psk31-transmitter.C.orig Sun May 8 14:02:00 2005
++++ src/psk31-transmitter.C Sun May 8 14:02:14 2005
+@@ -11,7 +11,7 @@
+ #include <errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+ #include <sys/ioctl.h>
+ #include "psk31-coder.h"
+ #include "psk31-transmitter.h"
+--- src/spectrum.C.orig Sun May 8 14:02:28 2005
++++ src/spectrum.C Sun May 8 14:03:01 2005
+@@ -30,7 +30,7 @@
+ #include <stdlib.h>
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+
+ #include <gtk/gtk.h>
+ #include <stdio.h>
diff --git a/comms/gpsk31/files/patch-src_server-main.C b/comms/gpsk31/files/patch-src_server-main.C
new file mode 100644
index 000000000000..4305870bed40
--- /dev/null
+++ b/comms/gpsk31/files/patch-src_server-main.C
@@ -0,0 +1,10 @@
+--- src/server-main.C.orig Sun May 8 13:28:03 2005
++++ src/server-main.C Sun May 8 13:28:18 2005
+@@ -19,6 +19,7 @@
+ * thread and from user interface thread (==interface functions)
+ */
+
++#include <sys/types.h>
+ #include <sys/mman.h>
+ #include "config.h"
+ #include <stdio.h>
diff --git a/comms/gpsk31/pkg-descr b/comms/gpsk31/pkg-descr
new file mode 100644
index 000000000000..c8f483cc64e5
--- /dev/null
+++ b/comms/gpsk31/pkg-descr
@@ -0,0 +1,2 @@
+
+This is a small PSK31 program that uses gtk and soundcard as modem.
diff --git a/comms/gpsk31/pkg-plist b/comms/gpsk31/pkg-plist
new file mode 100644
index 000000000000..9e841147f1d2
--- /dev/null
+++ b/comms/gpsk31/pkg-plist
@@ -0,0 +1,4 @@
+bin/gpsk31
+share/gpsk31/gpsk31.conf
+share/gpsk31/psk31.cod
+@dirrm share/gpsk31