aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-09-03 07:29:44 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-09-03 07:31:04 +0000
commit98516d34df514f2d772f96dd1ec2ba80ab72ba4c (patch)
treec0034f9bf18f002768b8f172cef7d4248f0afe07 /comms
parentb3408688b0e693740017005e1221ca1d9ed376bc (diff)
downloadports-98516d34df514f2d772f96dd1ec2ba80ab72ba4c.tar.gz
ports-98516d34df514f2d772f96dd1ec2ba80ab72ba4c.zip
comms/wsjtz: Fix build
- Add missing dependencies - Add DOCS option Reported by: pkg-fallout
Diffstat (limited to 'comms')
-rw-r--r--comms/wsjtz/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/comms/wsjtz/Makefile b/comms/wsjtz/Makefile
index f06f4860d24c..b917a696629c 100644
--- a/comms/wsjtz/Makefile
+++ b/comms/wsjtz/Makefile
@@ -19,14 +19,16 @@ BUILD_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor \
${LOCALBASE}/share/xsl/docbook:textproc/docbook-xsl
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
- libxslt.so:textproc/libxslt
+ libxslt.so:textproc/libxslt \
+ libhamlib.so:comms/hamlib \
+ libreadline.so:devel/readline
USES= cmake compiler:c++11-lib fortran gl \
makeinfo pkgconfig qt:5 zip
USE_GL= glu
USE_QT= core gui network widgets \
multimedia concurrent printsupport serialport sql sql-sqlite3 \
- buildtools_build linguisttools_build qmake_build
+ testlib buildtools_build linguisttools_build qmake_build
CMAKE_ARGS+= -DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib \
-DLOCALBASE::STRING="${LOCALBASE}"
@@ -34,6 +36,8 @@ CMAKE_ARGS+= -DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib \
#CMAKE_ARGS+= --debug-output --trace
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/z/x/}