aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:27:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:27:29 +0000
commitc4d4cacd63490d4b63e844ae298880332a388ba7 (patch)
tree3913b841cc9c2f98d7e4b2056eafc0d9980bf1c8 /comms
parent5faefa6350cd172add279e339bd86a650313beb3 (diff)
downloadports-c4d4cacd63490d4b63e844ae298880332a388ba7.tar.gz
ports-c4d4cacd63490d4b63e844ae298880332a388ba7.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/garmin-utils/Makefile11
-rw-r--r--comms/hcidump/Makefile13
-rw-r--r--comms/ib-kmod/Makefile4
-rw-r--r--comms/lirc/Makefile10
-rw-r--r--comms/minicom/Makefile8
-rw-r--r--comms/spandsp/Makefile7
-rw-r--r--comms/unixcw/Makefile7
7 files changed, 9 insertions, 51 deletions
diff --git a/comms/garmin-utils/Makefile b/comms/garmin-utils/Makefile
index 3aaedd7a95ed..e5c8a1cf7a0a 100644
--- a/comms/garmin-utils/Makefile
+++ b/comms/garmin-utils/Makefile
@@ -16,15 +16,8 @@ COMMENT= Utilities for Garmin GPS receivers
MAN1= gardump.1 garload.1
MANCOMPRESSED= yes
MAKE_ARGS+= MANDIR=${MANPREFIX}/man/man
+MAKE_ARGS+= GPS_SERIAL_PORT=/dev/cuad0
PLIST_FILES= bin/gardump bin/garload
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600006
-MAKE_ARGS+= GPS_SERIAL_PORT=/dev/cuaa0
-.else
-MAKE_ARGS+= GPS_SERIAL_PORT=/dev/cuad0
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/hcidump/Makefile b/comms/hcidump/Makefile
index 5bd014e94218..b0edbec71933 100644
--- a/comms/hcidump/Makefile
+++ b/comms/hcidump/Makefile
@@ -19,15 +19,4 @@ MAN1= hcidump.1
MANCOMPRESSED= yes
PLIST_FILES= bin/hcidump
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502000
-IGNORE= it needs Bluetooth stack (FreeBSD 5.2 or newer)
-.endif
-
-.if ${OSVERSION} < 502121
-# libbluetooth is only installed on i386 before this version
-ONLY_FOR_ARCHS= i386
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/ib-kmod/Makefile b/comms/ib-kmod/Makefile
index 7c8182189dee..d023937e68b5 100644
--- a/comms/ib-kmod/Makefile
+++ b/comms/ib-kmod/Makefile
@@ -26,10 +26,6 @@ PLIST_FILES= "@cwd ${KMODDIR}" \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600031
-IGNORE= required FreeBSD 6.0-STABLE at least (if_alloc(), etc.)
-.endif
-
pre-fetch:
.if !exists(${SRC_BASE}/sys/Makefile)
@${ECHO} "*************************************************"; \
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 8bee112f7394..917ab9b1057e 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -23,6 +23,9 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
OPTIONS= IRMAN "Build with libirman support" On
@@ -44,13 +47,6 @@ CONFIGURE_ARGS+= --with-driver=irman --with-driver=dvico
CONFIGURE_ARGS+= --with-driver=any --with-driver=dvico
.endif
-.if ${OSVERSION} >= 500041
-# These are already included in the getopt_long case on < 50041
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-.endif
-
MAN1= ircat.1 irexec.1 irpty.1 irrecord.1 irsend.1 irw.1 \
irxevent.1 lircrcd.1 mode2.1 smode2.1 xmode2.1
MAN8= lircd.8 lircmd.8
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index acea25667b13..3f6cb9175fc8 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -35,13 +35,7 @@ CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600000
MINICOM_DEFAULT_PORT?= /dev/cuad0
-.else
-MINICOM_DEFAULT_PORT?= /dev/cuaa0
-.endif
CONFIGURE_ARGS+= --enable-dfl-port=${MINICOM_DEFAULT_PORT}
MAN1= minicom.1 runscript.1 ascii-xfr.1 xminicom.1
@@ -71,4 +65,4 @@ post-install:
${DOCSDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/spandsp/Makefile b/comms/spandsp/Makefile
index 97edbd469202..519dd1ef7e6f 100644
--- a/comms/spandsp/Makefile
+++ b/comms/spandsp/Makefile
@@ -28,12 +28,7 @@ CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
post-patch:
@${FIND} ${WRKSRC} -name *.c | ${XARGS} ${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|'
-.if ${OSVERSION} < 503000
- ${ECHO} '#define lrintf(x) ((int16_t)rintf(x))' > ${WRKSRC}/src/tgmath.h
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
index f37c87e1baa7..9c2b7a0673e8 100644
--- a/comms/unixcw/Makefile
+++ b/comms/unixcw/Makefile
@@ -35,11 +35,6 @@ USE_AUTOTOOLS= autoconf:262
USE_LDCONFIG= yes
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
-.endif
-
pre-extract:
.if !defined(WITH_XCWCP)
@${ECHO_CMD}
@@ -53,4 +48,4 @@ post-patch:
@${REINPLACE_CMD} -e "s|%%LIBDATA%%|${PREFIX}/libdata|" \
${WRKSRC}/src/cwlib/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>