aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-16 03:16:14 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-16 03:16:14 +0000
commit3ac10856732f2b6a9168b42a9cee95948ccbd01d (patch)
treedef6570629e848082d51dd55d6ebb32ef19708ba /comms
parent2026d5c01e0e301d10637db9e47ae049871e13b1 (diff)
downloadports-3ac10856732f2b6a9168b42a9cee95948ccbd01d.tar.gz
ports-3ac10856732f2b6a9168b42a9cee95948ccbd01d.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/yawmppp/Makefile31
-rw-r--r--comms/yawmppp/distinfo1
-rw-r--r--comms/yawmppp/pkg-comment1
-rw-r--r--comms/yawmppp/pkg-descr12
-rw-r--r--comms/yawmppp/pkg-plist12
6 files changed, 58 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index c2de1c11613a..d01fe27e79ee 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -29,6 +29,7 @@
SUBDIR += vpb2
SUBDIR += xcept
SUBDIR += yaps
+ SUBDIR += yawmppp
SUBDIR += zmtx-zmrx
.include <bsd.port.subdir.mk>
diff --git a/comms/yawmppp/Makefile b/comms/yawmppp/Makefile
new file mode 100644
index 000000000000..235b822f5ee8
--- /dev/null
+++ b/comms/yawmppp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: yawmppp
+# Date created: 07 Mar 2000
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yawmppp
+PORTVERSION= 2.0.1
+CATEGORIES= comms windowmaker
+MASTER_SITES= ftp://ftp.seul.org/pub/yawmppp/ \
+ http://www.dcc.unicamp.br/~guazzibe/yawmppp/arch/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GTK= yes
+CONFIGURE_ENV= GTKCONFIG="${GTK_CONFIG}" CFLAGS="${CFLAGS} -I${X11BASE}/include"
+CONFIGURE_ARGS= --x-includes="${X11BASE}/include" \
+ --x-libraries="${X11BASE}/lib"
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+MAN1= yawmppp.1x
+
+pre-configure:
+ ${PERL} -pi -e "s@-g -O2@${CFLAGS}@g; s@-O2 -Wall@${CFLAGS} -Wall@g; \
+ s@-O2@${CFLAGS}@g" ${WRKSRC}/*/Makefile.in \
+ ${WRKSRC}/configure ${WRKSRC}/*/*/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/comms/yawmppp/distinfo b/comms/yawmppp/distinfo
new file mode 100644
index 000000000000..af61a5bd3496
--- /dev/null
+++ b/comms/yawmppp/distinfo
@@ -0,0 +1 @@
+MD5 (yawmppp-2.0.1.tar.gz) = 2999d53fb4df1940f4a8eaf183924d40
diff --git a/comms/yawmppp/pkg-comment b/comms/yawmppp/pkg-comment
new file mode 100644
index 000000000000..3c099131455b
--- /dev/null
+++ b/comms/yawmppp/pkg-comment
@@ -0,0 +1 @@
+A Window Maker dockapp that helps with easy use of pppd
diff --git a/comms/yawmppp/pkg-descr b/comms/yawmppp/pkg-descr
new file mode 100644
index 000000000000..eccf0c877cc2
--- /dev/null
+++ b/comms/yawmppp/pkg-descr
@@ -0,0 +1,12 @@
+YAWMPPP (Yet Another Window Maker PPP dockapp) is a
+Window Maker dockapp that gets its inspiration from the
+original WMPPP. It has an easy-to-use GUI configuration
+dialog and generates a chat script (as well as stop and
+start scripts) for use with pppd. The dockapp shows
+how long you've been connected, current network traffic,
+and some fairly interesting lights.
+
+WWW: http://yawmppp.seul.org/
+Author: Felipe Bergo <bergo@seul.org>
+
+- Will <andrews@technologist.com>
diff --git a/comms/yawmppp/pkg-plist b/comms/yawmppp/pkg-plist
new file mode 100644
index 000000000000..c66c6bb7306f
--- /dev/null
+++ b/comms/yawmppp/pkg-plist
@@ -0,0 +1,12 @@
+bin/yawmppp
+bin/yawmppp.log
+bin/yawmppp.pref
+bin/yawmppp.thin
+doc/yawmppp-%%PORTVERSION%%/CHANGELOG
+doc/yawmppp-%%PORTVERSION%%/COPYING
+doc/yawmppp-%%PORTVERSION%%/FAQ
+doc/yawmppp-%%PORTVERSION%%/INSTALL
+doc/yawmppp-%%PORTVERSION%%/README
+share/icons/pppdoc.xpm
+share/icons/stepphone.xpm
+@dirrm doc/yawmppp-%%PORTVERSION%%