aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-10-24 18:51:36 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-01-27 06:12:26 +0000
commit4f0a5e1540c391610950d6ae9ce64ba0dd218d72 (patch)
treee0e3a0327237691d3fe5df542835ced376d3bfae /comms
parentcc7a787d5f043014dcea80bd0058dd7117a5e308 (diff)
downloadports-4f0a5e1540c391610950d6ae9ce64ba0dd218d72.tar.gz
ports-4f0a5e1540c391610950d6ae9ce64ba0dd218d72.zip
PyQt: Update sip to 6.5.0, reintroduce sip4 and simplify PyQt framework.
SIP: As mentioned in the update from sip to sip5, this is a transitional version to remove what is deprecated in sip4. Sip6 completely removes the deprecated parts. Unfortunately, some ports — mostly cura things — can not use sip6, so we reintroduce sip4. PyQt: At the same time, we took the opportunity to simplify PyQT and propose only one package as for devel/pyside2. */py-qt5-* have been merged — excepted chart, networkauth and webengine — into devel/py-qt5-pyqt. This allows us to be in adequacy with the packages that the author of these libraries proposes, namely: PyQt - devel/py-qt5-pyqt PyQt-Charts - x11-toolkits/py-qt5-chart PyQt-NetworkAuth – net/py-qt5-networkauth PyQt-WebEngine – www/py-qt5-webengine SIP – devel/py-sip py-sip - devel/py-qt5-sip PyQt-builder - devel/py-qtbuilder Qscintilla - devel/py-qt5-qscintilla2 Reviewed by: diizzy, kde Tested by: kai, rhurlin, arrowd, madpilot Approved by: makc, tcberner, kde Differential Revision: https://reviews.freebsd.org/D33237 Exp-run by: antoine
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile2
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--comms/nanovna-saver/Makefile2
-rw-r--r--comms/py-qt5-sensors/Makefile30
-rw-r--r--comms/py-qt5-sensors/pkg-descr4
-rw-r--r--comms/py-qt5-sensors/pkg-plist24
-rw-r--r--comms/py-qt5-serialport/Makefile30
-rw-r--r--comms/py-qt5-serialport/pkg-descr4
-rw-r--r--comms/py-qt5-serialport/pkg-plist6
9 files changed, 2 insertions, 102 deletions
diff --git a/comms/Makefile b/comms/Makefile
index c5ddf663d841..1676e470b3c8 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -137,8 +137,6 @@
SUBDIR += py-hidapi
SUBDIR += py-libimobiledevice
SUBDIR += py-pyserial
- SUBDIR += py-qt5-sensors
- SUBDIR += py-qt5-serialport
SUBDIR += py-xmodem
SUBDIR += pyla
SUBDIR += qico
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 920c34daa21a..2552c309d569 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -68,7 +68,7 @@ CMAKE_ARGS+= -DCMAKE_INSTALL_RPATH:STRING="${LOCALBASE}/lib/gcc${_GCC_VER}" \
#CMAKE_ARGS+= --debug-output --trace
USE_CXXSTD= c++11
USE_GITHUB= yes
-USE_PYQT= core gui opengl
+USE_PYQT= pyqt5
USE_WX= 3.0
USE_QT= buildtools core gui xml qmake widgets
WX_COMPS= wx wx:build wx:run python:build python:run
diff --git a/comms/nanovna-saver/Makefile b/comms/nanovna-saver/Makefile
index 52e6ed42cdfe..fa2690c0c54e 100644
--- a/comms/nanovna-saver/Makefile
+++ b/comms/nanovna-saver/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PY_DEPENDS}
USES= python:3.3+ pyqt:5
USE_PYTHON= distutils autoplist noflavors
-USE_PYQT= core_run gui_run widgets_run
+USE_PYQT= pyqt5_run
USE_GITHUB= yes
GH_ACCOUNT= mihtjel
diff --git a/comms/py-qt5-sensors/Makefile b/comms/py-qt5-sensors/Makefile
deleted file mode 100644
index 9d5ec277b65e..000000000000
--- a/comms/py-qt5-sensors/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-PORTNAME= sensors
-PORTREVISION= 3
-CATEGORIES= comms devel python
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Python bindings for the Qt5 toolkit, QtSensors module
-
-CONFIGURE_ARGS= --enable QtSensors
-PYQT_DIST= yes
-
-USES= gl python:3.5+ pyqt:5 qt:5
-USE_GL= gl
-USE_PYQT= sip_build core_run
-USE_PYTHON= concurrent flavors py3kplist
-USE_QT= core gui sensors qmake_build
-
-OPTIONS_DEFINE= API DEBUG
-OPTIONS_DEFAULT=API
-OPTIONS_SUB= yes
-
-API_DESC= Install QtSensors API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
-API_CONFIGURE_OFF= --no-qsci-api
-API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
-DEBUG_CONFIGURE_ON= --debug --trace
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtSensors.so
-
-.include <bsd.port.mk>
diff --git a/comms/py-qt5-sensors/pkg-descr b/comms/py-qt5-sensors/pkg-descr
deleted file mode 100644
index 0340c2f37557..000000000000
--- a/comms/py-qt5-sensors/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-PyQt5 is a set of Python bindings for Qt5 application framework.
-This package provides the QtSensors module.
-
-WWW: https://riverbankcomputing.com/software/pyqt
diff --git a/comms/py-qt5-sensors/pkg-plist b/comms/py-qt5-sensors/pkg-plist
deleted file mode 100644
index 094231ef2feb..000000000000
--- a/comms/py-qt5-sensors/pkg-plist
+++ /dev/null
@@ -1,24 +0,0 @@
-%%PYTHON_SITELIBDIR%%/PyQt5/QtSensors.pyi
-%%PYTHON_SITELIBDIR%%/PyQt5/QtSensors.so
-%%API%%%%PYQT_APIDIR%%/api/python/QtSensors.api
-%%PYQT_SIPDIR%%/QtSensors/QtSensorsmod.sip
-%%PYQT_SIPDIR%%/QtSensors/qaccelerometer.sip
-%%PYQT_SIPDIR%%/QtSensors/qaltimeter.sip
-%%PYQT_SIPDIR%%/QtSensors/qambientlightsensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qambienttemperaturesensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qcompass.sip
-%%PYQT_SIPDIR%%/QtSensors/qdistancesensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qgyroscope.sip
-%%PYQT_SIPDIR%%/QtSensors/qholstersensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qhumiditysensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qirproximitysensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qlidsensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qlightsensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qmagnetometer.sip
-%%PYQT_SIPDIR%%/QtSensors/qorientationsensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qpressuresensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qproximitysensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qrotationsensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qsensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qtapsensor.sip
-%%PYQT_SIPDIR%%/QtSensors/qtiltsensor.sip
diff --git a/comms/py-qt5-serialport/Makefile b/comms/py-qt5-serialport/Makefile
deleted file mode 100644
index 99a67a6a8487..000000000000
--- a/comms/py-qt5-serialport/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-PORTNAME= serialport
-PORTREVISION= 3
-CATEGORIES= comms devel python
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Python bindings for the Qt5 toolkit, QtSerialPort module
-
-CONFIGURE_ARGS= --enable QtSerialPort
-PYQT_DIST= yes
-
-USES= gl python:3.5+ pyqt:5 qt:5
-USE_GL= gl
-USE_PYQT= sip_build core_run
-USE_PYTHON= concurrent flavors py3kplist
-USE_QT= core gui serialport qmake_build
-
-OPTIONS_DEFINE= API DEBUG
-OPTIONS_DEFAULT=API
-OPTIONS_SUB= yes
-
-API_DESC= Install QtSerialPort API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
-API_CONFIGURE_OFF= --no-qsci-api
-API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
-DEBUG_CONFIGURE_ON= --debug --trace
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtSerialPort.so
-
-.include <bsd.port.mk>
diff --git a/comms/py-qt5-serialport/pkg-descr b/comms/py-qt5-serialport/pkg-descr
deleted file mode 100644
index 1a4d33ea807d..000000000000
--- a/comms/py-qt5-serialport/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-PyQt5 is a set of Python bindings for Qt5 application framework.
-This package provides the QtSerialPort module.
-
-WWW: https://riverbankcomputing.com/software/pyqt
diff --git a/comms/py-qt5-serialport/pkg-plist b/comms/py-qt5-serialport/pkg-plist
deleted file mode 100644
index 5ae131680464..000000000000
--- a/comms/py-qt5-serialport/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-%%PYTHON_SITELIBDIR%%/PyQt5/QtSerialPort.so
-%%PYTHON_SITELIBDIR%%/PyQt5/QtSerialPort.pyi
-%%PYQT_SIPDIR%%/QtSerialPort/QtSerialPortmod.sip
-%%PYQT_SIPDIR%%/QtSerialPort/qserialport.sip
-%%PYQT_SIPDIR%%/QtSerialPort/qserialportinfo.sip
-%%API%%%%PYQT_APIDIR%%/api/python/QtSerialPort.api