aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-29 15:59:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-29 15:59:20 +0000
commit63e4efd2690d3c7e56bed4a8019a422fc8dd0f43 (patch)
treeb8ec26609920271398fe9e4fcd2a3e6b8319da9c /comms
parent155bf8b7d9c1436513ace399e171ee84047c9277 (diff)
downloadports-63e4efd2690d3c7e56bed4a8019a422fc8dd0f43.tar.gz
ports-63e4efd2690d3c7e56bed4a8019a422fc8dd0f43.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/qfaxreader/Makefile42
-rw-r--r--comms/qfaxreader/distinfo3
-rw-r--r--comms/qfaxreader/pkg-descr22
-rw-r--r--comms/qfaxreader/pkg-plist7
5 files changed, 75 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 46a428de9b29..14fa5e090397 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -76,6 +76,7 @@
SUBDIR += py-lirc
SUBDIR += py-serial
SUBDIR += pyla
+ SUBDIR += qfaxreader
SUBDIR += qico
SUBDIR += qicosi
SUBDIR += qpage
diff --git a/comms/qfaxreader/Makefile b/comms/qfaxreader/Makefile
new file mode 100644
index 000000000000..40437a37915f
--- /dev/null
+++ b/comms/qfaxreader/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: qfaxreader
+# Date created: 2005-11-18
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+#
+# $Tecnik: ports/comms/qfaxreader/Makefile,v 1.4 2005/12/28 22:39:36 itetcu Exp $
+#
+
+PORTNAME= qfaxreader
+DISTVERSION= 0.3RC5
+CATEGORIES= comms graphics print
+MASTER_SITES= http://oss.thel.ro/${PORTNAME}/ \
+ http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Mono/color multipage tiff/fax files visualisation/printing utility
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_QT_VER= 3
+CONFIGURE_ENV= QTDIR=${QT_PREFIX} PTHREAD_LIBS=${PTHREAD_LIBS}
+CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
+
+MAN1= qfaxreader.1
+
+OPTIONS= GDBM "For sender-id look-up (recomended)" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GDBM) || exists(${LOCALBASE}/include/gdbm.h)
+LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+.endif
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/qfaxreader/distinfo b/comms/qfaxreader/distinfo
new file mode 100644
index 000000000000..b930eaae4cee
--- /dev/null
+++ b/comms/qfaxreader/distinfo
@@ -0,0 +1,3 @@
+MD5 (qfaxreader-0.3RC5.tar.bz2) = 314ada005f209e9d2fcb6bbebe85199e
+SHA256 (qfaxreader-0.3RC5.tar.bz2) = c6845e7e153a1119d41b8914dcf8e8c8b9267ce81f5c65fffd8598d7c55d7317
+SIZE (qfaxreader-0.3RC5.tar.bz2) = 243157
diff --git a/comms/qfaxreader/pkg-descr b/comms/qfaxreader/pkg-descr
new file mode 100644
index 000000000000..f3ccf72747fa
--- /dev/null
+++ b/comms/qfaxreader/pkg-descr
@@ -0,0 +1,22 @@
+DESCRIPTION
+QFaxReader is a monochrome/color multipage tiff/fax files visualisation
+utility. Is designed for the users who receive faxes using computers.
+
+FEATURES
+ * Handle multi page tiff/fax files (even color)
+ * Correctly display fax images in any resolution
+ * Fullscreen mode
+ * Printing fax files (multiple pages per sheet)
+ * Autodetect printing system (CUPS, lpr-bsd, lpr-ng)
+ * Image transformation (rotate left, rotate right, vertical flip)
+ * Arbitrary zoom fax images
+ * Sidebar with easy navigation through directories
+ * AutoRefresh + notification for new facsimiles
+ * Aliases database for replacing faxes id's with real name
+ If you don't have gdbm or db library installed, this feature is disabled.
+ * Export in all formats which your QT have support
+ WARNING! This feature overwrite files without any notification!
+ * Experimental internationalization support
+ * CID support
+
+WWW: http://oss.thel.ro/qfaxreader
diff --git a/comms/qfaxreader/pkg-plist b/comms/qfaxreader/pkg-plist
new file mode 100644
index 000000000000..866961ed8523
--- /dev/null
+++ b/comms/qfaxreader/pkg-plist
@@ -0,0 +1,7 @@
+bin/qfaxreader
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/README
+%%DOCSDIR%%/TODO
+@dirrm %%DOCSDIR%%