aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2022-01-12 01:06:38 +0000
committerDiane Bruce <db@FreeBSD.org>2022-01-12 01:06:38 +0000
commit763fc7004ceaf9e837b160271f4491fbe92df031 (patch)
tree78628e4a1d6942fc7495778a419fc8304dcf5388 /comms
parent1472128ffce86da03f0c783d25a14a6ae1baad4a (diff)
downloadports-763fc7004ceaf9e837b160271f4491fbe92df031.tar.gz
ports-763fc7004ceaf9e837b160271f4491fbe92df031.zip
comms/hamlib: Update to 4.4
- Some patches not needed now due to adrian@ patches sent upstream. - Additional changes by @takefu added RIG_FUNC_SEND_VOICE_MEM from git For a complete log of changes to Hamlib, please visit: http://sourceforge.net/p/hamlib/code/commit_browser Major changes in 4.0 affecting usage Most rig model numbers have changed RIG_LEVEL_VOX has been deprecated and replaced by RIG_LEVEL_VOXDELAY rigctl 'f' command now returns VFO argument too rigctl 'y' and 'Y' command now take/show antenna argument and option. range_list items are undergoing changes towards a different model TBD RTS/DTR PTT sharing is off by default now -- use serial_share=1 option to enable PR: ports/261105 Reported by: takefu@airport.gm
Diffstat (limited to 'comms')
-rw-r--r--comms/hamlib/Makefile14
-rw-r--r--comms/hamlib/distinfo6
-rw-r--r--comms/hamlib/files/patch-configure.ac11
-rw-r--r--comms/hamlib/files/patch-hamlib.pc.in2
-rw-r--r--comms/hamlib/files/patch-tests_testlibusb.c29
-rw-r--r--comms/hamlib/pkg-plist8
6 files changed, 15 insertions, 55 deletions
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 88f9eb9d83fc..a53a00bacfec 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -1,8 +1,7 @@
# Created by: Sebastian Yepes <esn@x123.info>
PORTNAME= hamlib
-PORTVERSION= 4.3.1
-PORTREVISION= 1
+PORTVERSION= 4.4
CATEGORIES= comms hamradio
MASTER_SITES= SF
@@ -16,14 +15,12 @@ LIB_DEPENDS= libltdl.so:devel/libltdl
USES= autoreconf gnome libtool:keepla localbase:ldflags pathfix perl5 pkgconfig python \
readline shebangfix tcl
-USE_PYTHON= py3kplist
-USE_PERL5= build run
USE_GNOME= libxml2
USE_LDCONFIG= yes
+USE_PERL5= build run
+USE_PYTHON= py3kplist
# $TCL_INCLUDE_SPEC
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
SHEBANG_FILES= bindings/perltest.pl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-perl-binding \
@@ -31,9 +28,10 @@ CONFIGURE_ARGS= --with-perl-binding \
--with-libusb \
--with-python-binding
CONFIGURE_ENV= LIBUSB_LIBS="-lusb"
-PLIST_SUB= VER=${PORTVERSION} TCL_VER=${TCL_VER}
INSTALL_TARGET= install-strip
-
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+PLIST_SUB= VER=${PORTVERSION} TCL_VER=${TCL_VER}
OPTIONS_DEFINE= DOCS
post-patch:
diff --git a/comms/hamlib/distinfo b/comms/hamlib/distinfo
index a9cb510661ea..2bd414567697 100644
--- a/comms/hamlib/distinfo
+++ b/comms/hamlib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1636328018
-SHA256 (hamlib-4.3.1.tar.gz) = 3437386dfdd2314f108cf35f1527b20d784256b76633d216a50de94f4045a730
-SIZE (hamlib-4.3.1.tar.gz) = 2356944
+TIMESTAMP = 1641893139
+SHA256 (hamlib-4.4.tar.gz) = 8bf0107b071f52f08587f38e2dee8a7848de1343435b326f8f66d95e1f8a2487
+SIZE (hamlib-4.4.tar.gz) = 2401399
diff --git a/comms/hamlib/files/patch-configure.ac b/comms/hamlib/files/patch-configure.ac
deleted file mode 100644
index 7a9686e2aeb3..000000000000
--- a/comms/hamlib/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2016-12-31 20:01:25 UTC
-+++ configure.ac
-@@ -87,7 +87,7 @@ AC_PROG_INSTALL
- AC_PROG_LN_S
-
- # TODO: check whether CXX is functional
--AC_CHECK_PROG([cf_with_cxx], ["${CXX}"], [yes], [no])
-+AC_PATH_PROG([cf_with_cxx], ["${CXX}"], [yes], [no])
-
- AM_CONDITIONAL([ENABLE_CXX], [test x"${cf_with_cxx}" = "xyes"])
-
diff --git a/comms/hamlib/files/patch-hamlib.pc.in b/comms/hamlib/files/patch-hamlib.pc.in
index a5e20151ff44..1d5b0de8a0a7 100644
--- a/comms/hamlib/files/patch-hamlib.pc.in
+++ b/comms/hamlib/files/patch-hamlib.pc.in
@@ -1,4 +1,4 @@
---- hamlib.pc.in.orig 2016-12-31 20:01:25 UTC
+--- hamlib.pc.in.orig 2021-12-03 00:09:30 UTC
+++ hamlib.pc.in
@@ -7,7 +7,6 @@ Name: @PACKAGE_NAME@
Description: Library to control radio and rotator equipment.
diff --git a/comms/hamlib/files/patch-tests_testlibusb.c b/comms/hamlib/files/patch-tests_testlibusb.c
deleted file mode 100644
index 8926f15ffe7e..000000000000
--- a/comms/hamlib/files/patch-tests_testlibusb.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- tests/testlibusb.c 2021-11-30 22:59:53.050103000 -0500
-+++ tests/testlibusb.c 2021-11-30 23:03:26.187330000 -0500
-@@ -113,7 +113,9 @@
- printf(" wSpeedSupported: %u\n", ss_usb_cap->wSpeedSupported);
- printf(" bFunctionalitySupport: %u\n", ss_usb_cap->bFunctionalitySupport);
- printf(" bU1devExitLat: %u\n", ss_usb_cap->bU1DevExitLat);
-+#if !defined(__FreeBSD__)
- printf(" bU2devExitLat: %u\n", ss_usb_cap->bU2DevExitLat);
-+#endif
- }
-
- static void print_bos(libusb_device_handle *handle)
-@@ -131,6 +133,7 @@
-
- printf(" Binary Object Store (BOS):\n");
- printf(" wTotalLength: %u\n", bos->wTotalLength);
-+#if !defined(__FreeBSD__)
- printf(" bNumDeviceCaps: %u\n", bos->bNumDeviceCaps);
-
- for (i = 0; i < bos->bNumDeviceCaps; i++)
-@@ -168,7 +171,7 @@
- libusb_free_ss_usb_device_capability_descriptor(ss_dev_cap);
- }
- }
--
-+#endif
- libusb_free_bos_descriptor(bos);
- }
-
diff --git a/comms/hamlib/pkg-plist b/comms/hamlib/pkg-plist
index 011248cfc8a2..372b478fd614 100644
--- a/comms/hamlib/pkg-plist
+++ b/comms/hamlib/pkg-plist
@@ -22,12 +22,12 @@ lib/libhamlib++.a
lib/libhamlib++.la
lib/libhamlib++.so
lib/libhamlib++.so.4
-lib/libhamlib++.so.4.0.3
+lib/libhamlib++.so.4.0.4
lib/libhamlib.a
lib/libhamlib.la
lib/libhamlib.so
lib/libhamlib.so.4
-lib/libhamlib.so.4.0.3
+lib/libhamlib.so.4.0.4
%%SITE_ARCH%%/Hamlib.pm
%%SITE_ARCH%%/auto/Hamlib/Hamlib.so
%%SITE_ARCH%%/perltest.pl
@@ -35,7 +35,9 @@ lib/libhamlib.so.4.0.3
%%PYTHON_SITELIBDIR%%/_Hamlib.a
%%PYTHON_SITELIBDIR%%/_Hamlib.la
%%PYTHON_SITELIBDIR%%/_Hamlib.so
-lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-4.3.so
+%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.pyc
+lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-%%VER%%.so
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.a
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.la
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.so