aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2018-07-31 06:33:03 +0000
committerFukang Chen <loader@FreeBSD.org>2018-07-31 06:33:03 +0000
commit8f49a8fe8884bafddd5efa0b5073a409b0016995 (patch)
treebf5af5cf22a16a41a9bb70973b082123e8a9edd6 /comms
parentce3dd72fc8692def247b9cb0f6b8e3e155fe0ddc (diff)
downloadports-8f49a8fe8884bafddd5efa0b5073a409b0016995.tar.gz
ports-8f49a8fe8884bafddd5efa0b5073a409b0016995.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/py-esptool/Makefile41
-rw-r--r--comms/py-esptool/distinfo3
-rw-r--r--comms/py-esptool/pkg-descr4
4 files changed, 49 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index a4a0a08d3ab2..47c1d1d790ba 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -135,6 +135,7 @@
SUBDIR += pr
SUBDIR += predict
SUBDIR += py-bulksms
+ SUBDIR += py-esptool
SUBDIR += py-gammu
SUBDIR += py-hidapi
SUBDIR += py-libconcord
diff --git a/comms/py-esptool/Makefile b/comms/py-esptool/Makefile
new file mode 100644
index 000000000000..4d07d62a9079
--- /dev/null
+++ b/comms/py-esptool/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= esptool
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.5.0
+CATEGORIES= comms python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Utility to communicate with Espressif ESP8266 & ESP32 chips
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}serial>=3.0:comms/py-serial@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyaes>0:security/py-pyaes@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+
+GH_ACCOUNT= espressif
+NO_ARCH= yes
+
+ESPTOOL_BAUDRATE?= 115200
+ESPTOOL_CHIP?= esp8266
+ESPTOOL_SERIALPORT?= /dev/ttyU0
+
+do-test:
+ @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest \
+ --ignore test/test_esptool.py
+.if exists(${ESPTOOL_SERIALPORT})
+ @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} \
+ ${PYTHON_CMD} test/test_esptool.py \
+ ${ESPTOOL_SERIALPORT} ${ESPTOOL_CHIP} ${ESPTOOL_BAUDRATE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/py-esptool/distinfo b/comms/py-esptool/distinfo
new file mode 100644
index 000000000000..b452a8484764
--- /dev/null
+++ b/comms/py-esptool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532614101
+SHA256 (espressif-esptool-v2.5.0_GH0.tar.gz) = c18e57b3c012fc1ac4caeebf388949d1704b6c602b3489fe19b13e24cbc01f24
+SIZE (espressif-esptool-v2.5.0_GH0.tar.gz) = 4042607
diff --git a/comms/py-esptool/pkg-descr b/comms/py-esptool/pkg-descr
new file mode 100644
index 000000000000..8af32be018f2
--- /dev/null
+++ b/comms/py-esptool/pkg-descr
@@ -0,0 +1,4 @@
+A Python-based, open source, platform independent, utility to communicate
+with the ROM bootloader in Espressif ESP8266 & ESP32 chips.
+
+WWW: https://github.com/espressif/esptool