aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-11 22:28:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-11 22:28:24 +0000
commitc482f36edd91c27cc77d7f9f963dc6c4fe9dbb53 (patch)
tree48bf085482f07dd563a7062272a2b4fd45c201a2 /comms
parentbd787bee6fc36f39514ff7a264b0ae98e5ae8c0b (diff)
downloadports-c482f36edd91c27cc77d7f9f963dc6c4fe9dbb53.tar.gz
ports-c482f36edd91c27cc77d7f9f963dc6c4fe9dbb53.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/gmfsk/Makefile37
-rw-r--r--comms/gmfsk/distinfo4
-rw-r--r--comms/gmfsk/files/patch-config.h.in11
-rw-r--r--comms/gmfsk/files/patch-mt63_dsp.h21
-rw-r--r--comms/gmfsk/files/patch-snd.c27
-rw-r--r--comms/gmfsk/files/patch-src_mt63_dsp.h22
-rw-r--r--comms/gmfsk/pkg-descr4
-rw-r--r--comms/gmfsk/pkg-message10
-rw-r--r--comms/gmfsk/pkg-plist31
9 files changed, 77 insertions, 90 deletions
diff --git a/comms/gmfsk/Makefile b/comms/gmfsk/Makefile
index cc76b4ddefe7..e1c5a4be00da 100644
--- a/comms/gmfsk/Makefile
+++ b/comms/gmfsk/Makefile
@@ -6,27 +6,40 @@
#
PORTNAME= gmfsk
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 0.6
CATEGORIES= comms audio
-MASTER_SITES= http://hes.iki.fi/pub/ham/unix/linux/hfmodems/
+MASTER_SITES= http://gmfsk.connect.fi/
MAINTAINER= carl@stagecraft.cx
COMMENT= The Gnome MFSK terminal program
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
# This is pure evil but it looks like autoconf 2.53 has a bug in linking the
-# preprocessor include tests. This is a work around.
-CONFIGURE_ARGS= LDFLAGS="-L${LOCALBASE}/lib"
-# There is a bug in the code that causes the compile to fail if -O is not set.
-CFLAGS+= -O -I${LOCALBASE}/include
-USE_GMAKE= yes
-USE_AUTOCONF_VER= 253
-USE_GNOME= libgnomeui
+# preprocessor include tests. The following line is a work around.
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+USE_GMAKE= yes
+USE_GNOME= libgnomeui gnomehack gnomeprefix
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+OPTIONS= HAMLIB "Enable HAMLIB Support" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_HAMLIB)
+LIB_DEPENDS+= hamlib:${PORTSDIR}/comms/hamlib
+CONFIGURE_ARGS+= --enable-hamlib
+CONFIGURE_ENV+= PKG_CONFIG_PATH=${LOCALBASE}/lib/pkgconfig
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[$$][(]localstatedir[)]/lib/scrollkeeper|${SCROLLKEEPER_DIR}|g' \
+ ${WRKSRC}/omf.make ${WRKSRC}/help/gmfsk/C/Makefile.in
post-install:
@${CAT} pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/gmfsk/distinfo b/comms/gmfsk/distinfo
index 27c05816b636..45bdd5632e86 100644
--- a/comms/gmfsk/distinfo
+++ b/comms/gmfsk/distinfo
@@ -1,2 +1,2 @@
-MD5 (gmfsk-0.5.tar.gz) = b27d4debb69b97a6c290b7811bb402f6
-SIZE (gmfsk-0.5.tar.gz) = 270352
+MD5 (gmfsk-0.6.tar.gz) = 184840b31b85f6c4f86cdbe27f0644c8
+SIZE (gmfsk-0.6.tar.gz) = 540765
diff --git a/comms/gmfsk/files/patch-config.h.in b/comms/gmfsk/files/patch-config.h.in
deleted file mode 100644
index 12ce1651a549..000000000000
--- a/comms/gmfsk/files/patch-config.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./config.h.in.orig Thu May 29 21:48:43 2003
-+++ ./config.h.in Thu May 29 21:48:51 2003
-@@ -20,7 +20,7 @@
- #undef HAVE_DFFTW_H
-
- /* Define to 1 if you have the <fftw.h> header file. */
--#undef HAVE_FFTW_H
-+#define HAVE_FFTW_H
-
- /* Define if the GNU gettext() function is already present or preinstalled. */
- #undef HAVE_GETTEXT
diff --git a/comms/gmfsk/files/patch-mt63_dsp.h b/comms/gmfsk/files/patch-mt63_dsp.h
new file mode 100644
index 000000000000..2fed48b35150
--- /dev/null
+++ b/comms/gmfsk/files/patch-mt63_dsp.h
@@ -0,0 +1,21 @@
+--- src/mt63/dsp.h.orig Sat Sep 25 10:52:22 2004
++++ src/mt63/dsp.h Sat Sep 25 10:58:58 2004
+@@ -555,15 +555,15 @@
+ inline void LowPass2(typeInp Inp, LowPass2elem &Elem,
+ typeW W1, typeW W2, typeW W5)
+ { double Sum, Diff;
+- Sum=Elem.Mid+Elem.Out; Diff=Elem.Mid-Elem.Out; Elem.Mid+=W2*Inp-W1*Sum; Out+=W5*Diff; }
++ Sum=Elem.Mid+Elem.Out; Diff=Elem.Mid-Elem.Out; Elem.Mid+=W2*Inp-W1*Sum; Elem.Out+=W5*Diff; }
+
+ template <class typeInp>
+ inline void LowPass2(typeInp Inp, LowPass2elem &Elem, LowPass2weight &Weight)
+ { double Sum, Diff;
+ Sum=Elem.Mid+Elem.Out;
+ Diff=Elem.Mid-Elem.Out;
+- Elem.Mid+=Weight.W2*Inp-Weigth.W1*Sum;
+- Out+=Weight.W5*Diff; }
++ Elem.Mid+=Weight.W2*Inp-Weight.W1*Sum;
++ Elem.Out+=Weight.W5*Diff; }
+
+ /*
+ inline void LowPass2(float Inp, double &Mid, double &Out,
diff --git a/comms/gmfsk/files/patch-snd.c b/comms/gmfsk/files/patch-snd.c
deleted file mode 100644
index 82a04f4fc82c..000000000000
--- a/comms/gmfsk/files/patch-snd.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- ./src/snd.c.orig Thu May 29 22:03:20 2003
-+++ ./src/snd.c Thu May 29 22:17:00 2003
-@@ -9,7 +9,14 @@
- #include <unistd.h>
- #include <errno.h>
- #include <fcntl.h>
--#include <endian.h>
-+#if HAVE_SYS_BYTEORDER_H
-+# include <sys/byteorder.h>
-+#elif HAVE_MACHINE_ENDIAN_H
-+# include <machine/endian.h>
-+#elif HAVE_ENDIAN_H
-+# include <endian.h>
-+#endif
-+
- #include <sys/soundcard.h>
- #include <sys/ioctl.h>
-
-@@ -18,6 +25,8 @@
- #include "misc.h"
-
- #undef SND_DEBUG
-+
-+#define AFMT_S16_NE AFMT_S16_LE
-
- /* ---------------------------------------------------------------------- */
-
diff --git a/comms/gmfsk/files/patch-src_mt63_dsp.h b/comms/gmfsk/files/patch-src_mt63_dsp.h
deleted file mode 100644
index b5c4459cd6de..000000000000
--- a/comms/gmfsk/files/patch-src_mt63_dsp.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/mt63/dsp.h.orig Thu Sep 23 16:05:14 2004
-+++ src/mt63/dsp.h Thu Sep 23 16:09:10 2004
-@@ -846,7 +846,7 @@
- Sum = Elem.Mid + Elem.Out;
- Diff = Elem.Mid - Elem.Out;
- Elem.Mid += W2 * Inp - W1 * Sum;
-- Out += W5 * Diff;
-+ Elem.Out += W5 * Diff;
- }
-
- template < class typeInp >
-@@ -856,8 +856,8 @@
- double Sum, Diff;
- Sum = Elem.Mid + Elem.Out;
- Diff = Elem.Mid - Elem.Out;
-- Elem.Mid += Weight.W2 * Inp - Weigth.W1 * Sum;
-- Out += Weight.W5 * Diff;
-+ Elem.Mid += Weight.W2 * Inp - Weight.W1 * Sum;
-+ Elem.Out += Weight.W5 * Diff;
- }
-
- /*
diff --git a/comms/gmfsk/pkg-descr b/comms/gmfsk/pkg-descr
index be532b0adfe0..31db8d1147f7 100644
--- a/comms/gmfsk/pkg-descr
+++ b/comms/gmfsk/pkg-descr
@@ -5,9 +5,9 @@ gMFSK is a multi-mode soundcard terminal program for HF amateur
communications. Originally the program was written for compatibility
with the IZ8BLY Stream program in MFSK16 mode. Currently the program
supports the following amateur digital communications modes: MFSK16,
-MFSK8, RTTY, THROB, PSK31, MT63 and FELDHELL.
+MFSK8, RTTY, THROB, PSK31, PSK63, MT63 and FELDHELL.
-WWW: http://hes.iki.fi/
+WWW: http://gmfsk.connect.fi/
- Carl
carl@stagecraft.cx
diff --git a/comms/gmfsk/pkg-message b/comms/gmfsk/pkg-message
index 1459e1c9c302..fec5f3bc9f6e 100644
--- a/comms/gmfsk/pkg-message
+++ b/comms/gmfsk/pkg-message
@@ -13,16 +13,12 @@ Under Settings->Preferences->Devices->Sound set your sound device to
This will use the 16bit sound device rather than /dev/dsp0 which is
the 8bit sound device.
-Then use the Gnome-volume-control to set your receive and transmit
-levels. DO NOT OVERDRIVE YOUR RIG. I recommend you head over to
+Then use the Gnome-volume-control or your favourite mixer program
+to set your receive and transmit levels. DO NOT OVERDRIVE YOUR RIG.
+I recommend you head over to
http://www.w5bbr.com/
which has links to useful info.
-The port currently has a minor bug that means error messages will be
-printed if the LANG environment variable is not set to something in
-/usr/share/locale. You can either set the LANG environment variable
-or ignore the error.
-
Enjoy!
Carl, VK1KCM
carl@stagecraft.cx
diff --git a/comms/gmfsk/pkg-plist b/comms/gmfsk/pkg-plist
index 945c87e0cc69..7516f5d16fcc 100644
--- a/comms/gmfsk/pkg-plist
+++ b/comms/gmfsk/pkg-plist
@@ -1,8 +1,25 @@
bin/gmfsk
-share/pixmaps/gmfsk/mfsk.png
-share/pixmaps/gmfsk/pause.xpm
-share/pixmaps/gmfsk/rx.xpm
-share/pixmaps/gmfsk/tune.xpm
-share/pixmaps/gmfsk/tx.xpm
-@dirrm share/pixmaps/gmfsk
-@dirrm share/pixmaps
+@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gmfsk.schemas >/dev/null || /usr/bin/true
+etc/gconf/schemas/gmfsk.schemas
+@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gmfsk.schemas >/dev/null || /usr/bin/true
+share/gnome/help/gmfsk/C/fdl-appendix.xml
+share/gnome/help/gmfsk/C/figures/gmfsk_start_window.png
+share/gnome/help/gmfsk/C/figures/note.png
+share/gnome/help/gmfsk/C/figures/tip.png
+share/gnome/help/gmfsk/C/figures/warning.png
+share/gnome/help/gmfsk/C/gmfsk.xml
+share/gnome/help/gmfsk/C/legal.xml
+share/gnome/omf/gmfsk/gmfsk-C.omf
+share/gnome/pixmaps/gmfsk/gnome-screenshot.png
+share/gnome/pixmaps/gmfsk/mfsk.png
+share/gnome/pixmaps/gmfsk/pause.xpm
+share/gnome/pixmaps/gmfsk/rx.xpm
+share/gnome/pixmaps/gmfsk/tune.xpm
+share/gnome/pixmaps/gmfsk/tx.xpm
+@dirrm share/gnome/pixmaps/gmfsk
+@dirrm share/gnome/omf/gmfsk
+@dirrm share/gnome/help/gmfsk/C/figures
+@dirrm share/gnome/help/gmfsk/C
+@dirrm share/gnome/help/gmfsk
+@exec scrollkeeper-install -q %D/share/gnome/omf/gmfsk/gmfsk-C.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gmfsk/gmfsk-C.omf 2>/dev/null || /usr/bin/true