aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2017-03-26 18:59:58 +0000
committerDiane Bruce <db@FreeBSD.org>2017-03-26 18:59:58 +0000
commit01c31a5a735538c47e4536181ceb6958348478b9 (patch)
tree428b9d8f9d37a3f97878788b62a7c67e025086ce /comms
parent7030a9c847133bdf06c5e3fbade976aff9bc3233 (diff)
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/fldigi/Makefile13
-rw-r--r--comms/fldigi/distinfo6
-rw-r--r--comms/fldigi/files/patch-src_include_main.h2
-rw-r--r--comms/fldigi/files/patch-src_logbook_adif__io.cxx11
-rw-r--r--comms/fldigi/files/patch-src_misc_newinstall.cxx2
-rw-r--r--comms/fldigi/files/patch-src_widgets_picture.cxx2
6 files changed, 25 insertions, 11 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 935f24515b59..0ffd10c29068 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fldigi
-PORTVERSION= 3.23.20
+PORTVERSION= 3.23.21
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -13,13 +13,16 @@ LICENSE= GPLv3
BUILD_DEPENDS= asciidoc:textproc/asciidoc\
docbook-xsl>=1.0:textproc/docbook-xsl\
xsltproc:textproc/libxslt
-LIB_DEPENDS= libsamplerate.so:audio/libsamplerate\
- libboost_system.so:devel/boost-libs\
- libfltk.so:x11-toolkits/fltk
+LIB_DEPENDS= libboost_system.so:devel/boost-libs\
+ libpng16.so:graphics/png \
+ libfltk.so:x11-toolkits/fltk \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libsamplerate.so:audio/libsamplerate
USE_CXXSTD= gnu++0x
GNU_CONFIGURE= yes
-USES= compiler:c++11-lib execinfo gmake perl5 pkgconfig shebangfix
+USES= compiler:c++11-lib execinfo jpeg gmake perl5 pkgconfig shebangfix
+USE_XORG= x11 xft xext xfixes xcursor xinerama
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
diff --git a/comms/fldigi/distinfo b/comms/fldigi/distinfo
index d20f17fb45fb..1cb9787a93e7 100644
--- a/comms/fldigi/distinfo
+++ b/comms/fldigi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483830837
-SHA256 (fldigi-3.23.20.tar.gz) = 97b5489c4e428ed707aaf6c05a7b46874339031a8e9b24e50f4818c15435fce9
-SIZE (fldigi-3.23.20.tar.gz) = 3215903
+TIMESTAMP = 1490552971
+SHA256 (fldigi-3.23.21.tar.gz) = a70914876a415eba5eec112f752330a1cecbf55aa442f5d9dd466fb75ea11a3b
+SIZE (fldigi-3.23.21.tar.gz) = 3217867
diff --git a/comms/fldigi/files/patch-src_include_main.h b/comms/fldigi/files/patch-src_include_main.h
index 92cd1881845f..ebb34dc581d5 100644
--- a/comms/fldigi/files/patch-src_include_main.h
+++ b/comms/fldigi/files/patch-src_include_main.h
@@ -1,4 +1,4 @@
---- src/include/main.h.orig 2016-12-07 04:15:22 UTC
+--- src/include/main.h.orig 2017-01-29 13:26:25 UTC
+++ src/include/main.h
@@ -22,6 +22,8 @@
#define MAIN_H_
diff --git a/comms/fldigi/files/patch-src_logbook_adif__io.cxx b/comms/fldigi/files/patch-src_logbook_adif__io.cxx
new file mode 100644
index 000000000000..0b0b5113fcfc
--- /dev/null
+++ b/comms/fldigi/files/patch-src_logbook_adif__io.cxx
@@ -0,0 +1,11 @@
+--- src/logbook/adif_io.cxx.orig 2017-01-29 13:26:25 UTC
++++ src/logbook/adif_io.cxx
+@@ -316,7 +316,7 @@ void cAdifIO::do_readfile(const char *fn
+ } else {
+ ptr2 = ptr + 1;
+ }
+- if ((ptr2) > 0 && (unsigned)(ptr2 - ptr) <= p)
++ if ((unsigned long)(ptr2) > 0 && (unsigned long)(ptr2 - ptr) <= p)
+ ptr = strchr(ptr2,'<');
+ else
+ break; // corrupt record
diff --git a/comms/fldigi/files/patch-src_misc_newinstall.cxx b/comms/fldigi/files/patch-src_misc_newinstall.cxx
index 9947e55fb9d1..7ee4f210e8b2 100644
--- a/comms/fldigi/files/patch-src_misc_newinstall.cxx
+++ b/comms/fldigi/files/patch-src_misc_newinstall.cxx
@@ -1,4 +1,4 @@
---- src/misc/newinstall.cxx.orig 2016-08-07 11:40:51 UTC
+--- src/misc/newinstall.cxx.orig 2017-01-29 13:26:25 UTC
+++ src/misc/newinstall.cxx
@@ -67,7 +67,7 @@ text[3] = " btu <NAME> <CALL> de <MYCALL
diff --git a/comms/fldigi/files/patch-src_widgets_picture.cxx b/comms/fldigi/files/patch-src_widgets_picture.cxx
index d20e12426aaf..fed30c020f18 100644
--- a/comms/fldigi/files/patch-src_widgets_picture.cxx
+++ b/comms/fldigi/files/patch-src_widgets_picture.cxx
@@ -1,4 +1,4 @@
---- src/widgets/picture.cxx.orig 2016-09-18 12:35:58 UTC
+--- src/widgets/picture.cxx.orig 2017-01-29 13:26:25 UTC
+++ src/widgets/picture.cxx
@@ -40,6 +40,7 @@
#include <algorithm>