aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-10-21 21:15:31 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-10-21 21:15:31 +0000
commit4ba98149cf8de6cf9a4d47e94b64fb66ef3c81b4 (patch)
tree7af9251161c08f3971475fc71eb3afe6793c08fd /comms
parent6e651be77728af7df1504e6c5914bacb565e3c79 (diff)
downloadports-4ba98149cf8de6cf9a4d47e94b64fb66ef3c81b4.tar.gz
ports-4ba98149cf8de6cf9a4d47e94b64fb66ef3c81b4.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/hylafax/Makefile6
-rw-r--r--comms/hylafax/files/patch-configure18
2 files changed, 21 insertions, 3 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 55d9599f9dd9..3b7739fca6c5 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -17,8 +17,8 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
# no dependency on ghostscript because we don't know which
# version the user prefers
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
+ jpeg:${PORTSDIR}/graphics/jpeg
DIST_SUBDIR= hylafax
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
# Want PAM?
.if defined(WITHOUT_PAM)
-CONFIGURE_ARGS+=--disable-PAM
+CONFIGURE_ARGS+=--disable-pam
.endif
# Want HTML documentation?
diff --git a/comms/hylafax/files/patch-configure b/comms/hylafax/files/patch-configure
index 01c147b44d7d..a379120f3128 100644
--- a/comms/hylafax/files/patch-configure
+++ b/comms/hylafax/files/patch-configure
@@ -253,6 +253,24 @@
test "$LIBMALLOC" = yes && MACHDEPLIBS="$MACHDEPLIBS -lmalloc"
#
+@@ -2364,5 +2364,5 @@
+ if [ "${lib_ver}" = "3.4" ]; then
+ tiff_runlen_t="uint16"
+- elif [ "${lib_ver}" = "3.5" -o "${lib_ver}" = "3.6" ]; then
++ elif [ "${lib_ver}" = "3.5" -o "${lib_ver}" = "3.6" -o "${lib_ver}" = "3.7" ]; then
+ tiff_runlen_t="uint32"
+ fi
+@@ -2401,7 +2401,7 @@
+ Incompatible TIFF Library.
+
+-HylaFAX ${VERSION} requires TIFF software distribution ver 3.4, 3.5, or
+-3.6. If you do not have up to date TIFF software on your system then
+-you can retrieve it from the location where you obtained this software.
++HylaFAX ${VERSION} requires TIFF software distribution ver 3.4, 3.5,
++3.6, or 3.7. If you do not have up to date TIFF software on your system
++then you can retrieve it from the location where you obtained this software.
+ The Home Page for version 3.5 and later is http://www.libtiff.org
+ EOF
@@ -2640,7 +2652,7 @@
}
CheckFuncDecl unlink 'extern int unlink(const char*);' unistd.h