aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-05-13 16:06:05 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-05-13 16:06:05 +0000
commit6a1d7c932a5e0648085597022e2ded39f9fff06f (patch)
tree47ee1dde4077215141f2aec641b7395ff6e08be6 /comms
parenteed462d207c60b5601e10f4a8e3e32ffcab36e73 (diff)
downloadports-6a1d7c932a5e0648085597022e2ded39f9fff06f.tar.gz
ports-6a1d7c932a5e0648085597022e2ded39f9fff06f.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/uartlirc/Makefile53
-rw-r--r--comms/uartlirc/distinfo2
-rw-r--r--comms/uartlirc/pkg-descr22
4 files changed, 78 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 3a4c0db01b81..48abc272eb6a 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -149,6 +149,7 @@
SUBDIR += trustedqsl
SUBDIR += twpsk
SUBDIR += uarduno
+ SUBDIR += uartlirc
SUBDIR += uhso-kmod
SUBDIR += uird
SUBDIR += umcs7840
diff --git a/comms/uartlirc/Makefile b/comms/uartlirc/Makefile
new file mode 100644
index 000000000000..eedaa69a05e7
--- /dev/null
+++ b/comms/uartlirc/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: uarlirc
+# Date created: Sun May 13 17:39:40 CEST 2012
+# Whom: nox@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= uartlirc
+PORTVERSION= 0.3
+CATEGORIES= comms kld
+MASTER_SITES= LOCAL/nox \
+ http://people.freebsd.org/~nox/tmp/
+DISTNAME= ${PORTNAME}-preliminary-003
+EXTRACT_SUFX= .shar
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Driver for "homebrew" serial LIRC receivers
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+EXTRACT_CMD= ${SH}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS=
+
+.include <bsd.port.pre.mk>
+
+PLIST_FILES+= "@cwd /"
+PLIST_FILES+= ${KMODDIR:C,^/,,}/${PORTNAME}.ko
+PLIST_FILES+= "@exec kldxref ${KMODDIR}"
+PLIST_FILES+= "@unexec kldxref ${KMODDIR}"
+
+# install where x11/nvidia-driver does also:
+KMODDIR= /boot/modules
+
+MAKE_ENV+= KMODDIR="${KMODDIR}"
+
+SYSDIR?= ${SRC_BASE}/sys
+MAKE_ENV+= SYSDIR="${SYSDIR}"
+
+CFLAGS+= ${DEBUG_FLAGS}
+
+.if ${OSVERSION} < 800000
+IGNORE= needs <sys/buf_ring.h>
+.endif
+
+.if !exists(${SYSDIR}/Makefile)
+IGNORE= requires kernel source to be installed
+.endif
+
+do-install:
+ ${INSTALL} ${WRKSRC}/${PORTNAME}.ko ${KMODDIR}
+ kldxref ${KMODDIR}
+
+.include <bsd.port.post.mk>
diff --git a/comms/uartlirc/distinfo b/comms/uartlirc/distinfo
new file mode 100644
index 000000000000..bca798e6e9f6
--- /dev/null
+++ b/comms/uartlirc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (uartlirc-preliminary-003.shar) = 3d65bbb8448760a1cbb42d4ea9517fe06689a20b363b5fef90358cc24cb399e1
+SIZE (uartlirc-preliminary-003.shar) = 254995
diff --git a/comms/uartlirc/pkg-descr b/comms/uartlirc/pkg-descr
new file mode 100644
index 000000000000..340ef98824d1
--- /dev/null
+++ b/comms/uartlirc/pkg-descr
@@ -0,0 +1,22 @@
+This is a driver for "homebrew" type serial LIRC reveivers as
+described here:
+
+ http://lirc.org/receivers.html
+
+It overrides the `normal' uart(4) driver, if you have that driver
+already loaded or statically in your kernel (like it is in GENERIC)
+then you need to load uartlirc.ko from loader.conf(5) (or manually
+via the loader prompt) for the override to work. The driver provides
+a /dev/lircX node for each serial port in addition to the normal
+tty nodes /dev/cuauX etc, so you can still use other serial ports
+normally should you have more than one.
+
+Note: it only supports PCI/motherboard serial ports not ones connected
+via USB, for USB you can use mceusb hardware supported via webcamd,
+or FTDI hardware supported by comms/lirc natively via libftdi, see:
+
+ http://wiki.freebsd.org/WebcamCompat
+
+and the comms/lirc port's pkg-message.
+
+WWW: http://forums.freebsd.org/showthread.php?p=175029