aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 20:13:14 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 20:13:14 +0000
commit124debd4f912f7f70cf7c0c538aebf1d0c2f13a9 (patch)
treeff42a230259e3ec145f77e42c57f0fda7f690129 /comms
parentac66b26c6fb83bf1f7d00b75d2af403b36177308 (diff)
downloadports-124debd4f912f7f70cf7c0c538aebf1d0c2f13a9.tar.gz
ports-124debd4f912f7f70cf7c0c538aebf1d0c2f13a9.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/gsmlib/Makefile27
-rw-r--r--comms/gsmlib/distinfo2
-rw-r--r--comms/gsmlib/files/patch-Makefile.in.in11
-rw-r--r--comms/gsmlib/files/patch-configure10
-rw-r--r--comms/gsmlib/files/patch-gsm_sms_codec.cc11
-rw-r--r--comms/gsmlib/pkg-plist2
6 files changed, 31 insertions, 32 deletions
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index 81129332b567..a2c65cafaf8b 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -7,25 +7,36 @@
#
PORTNAME= gsmlib
-PORTVERSION= 1.9
-PORTREVISION= 1
+PORTVERSION= 1.10
CATEGORIES= comms
MASTER_SITES= http://www.pxh.de/fs/gsmlib/download/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-USE_LIBTOOL= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= \
- CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+USE_REINPLACE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
MAN1= gsmctl.1 gsmpb.1 gsmsendsms.1 gsmsmsstore.1
MAN7= gsminfo.7
MAN8= gsmsmsd.8
+CPPFLAGS= -I${LOCALBASE}/include -DBROKEN_STRFTIME -DHAVE_DECL_GETOPT \
+ ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
+post-patch:
+ @${GREP} -lR "<malloc.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<malloc\.h>|<stdlib.h>|g'
+
.include <bsd.port.mk>
diff --git a/comms/gsmlib/distinfo b/comms/gsmlib/distinfo
index 58710658521b..f61ce0c512ed 100644
--- a/comms/gsmlib/distinfo
+++ b/comms/gsmlib/distinfo
@@ -1 +1 @@
-MD5 (gsmlib-1.9.tar.gz) = e53e62041f7dd73b33ea108dfbffc973
+MD5 (gsmlib-1.10.tar.gz) = deea4ce2e4f5f1965d32d576597d3ff4
diff --git a/comms/gsmlib/files/patch-Makefile.in.in b/comms/gsmlib/files/patch-Makefile.in.in
deleted file mode 100644
index b8c0a3373461..000000000000
--- a/comms/gsmlib/files/patch-Makefile.in.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Wed Apr 24 04:05:50 2002
-+++ po/Makefile.in.in Wed Apr 24 04:06:09 2002
-@@ -122,7 +122,7 @@
- cat=`basename $$cat`; \
- case "$$cat" in \
- *.gmo) destdir=$(gnulocaledir);; \
-- *) destdir=$(localedir);; \
-+ *) destdir=$(gnulocaledir);; \
- esac; \
- lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
- dir=$$destdir/$$lang/LC_MESSAGES; \
diff --git a/comms/gsmlib/files/patch-configure b/comms/gsmlib/files/patch-configure
new file mode 100644
index 000000000000..54f27ec9e860
--- /dev/null
+++ b/comms/gsmlib/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Oct 17 05:23:09 2002
++++ configure Sat Nov 30 07:16:22 2002
+@@ -7400,6 +7400,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/comms/gsmlib/files/patch-gsm_sms_codec.cc b/comms/gsmlib/files/patch-gsm_sms_codec.cc
deleted file mode 100644
index 511c3ec35bb6..000000000000
--- a/comms/gsmlib/files/patch-gsm_sms_codec.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- gsmlib/gsm_sms_codec.cc.orig Tue Oct 29 02:33:19 2002
-+++ gsmlib/gsm_sms_codec.cc Tue Oct 29 02:33:36 2002
-@@ -110,6 +110,8 @@
- t.tm_isdst = -1;
- t.tm_yday = 0;
- t.tm_wday = 0;
-+
-+#define BROKEN_STRFTIME
-
- #ifdef BROKEN_STRFTIME
- char formattedTime[1024];
diff --git a/comms/gsmlib/pkg-plist b/comms/gsmlib/pkg-plist
index a440eaf39b52..a89b736be902 100644
--- a/comms/gsmlib/pkg-plist
+++ b/comms/gsmlib/pkg-plist
@@ -23,7 +23,6 @@ include/gsmlib/gsm_sorted_phonebook_base.h
include/gsmlib/gsm_sorted_sms_store.h
include/gsmlib/gsm_unix_serial.h
include/gsmlib/gsm_util.h
-@dirrm include/gsmlib
lib/libgsmext.a
lib/libgsmext.so
lib/libgsmext.so.1
@@ -31,3 +30,4 @@ lib/libgsmme.a
lib/libgsmme.so
lib/libgsmme.so.1
share/locale/de/LC_MESSAGES/gsmlib.mo
+@dirrm include/gsmlib