aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-05-16 17:25:28 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-05-16 17:25:28 +0000
commit4c59ac295e70a2fde17da4a22647b9fff81fa8d7 (patch)
tree33d9bc0b5e605a5d3579fa88f5eeab1581dd936e /comms
parent64ec27bb47ad6cc45d56b77e1ef2ff8bd4b27fff (diff)
downloadports-4c59ac295e70a2fde17da4a22647b9fff81fa8d7.tar.gz
ports-4c59ac295e70a2fde17da4a22647b9fff81fa8d7.zip
Fix shebangs.
Approved by: rakuco (mentor, implicit)
Notes
Notes: svn path=/head/; revision=441013
Diffstat (limited to 'comms')
-rw-r--r--comms/uhd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index ca11547754b2..c610fec6712d 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= uhd
PORTVERSION= 3.9.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= comms hamradio
MASTER_SITES= http://files.ettus.com/binaries/images/
DISTFILES= ${IMAGE_FILE}
@@ -27,13 +27,15 @@ CONFLICTS= usrp-[0-9]*
BROKEN_powerpc64= fails to link: undefined reference to boost function
USES= compiler:c++0x cmake:outsource gmake ncurses pkgconfig \
- dos2unix python:2.7
+ dos2unix python:2.7 shebangfix
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
#MAKE_JOBS_UNSAFE= yes
CXXFLAGS_amd64= -msse2
CXXFLAGS_i386= -msse2
+SHEBANG_GLOB= *.py *.py.in
+
CMAKE_ARGS+= -DPKG_LIB_DIR:STRING="share/uhd" -DUHD_TXRX_DEBUG_PRINTS="yes"
# for excruciating debug use this -db
#CMAKE_ARGS+= --debug-output --trace