aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-21 21:55:08 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-21 21:55:08 +0000
commitfa7459871993c1b82be45b128cb6cc16d6d6097b (patch)
treef3de3615c4398425cec6e6c4d1a630f701a34d2d /comms
parenta379971cffb802fce69885970f1184f7228beb86 (diff)
downloadports-fa7459871993c1b82be45b128cb6cc16d6d6097b.tar.gz
ports-fa7459871993c1b82be45b128cb6cc16d6d6097b.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Notes
Notes: svn path=/head/; revision=441429
Diffstat (limited to 'comms')
-rw-r--r--comms/direwolf/Makefile2
-rw-r--r--comms/linrad/Makefile7
-rw-r--r--comms/uarduno/Makefile2
3 files changed, 8 insertions, 3 deletions
diff --git a/comms/direwolf/Makefile b/comms/direwolf/Makefile
index d22adfedfdba..2d4985d6a7d2 100644
--- a/comms/direwolf/Makefile
+++ b/comms/direwolf/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libhamlib.so:comms/hamlib \
libgps.so:astro/gpsd
+BROKEN_powerpc64= fails to link: direwolf-1.4_1 depends on shared library: libgpsd.so - not found
+
USE_GITHUB= yes
GH_ACCOUNT= wb2osz
GH_TAGNAME= 6207e2e
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index ccb2f4a29ca4..7a71eca7b67d 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -32,9 +32,10 @@ LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
z_PARALLEL_PORT.txt z_SETTINGS.txt \
z_USERS_EXTRA.txt z_USERS_HWARE.txt
-BROKEN_aarch64= Fails to compile: implicit declaration of function outb
-BROKEN_armv6= Fails to configure: can not find /nxb-bin/usr/bin/cc
-BROKEN_sparc64= Fails to compile: implicit declaration of function outb
+BROKEN_aarch64= fails to compile: implicit declaration of function outb
+BROKEN_armv6= fails to configure: can not find /nxb-bin/usr/bin/cc
+BROKEN_powerpc64= fails to compile: implicit declaration of function outb
+BROKEN_sparc64= fails to compile: implicit declaration of function outb
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
diff --git a/comms/uarduno/Makefile b/comms/uarduno/Makefile
index 6b725473c55f..e4c8f5d0276a 100644
--- a/comms/uarduno/Makefile
+++ b/comms/uarduno/Makefile
@@ -12,6 +12,8 @@ COMMENT= FreeBSD Kernel Driver for the Arduino Uno USB interface
LICENSE= BSD4CLAUSE
+BROKEN_powerpc64= fails to compile: pcpu.h: error: size of array '__assert_0' is negative
+
USES= kmod uidfix
# some test targets need a predictable source directory