aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-27 22:12:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-27 22:12:09 +0000
commit18dd6954f3060c12b7882f4cb2a1f68dbfc0f102 (patch)
tree51edb00936e1a3da263df313cad16c1fa2858d19 /comms
parenteb37a12fc9841da5f3a397814fbb99436d82a988 (diff)
- Add common code to support for cmake based ports.
- Update devel/cmake to 2.6.0 (also fix ports/123092) - Use the new CMAKE build framework in all ports using cmake Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=213789
Diffstat (limited to 'comms')
-rw-r--r--comms/gammu-devel/Makefile12
-rw-r--r--comms/gammu/Makefile12
2 files changed, 6 insertions, 18 deletions
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 2fe8cb7d92d7..c07a0a92f137 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -14,13 +14,11 @@ MASTER_SITES= ftp://dl.cihar.com/gammu/releases/ \
MAINTAINER= bsam@FreeBSD.org
COMMENT= GNU All Mobile Management Utilities
-BUILD_DEPENDS+= cmake:${PORTSDIR}/devel/cmake
RUN_DEPENDS= cdialog:${PORTSDIR}/devel/cdialog
-CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING=Release \
- -DCMAKE_INSTALL_PREFIX=${PREFIX} \
- -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
+CMAKE_ARGS+= -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
+USE_CMAKE= yes
USE_GNOME= pkgconfig
.if defined(NOPORTDOCS)
@@ -30,14 +28,10 @@ MAN1= gammu.1 gammu-config.1 jadmaker.1
PORTDOCS= *
.endif
-do-configure:
- @(cd ${WRKSRC}; \
- ${LOCALBASE}/bin/cmake ${CMAKE_ARGS})
- @${REINPLACE_CMD} -i '' -e 's:bash:sh:' -e 's:dialog:cdialog:' ${WRKSRC}/utils/gammu-config
-
.include <bsd.port.pre.mk>
post-patch:
+ @${REINPLACE_CMD} -i '' -e 's:bash:sh:' -e 's:dialog:cdialog:' ${WRKSRC}/utils/gammu-config
.if ${OSVERSION} < 700042
@${REINPLACE_CMD} -e 's@ -Wno-pointer-sign@@g' ${WRKSRC}/CMakeLists.txt
.endif
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 2fe8cb7d92d7..c07a0a92f137 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -14,13 +14,11 @@ MASTER_SITES= ftp://dl.cihar.com/gammu/releases/ \
MAINTAINER= bsam@FreeBSD.org
COMMENT= GNU All Mobile Management Utilities
-BUILD_DEPENDS+= cmake:${PORTSDIR}/devel/cmake
RUN_DEPENDS= cdialog:${PORTSDIR}/devel/cdialog
-CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING=Release \
- -DCMAKE_INSTALL_PREFIX=${PREFIX} \
- -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
+CMAKE_ARGS+= -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
+USE_CMAKE= yes
USE_GNOME= pkgconfig
.if defined(NOPORTDOCS)
@@ -30,14 +28,10 @@ MAN1= gammu.1 gammu-config.1 jadmaker.1
PORTDOCS= *
.endif
-do-configure:
- @(cd ${WRKSRC}; \
- ${LOCALBASE}/bin/cmake ${CMAKE_ARGS})
- @${REINPLACE_CMD} -i '' -e 's:bash:sh:' -e 's:dialog:cdialog:' ${WRKSRC}/utils/gammu-config
-
.include <bsd.port.pre.mk>
post-patch:
+ @${REINPLACE_CMD} -i '' -e 's:bash:sh:' -e 's:dialog:cdialog:' ${WRKSRC}/utils/gammu-config
.if ${OSVERSION} < 700042
@${REINPLACE_CMD} -e 's@ -Wno-pointer-sign@@g' ${WRKSRC}/CMakeLists.txt
.endif