aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-08 21:49:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-08 21:49:42 +0000
commit5cba629e2ea4b6cff711862d804739ca5d767ea0 (patch)
treeb63ab0a4249a70d1c2a39c9dafa82c9cba050475 /comms
parentdae716f409b9523221e695c999bbfae04963d53a (diff)
downloadports-5cba629e2ea4b6cff711862d804739ca5d767ea0.tar.gz
ports-5cba629e2ea4b6cff711862d804739ca5d767ea0.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/py-gammu/Makefile27
-rw-r--r--comms/py-gammu/distinfo3
-rw-r--r--comms/py-gammu/pkg-descr7
-rw-r--r--comms/py-gammu/pkg-plist11
5 files changed, 49 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 9f0678620f40..e794639cd706 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -100,6 +100,7 @@
SUBDIR += pr
SUBDIR += predict
SUBDIR += py-bulksms
+ SUBDIR += py-gammu
SUBDIR += py-lirc
SUBDIR += py-serial
SUBDIR += pyla
diff --git a/comms/py-gammu/Makefile b/comms/py-gammu/Makefile
new file mode 100644
index 000000000000..08713183294f
--- /dev/null
+++ b/comms/py-gammu/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-gammu
+# Date created: 03 Feb,2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gammu
+PORTVERSION= 0.28
+CATEGORIES= comms python
+MASTER_SITES= http://dl.cihar.com/python-gammu/latest/ \
+ http://mirror.clickcreations.com/python-gammu/latest/ \
+ http://dl.cihar.com.nyud.net/python-gammu/latest/ \
+ ftp://dl.cihar.com/python-gammu/latest/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python bindings for Gammu library
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/gammu:${PORTSDIR}/comms/gammu
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python_${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/comms/py-gammu/distinfo b/comms/py-gammu/distinfo
new file mode 100644
index 000000000000..0e217993fa05
--- /dev/null
+++ b/comms/py-gammu/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-gammu-0.28.tar.gz) = 3fbf329b433808c0af7a67528b559176
+SHA256 (python-gammu-0.28.tar.gz) = 9fce80feda7adafa0397203a8b08713614bbacbf00d89984362bee7b479e123b
+SIZE (python-gammu-0.28.tar.gz) = 91785
diff --git a/comms/py-gammu/pkg-descr b/comms/py-gammu/pkg-descr
new file mode 100644
index 000000000000..d834c1ec7ad0
--- /dev/null
+++ b/comms/py-gammu/pkg-descr
@@ -0,0 +1,7 @@
+py-gammu is a python bindings for Gammu library, which allows
+access many phones. It currently does not support all Gammu
+features, but range of covered functions is increasing, if you
+need some specific, feel free to use bug tracking system for
+feature requests.
+
+WWW: http://cihar.com/gammu/python/
diff --git a/comms/py-gammu/pkg-plist b/comms/py-gammu/pkg-plist
new file mode 100644
index 000000000000..f3e52882b073
--- /dev/null
+++ b/comms/py-gammu/pkg-plist
@@ -0,0 +1,11 @@
+%%PYTHON_SITELIBDIR%%/gammu/Core.so
+%%PYTHON_SITELIBDIR%%/gammu/Data.py
+%%PYTHON_SITELIBDIR%%/gammu/Data.pyc
+%%PYTHON_SITELIBDIR%%/gammu/Data.pyo
+%%PYTHON_SITELIBDIR%%/gammu/Worker.py
+%%PYTHON_SITELIBDIR%%/gammu/Worker.pyc
+%%PYTHON_SITELIBDIR%%/gammu/Worker.pyo
+%%PYTHON_SITELIBDIR%%/gammu/__init__.py
+%%PYTHON_SITELIBDIR%%/gammu/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gammu/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/gammu