aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2017-01-05 14:40:09 +0000
committerDiane Bruce <db@FreeBSD.org>2017-01-05 14:40:09 +0000
commita9b5204fec694656bbe3b533ee972c953045bdbb (patch)
tree2e08c752085bc7d820fee1900ea32ccccfd42f89 /comms
parent646b57cc565399fe441a529ef0889a11ea51ff67 (diff)
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/wsjtx/Makefile19
-rw-r--r--comms/wsjtx/distinfo7
-rw-r--r--comms/wsjtx/files/patch-CMakeLists.txt70
-rw-r--r--comms/wsjtx/files/patch-Configuration.cpp4
-rw-r--r--comms/wsjtx/files/patch-Radio.cpp6
-rw-r--r--comms/wsjtx/files/patch-WFPalette.hpp2
-rw-r--r--comms/wsjtx/files/patch-lib_wsprd_Makefile12
-rw-r--r--comms/wsjtx/files/patch-manpages_CMakeLists.txt8
-rw-r--r--comms/wsjtx/pkg-plist8
9 files changed, 87 insertions, 49 deletions
diff --git a/comms/wsjtx/Makefile b/comms/wsjtx/Makefile
index 27fa7b5551cb..58b7d7e49a5c 100644
--- a/comms/wsjtx/Makefile
+++ b/comms/wsjtx/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= wsjtx
-PORTVERSION= 1.6.0
-PORTREVISION= 1
+PORTVERSION= 1.7.0
CATEGORIES= comms hamradio
MASTER_SITES= SF/wsjt/${PORTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
@@ -12,22 +11,28 @@ COMMENT= Weak signal ham radio communication package
LICENSE= GPLv3
-BUILD_DEPENDS= a2x:textproc/asciidoc \
- ${LOCALBASE}/share/xsl/docbook:textproc/docbook-xsl
+BUILD_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor \
+ a2x:textproc/asciidoc \
+ ${LOCALBASE}/share/xsl/docbook:textproc/docbook-xsl
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libhamlib.so:comms/hamlib \
- libxslt.so:textproc/libxslt
-RUN_DEPENDS= ${LOCALBASE}/bin/kvasd:comms/kvasd
+ libxslt.so:textproc/libxslt \
+ libomp.so:devel/openmp
MAKE_JOBS_UNSAFE= yes
USE_GL= yes
USE_QT5= gui buildtools qmake_build widgets multimedia concurrent serialport
USES= cmake compiler:c++11-lib dos2unix fortran pkgconfig tar:tgz
CMAKE_ARGS+= -DPORT_BUILDING::STRING="ON" \
- -DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib
+ -DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib \
+ -DLOCALBASE::STRING="${LOCALBASE}"
WRKSRC= ${WRKDIR}/${PORTNAME}
+#
+# This nonsense is because wsjtx is shipped with a copy of hamlib
+# as well as wsjtx
+#
do-extract:
${TAR} xf ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} -C${WRKDIR}
${TAR} xf ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/wsjtx.tgz -C${WRKDIR}
diff --git a/comms/wsjtx/distinfo b/comms/wsjtx/distinfo
index e2e24c442fb7..14da98dacc83 100644
--- a/comms/wsjtx/distinfo
+++ b/comms/wsjtx/distinfo
@@ -1,4 +1,3 @@
-SHA256 (wsjtx-1.6.0.tgz) = 2dc2563827146b0009ab75f0bf45771bf2530cfcd8a341a93bc6958d238f86f2
-SIZE (wsjtx-1.6.0.tgz) = 12537071
-SHA256 (wsjtx-main-1.6.0.html) = eea98304686db562f35c8aa98dc431d15c3ae4d8b2577c2cf402735ab02074dc
-SIZE (wsjtx-main-1.6.0.html) = 2606371
+TIMESTAMP = 1482183615
+SHA256 (wsjtx-1.7.0.tgz) = e7b3f31dad87b2b9cfb0a39bbba466f7039200541d37bfd181974fd11956a358
+SIZE (wsjtx-1.7.0.tgz) = 21293155
diff --git a/comms/wsjtx/files/patch-CMakeLists.txt b/comms/wsjtx/files/patch-CMakeLists.txt
index 3528f1fe7fa0..28c575020ed7 100644
--- a/comms/wsjtx/files/patch-CMakeLists.txt
+++ b/comms/wsjtx/files/patch-CMakeLists.txt
@@ -1,20 +1,25 @@
---- CMakeLists.txt.orig 2015-12-11 00:00:13 UTC
+--- CMakeLists.txt.orig 2017-01-05 12:39:50 UTC
+++ CMakeLists.txt
-@@ -93,6 +93,13 @@ if (CMAKE_BUILD_TYPE MATCHES "[Dd][Ee][B
+@@ -1,5 +1,4 @@
+ cmake_minimum_required (VERSION 2.8.10 FATAL_ERROR)
+-
+ if (APPLE)
+ #
+ # The following variables define the portability and compatability attributes of the Mac OS X build
+@@ -97,6 +96,12 @@ if (CMAKE_BUILD_TYPE MATCHES "[Dd][Ee][B
set (is_debug_build 1)
endif ()
+if (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
-+ set (FREEBSD 1)
++ set (FREEBSD TRUE)
++ link_directories("/usr/lib" "${LOCALBASE}/lib")
++ include_directories("/usr/lib" "${LOCALBASE}/include")
+endif()
+
-+if (FREEBSD)
-+ set (WSJT_INCLUDE_KVASD Off)
-+endif ()
#
# Options & features
-@@ -153,7 +160,14 @@ set (LIB_DESTINATION lib)
+@@ -161,7 +166,14 @@ set (INCLUDE_DESTINATION include)
set (SHARE_DESTINATION share)
set (DOC_DESTINATION doc/${CMAKE_PROJECT_NAME})
set (DATA_DESTINATION ${CMAKE_PROJECT_NAME})
@@ -30,24 +35,45 @@
set (PLUGIN_DESTINATION lib/plugins)
set (QT_CONF_DESTINATION bin)
-@@ -937,7 +951,13 @@ set_target_properties (wsjtx PROPERTIES
- MACOSX_BUNDLE_GUI_IDENTIFIER "org.k1jt.wsjtx"
- )
-
--target_link_libraries (wsjtx wsjt_fort wsjt_cxx wsjt_qt ${hamlib_LIBRARIES} ${FFTW3_LIBRARIES} Qt5::Multimedia)
-+if(FREEBSD)
-+ set (extraLIBS "ltdl" "usb")
+@@ -721,7 +733,20 @@ find_program(ETAGS etags)
+ #
+ # OpenMP
+ #
+-find_package (OpenMP)
++message (status "ZZZ About to find_package (OpenMP)")
++# OpenMP_C_FLAGS - flags to add to the C compiler for OpenMP support
++# OpenMP_CXX_FLAGS - flags to add to the CXX compiler for OpenMP support
++# OpenMP_Fortran_FLAGS - flags to add to the Fortran compiler for OpenMP support
++# OPENMP_FOUND - true if openmp is detected
++
++if (FREEBSD)
++ set (OpenMP_C_FLAGS "-openmp")
++ set (OpenMP_CXX_FLAGS "-openmp")
++ set (OpenMP_Fortran_FLAGS "-openmp")
++ set (OPENMP_FOUND TRUE)
+else()
-+ set (extraLIBS "")
++ find_package (OpenMP)
+endif()
-+
-+target_link_libraries (wsjtx wsjt_fort wsjt_cxx wsjt_qt ${hamlib_LIBRARIES} ${extraLIBS} ${FFTW3_LIBRARIES} Qt5::Multimedia)
- qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
- add_resources (message_aggregator_RESOURCES /qss ${message_aggregator_STYLESHEETS})
-@@ -1011,20 +1031,6 @@ else (WSJT_INCLUDE_KVASD)
- endif (APPLE)
- endif (WSJT_INCLUDE_KVASD)
+ #
+ # fftw3 single precision library
+@@ -1132,6 +1157,13 @@ if (APPLE)
+ target_link_libraries (wsjtx wsjt_fort wsjt_cxx wsjt_qt wsjt_qtmm ${hamlib_LIBRARIES} ${FFTW3_LIBRARIES})
+ else ()
+ target_link_libraries (wsjtx wsjt_fort_omp wsjt_cxx wsjt_qt wsjt_qtmm ${hamlib_LIBRARIES} ${FFTW3_LIBRARIES})
++
++ if(FREEBSD)
++ set (extraLIBS "ltdl" "usb")
++ else()
++ set (extraLIBS "")
++ endif()
++
+ set_target_properties (wsjtx PROPERTIES
+ COMPILE_FLAGS "${OpenMP_C_FLAGS}"
+ LINK_FLAGS "${OpenMP_C_FLAGS}"
+@@ -1232,20 +1264,6 @@ install (TARGETS jt9 jt65code qra64code
+ BUNDLE DESTINATION ${WSJT_BIN_DESTINATION} COMPONENT runtime
+ )
-install (PROGRAMS
- ${RIGCTL_EXE}
diff --git a/comms/wsjtx/files/patch-Configuration.cpp b/comms/wsjtx/files/patch-Configuration.cpp
index 11c5a96b285f..9d66d578b48d 100644
--- a/comms/wsjtx/files/patch-Configuration.cpp
+++ b/comms/wsjtx/files/patch-Configuration.cpp
@@ -1,6 +1,6 @@
---- Configuration.cpp.orig 2015-12-11 00:00:14 UTC
+--- Configuration.cpp.orig 2017-01-05 12:39:49 UTC
+++ Configuration.cpp
-@@ -2507,13 +2507,13 @@ void Configuration::impl::fill_port_comb
+@@ -2548,13 +2548,13 @@ void Configuration::impl::fill_port_comb
auto Configuration::impl::apply_calibration (Frequency f) const -> Frequency
{
diff --git a/comms/wsjtx/files/patch-Radio.cpp b/comms/wsjtx/files/patch-Radio.cpp
index dce8d69c8f46..7ce1b1d8546c 100644
--- a/comms/wsjtx/files/patch-Radio.cpp
+++ b/comms/wsjtx/files/patch-Radio.cpp
@@ -1,6 +1,6 @@
---- Radio.cpp.orig 2015-12-11 00:00:13 UTC
+--- Radio.cpp.orig 2017-01-05 12:39:50 UTC
+++ Radio.cpp
-@@ -33,7 +33,7 @@ namespace Radio
+@@ -30,7 +30,7 @@ namespace Radio
{
value = v.toDouble ();
}
@@ -9,7 +9,7 @@
}
FrequencyDelta frequency_delta (QVariant const& v, int scale, QLocale const& locale)
-@@ -47,7 +47,7 @@ namespace Radio
+@@ -44,7 +44,7 @@ namespace Radio
{
value = v.toDouble ();
}
diff --git a/comms/wsjtx/files/patch-WFPalette.hpp b/comms/wsjtx/files/patch-WFPalette.hpp
index 44e179bd833f..f75a3b7e3ca2 100644
--- a/comms/wsjtx/files/patch-WFPalette.hpp
+++ b/comms/wsjtx/files/patch-WFPalette.hpp
@@ -1,4 +1,4 @@
---- WFPalette.hpp.orig 2015-12-11 00:00:14 UTC
+--- WFPalette.hpp.orig 2017-01-05 12:39:50 UTC
+++ WFPalette.hpp
@@ -5,6 +5,7 @@
#include <QList>
diff --git a/comms/wsjtx/files/patch-lib_wsprd_Makefile b/comms/wsjtx/files/patch-lib_wsprd_Makefile
index 7a92ce29727d..c6d9580d8ffb 100644
--- a/comms/wsjtx/files/patch-lib_wsprd_Makefile
+++ b/comms/wsjtx/files/patch-lib_wsprd_Makefile
@@ -1,16 +1,18 @@
---- lib/wsprd/Makefile.orig 2015-12-11 00:00:13 UTC
+--- lib/wsprd/Makefile.orig 2017-01-05 14:17:58 UTC
+++ lib/wsprd/Makefile
-@@ -1,9 +1,9 @@
+@@ -1,10 +1,10 @@
-CC = gcc
+#CC = gcc
- #CC = clang
+ #CC = clang-3.5
-FC = gfortran
+#FC = gfortran
-CFLAGS= -I/usr/include -Wall -Wno-missing-braces -O3 -ffast-math
-LDFLAGS = -L/usr/lib
-+CFLAGS= -Wno-missing-braces -O3 -ffast-math
+-FFLAGS = -O2 -Wall -Wno-conversion
++#CFLAGS= -I/usr/include -Wall -Wno-missing-braces -O3 -ffast-math
+#LDFLAGS = -L/usr/lib
- LIBS = -lfftw3 -lm
++#FFLAGS = -O2 -Wall -Wno-conversion
+ LIBS = -lfftw3f -lm
# Default rules
diff --git a/comms/wsjtx/files/patch-manpages_CMakeLists.txt b/comms/wsjtx/files/patch-manpages_CMakeLists.txt
index 5df0b01e3b12..15aa8662cdb4 100644
--- a/comms/wsjtx/files/patch-manpages_CMakeLists.txt
+++ b/comms/wsjtx/files/patch-manpages_CMakeLists.txt
@@ -1,11 +1,11 @@
---- manpages/CMakeLists.txt.orig 2015-12-11 00:00:14 UTC
+--- manpages/CMakeLists.txt.orig 2017-01-05 12:39:52 UTC
+++ manpages/CMakeLists.txt
-@@ -1,8 +1,6 @@
- set (ASCIIDOC_MANS
+@@ -2,8 +2,6 @@ set (ASCIIDOC_MANS
man1/wsjtx.1.txt
+ man1/wsprd.1.txt
man1/jt65code.1.txt
- man1/rigctl-wsjtx.1.txt
- man1/rigctld-wsjtx.1.txt
man1/message_aggregator.1.txt
+ man1/udp_daemon.1.txt
)
-
diff --git a/comms/wsjtx/pkg-plist b/comms/wsjtx/pkg-plist
index c86d98bd5cc6..05205b745a4c 100644
--- a/comms/wsjtx/pkg-plist
+++ b/comms/wsjtx/pkg-plist
@@ -3,6 +3,10 @@ bin/jt65code
bin/jt9
bin/jt9code
bin/message_aggregator
+bin/msk144code
+bin/qra64code
+bin/qra64sim
+bin/udp_daemon
bin/wsjtx
bin/wsprd
man/man1/jt4code.1.gz
@@ -10,8 +14,10 @@ man/man1/jt65code.1.gz
man/man1/jt9.1.gz
man/man1/jt9code.1.gz
man/man1/message_aggregator.1.gz
+man/man1/udp_daemon.1.gz
man/man1/wsjtx.1.gz
man/man1/wsprd.1.gz
+share/applications/message_aggregator.desktop
share/applications/wsjtx.desktop
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/BUGS
@@ -22,6 +28,6 @@ share/applications/wsjtx.desktop
%%DOCSDIR%%/THANKS
%%DOCSDIR%%/changelog.Debian.gz
%%DOCSDIR%%/copyright
-%%DOCSDIR%%/wsjtx-main-1.6.0.html
+%%DOCSDIR%%/wsjtx-main-1.7.0.html
share/pixmaps/wsjtx_icon.png
%%DATADIR%%/JPLEPH