aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2019-08-17 22:16:54 +0000
committerDiane Bruce <db@FreeBSD.org>2019-08-17 22:16:54 +0000
commitb8880049868c9c614731f88db6b6e52db2dd4436 (patch)
treebe0197a8ac9fbe702ca991dfbc05cfc7b76f7222 /comms
parent7e966e571b86dcdca3f3f3e85da75d0b07eac932 (diff)
downloadports-b8880049868c9c614731f88db6b6e52db2dd4436.tar.gz
ports-b8880049868c9c614731f88db6b6e52db2dd4436.zip
Unbreak on non head FreeBSD
Use latest clang on all versions of FreeBSD Submitted by: pkg-fallout
Notes
Notes: svn path=/head/; revision=509183
Diffstat (limited to 'comms')
-rw-r--r--comms/gnuradio/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index e7db8a94d62d..ea1c6e119ed7 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -31,7 +31,8 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
minixmlto:textproc/minixmlto \
sdl-config:devel/sdl12 \
swig3.0:devel/swig30 \
- xdg-open:devel/xdg-utils
+ xdg-open:devel/xdg-utils \
+ ${LOCALBASE}/bin/clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
LIB_DEPENDS= libcodec2.so:audio/codec2 \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
@@ -49,11 +50,7 @@ LIB_DEPENDS= libcodec2.so:audio/codec2 \
libzmq.so:net/libzmq4
RUN_DEPENDS:= ${BUILD_DEPENDS}
-# USES=compiler:c11 is necessary because base GCC fails:
-# volk/lib/volk_cpu.c: In function 'i_can_has_3dnow':
-# volk/lib/volk_cpu.c:62: error: can't find a register in class 'BREG' while reloading 'asm'
-# volk/lib/volk_cpu.c:62: error: 'asm' operand has impossible constraints
-USES= cmake compiler:c11 desktop-file-utils fortran gnome iconv \
+USES= cmake desktop-file-utils fortran gnome iconv \
perl5 pkgconfig pyqt:5 python:2.7 qt:5 shared-mime-info shebangfix
SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in \
@@ -71,10 +68,14 @@ CMAKE_ARGS+= -DCMAKE_INSTALL_RPATH:STRING="${LOCALBASE}/lib/gcc${_GCC_VER}" \
-DXMLTO_EXECUTABLE:STRING=minixmlto
# for detailed debugging uncomment the next line
#CMAKE_ARGS+= --debug-output --trace
+USE_CXXSTD= c++11
USE_GNOME= pygtk2
USE_PYQT= core gui opengl
USE_WX= 3.0
USE_QT= buildtools core gui xml qmake widgets
+CPP= ${LOCALBASE}/bin/clang-cpp${LLVM_DEFAULT}
+CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_DEFAULT}
WX_COMPS= wx wx:build wx:run python:build python:run
USE_LDCONFIG= yes
LIBSTRIP_FILES= analog audio blocks channels digital dtv fec fft\