aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-08-21 18:12:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-08-21 18:12:08 +0000
commit06e6ff3128cb562e5b9783d72c1d933db92d864e (patch)
tree6e90c68cdee150cf5069ba28ab3580465c9f2e30 /comms
parent435b5782a63e153317611b97a52c0aae28e774b0 (diff)
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/kermit/Makefile19
-rw-r--r--comms/kermit/distinfo4
-rw-r--r--comms/kermit/files/patch-ck__crp.c25
-rw-r--r--comms/kermit/files/patch-ckutio.c21
4 files changed, 6 insertions, 63 deletions
diff --git a/comms/kermit/Makefile b/comms/kermit/Makefile
index d3d7dc2f741b..67e764df2365 100644
--- a/comms/kermit/Makefile
+++ b/comms/kermit/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= kermit
-PORTVERSION= 9.0.301
+PORTVERSION= 9.0.302
CATEGORIES= comms
MASTER_SITES= ftp://kermit.columbia.edu/kermit/archives/ \
ftp://ftp.icm.edu.pl/pub/kermit/archives/
DISTNAME= cku${PORTVERSION:E}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Combined network and serial communication package
+COMMENT= Portable scriptable network and serial communication program
LICENSE= BSD
@@ -22,25 +22,14 @@ NO_WRKSUBDIR= yes
MAKEFILE= makefile
ALL_TARGET= freebsd+ssl
MAKE_ARGS= CC2=${CC} SSLINC=-I${OPENSSLINC} SSLLIB=-L${OPENSSLLIB}
-CFLAGS+= -DHERALD=\\\"\\\\\\\" ${HERALD}\\\\\\\"\\\"
PLIST_FILES= bin/kermit
PORTDOCS= *
PORTEXAMPLES= *
MAN1= kermit.1
-.include <bsd.port.pre.mk>
-
-# Explicitly pass version of our beloved OS until upstream code is fixed
-HERALD!= ${UNAME} -sr
-
post-patch:
- @${REINPLACE_CMD} -e 's,-O -pipe,${CFLAGS},' ${WRKSRC}/${MAKEFILE}
-# Catch up with recent <utmp.h> replacement by <utmpx.h>
-.if ${OSVERSION} > 900006
- @${REINPLACE_CMD} -e 's,ut\.ut_name,ut.ut_user,g' \
- -e 's,UNIXWARE,FREEBSD4,' ${WRKSRC}/ckufio.c
-.endif
+ @${REINPLACE_CMD} -e 's,-O2 -pipe,${CFLAGS},' ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wermit ${PREFIX}/bin/kermit
@@ -56,4 +45,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ckermod.ini ${EXAMPLESDIR}/dot.mykermrc
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/kermit/distinfo b/comms/kermit/distinfo
index f36dc5245c2b..37540059ce46 100644
--- a/comms/kermit/distinfo
+++ b/comms/kermit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cku301.tar.gz) = 9793eb125f8936b079c6d7e5c3d2ff885cfedc07f9d2dd1e7db928e3029a211a
-SIZE (cku301.tar.gz) = 3120826
+SHA256 (cku302.tar.gz) = 0d5f2cd12bdab9401b4c836854ebbf241675051875557783c332a6a40dac0711
+SIZE (cku302.tar.gz) = 3122219
diff --git a/comms/kermit/files/patch-ck__crp.c b/comms/kermit/files/patch-ck__crp.c
deleted file mode 100644
index 760bf8dc9c05..000000000000
--- a/comms/kermit/files/patch-ck__crp.c
+++ /dev/null
@@ -1,25 +0,0 @@
-
-$FreeBSD$
-
---- ck_crp.c.orig Tue Jun 25 17:53:02 2002
-+++ ck_crp.c Tue Mar 4 15:14:45 2003
-@@ -396,7 +396,7 @@
- des_new_random_key(Block B)
- {
- int rc=0;
-- rc = des_random_key(B);
-+ des_random_key(B);
- return(rc);
- }
-
-@@ -467,8 +467,8 @@
- * These function pointers point to the current routines
- * for encrypting and decrypting data.
- */
--static VOID (*encrypt_output) P((unsigned char *, int));
--static int (*decrypt_input) P((int));
-+VOID (*encrypt_output) P((unsigned char *, int));
-+int (*decrypt_input) P((int));
-
- #ifdef DEBUG
- static int encrypt_debug_mode = 1;
diff --git a/comms/kermit/files/patch-ckutio.c b/comms/kermit/files/patch-ckutio.c
deleted file mode 100644
index 8c42d0573cde..000000000000
--- a/comms/kermit/files/patch-ckutio.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- ckutio.c.orig
-+++ ckutio.c
-@@ -4879,8 +4879,18 @@
- #ifdef USETTYLOCK
- haslock = 0; /* Not locked yet. */
- *flfnam = '\0'; /* Lockfile name is empty. */
-+#ifdef __FreeBSD__
-+ char *devname;
-+ if ((devname = xxlast(ttdev,'/')) != NULL)
-+#if __FreeBSD_version < 800045
-+ ckstrncpy(lockname,devname+1,DEVNAMLEN);
-+#else
-+ ckstrncat(lockname,devname+1,DEVNAMLEN-ckstrncpy(lockname,"pts",4));
-+#endif
-+#else
- if (!strncmp(ttdev,"/dev/",5) && ttdev[5])
- ckstrncpy(lockname,ttdev+5,DEVNAMLEN);
-+#endif
- else
- ckstrncpy(lockname,ttdev,DEVNAMLEN);
- /*