aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-08-17 08:29:07 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-08-17 08:29:07 +0000
commit35cb1975e5d5ea8a9c04c38f1dd2f7fab3a71500 (patch)
tree0eaf7034a6c6a3ccca054c337a376b3c22a8e442 /comms
parent887b50e116e86c4c613d455d97c3f524c4a05f40 (diff)
downloadports-35cb1975e5d5ea8a9c04c38f1dd2f7fab3a71500.tar.gz
ports-35cb1975e5d5ea8a9c04c38f1dd2f7fab3a71500.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/ruby-serialport/Makefile1
-rw-r--r--comms/ruby-serialport/files/patch-ext::impl::posix_serialport.c20
-rw-r--r--comms/ruby-serialport/files/patch-ext::serialport.c42
3 files changed, 63 insertions, 0 deletions
diff --git a/comms/ruby-serialport/Makefile b/comms/ruby-serialport/Makefile
index fe81fd305882..6a0410617edf 100644
--- a/comms/ruby-serialport/Makefile
+++ b/comms/ruby-serialport/Makefile
@@ -7,6 +7,7 @@
PORTNAME= serialport
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= comms ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= ruby-${PORTNAME}
diff --git a/comms/ruby-serialport/files/patch-ext::impl::posix_serialport.c b/comms/ruby-serialport/files/patch-ext::impl::posix_serialport.c
new file mode 100644
index 000000000000..5cfae2d38cc3
--- /dev/null
+++ b/comms/ruby-serialport/files/patch-ext::impl::posix_serialport.c
@@ -0,0 +1,20 @@
+--- ext/impl/posix_serialport.c.orig 2009-07-30 11:59:13.000000000 +0400
++++ ext/impl/posix_serialport.c 2009-07-30 12:07:49.000000000 +0400
+@@ -568,7 +568,7 @@
+ return Qnil;
+ }
+
+-static void get_line_signals_helper_impl(obj, ls)
++static void get_line_signals_helper(obj, ls)
+ VALUE obj;
+ struct line_signals *ls;
+ {
+@@ -589,7 +589,7 @@
+ ls->ri = (status & TIOCM_RI ? 1 : 0);
+ }
+
+-static VALUE set_signal_impl(obj, val, sig)
++static VALUE set_signal(obj, val, sig)
+ VALUE obj,val;
+ int sig;
+ {
diff --git a/comms/ruby-serialport/files/patch-ext::serialport.c b/comms/ruby-serialport/files/patch-ext::serialport.c
new file mode 100644
index 000000000000..7c627cf6b111
--- /dev/null
+++ b/comms/ruby-serialport/files/patch-ext::serialport.c
@@ -0,0 +1,42 @@
+--- ext/serialport.c.orig 2009-07-30 12:57:44.000000000 +0400
++++ ext/serialport.c 2009-07-30 13:00:20.000000000 +0400
+@@ -126,6 +126,7 @@
+ * Set the state (0 or 1) of the DTR line
+ */
+ static VALUE sp_set_dtr(self, val)
++ VALUE self, val;
+ {
+ return sp_set_dtr_impl(self, val);
+ }
+@@ -138,6 +139,7 @@
+ * supported.
+ */
+ static VALUE sp_set_flow_control(self, val)
++ VALUE self, val;
+ {
+ return sp_set_flow_control_impl(self, val);
+ }
+@@ -153,6 +155,7 @@
+ * Note: Read timeouts don't mix well with multi-threading.
+ */
+ static VALUE sp_set_read_timeout(self, val)
++ VALUE self, val;
+ {
+ return sp_set_read_timeout_impl(self, val);
+ }
+@@ -161,6 +164,7 @@
+ * Set the state (0 or 1) of the RTS line
+ */
+ static VALUE sp_set_rts(self, val)
++ VALUE self, val;
+ {
+ return sp_set_rts_impl(self, val);
+ }
+@@ -171,6 +175,7 @@
+ * Note: Under Posix, write timeouts are not implemented.
+ */
+ static VALUE sp_set_write_timeout(self, val)
++ VALUE self, val;
+ {
+ return sp_set_write_timeout_impl(self, val);
+ }