aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-02-28 05:13:23 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-02-28 05:13:23 +0000
commit6dd92cbbfcde421e1f2b145a0a10adcfb5da7239 (patch)
tree34bebf2d438eaecc4a91c99035024ce49f492309 /comms
parent406f08f7967b7c90bb7f80d02f182f5f8d55487c (diff)
downloadports-6dd92cbbfcde421e1f2b145a0a10adcfb5da7239.tar.gz
ports-6dd92cbbfcde421e1f2b145a0a10adcfb5da7239.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/libimobiledevice/Makefile63
-rw-r--r--comms/libimobiledevice/distinfo2
-rw-r--r--comms/libimobiledevice/pkg-descr11
-rw-r--r--comms/libimobiledevice/pkg-plist24
5 files changed, 101 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 8019becf8fc2..c471255f7837 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -68,6 +68,7 @@
SUBDIR += kpsk
SUBDIR += ktrack
SUBDIR += libfec
+ SUBDIR += libimobiledevice
SUBDIR += libirman
SUBDIR += libsyncml
SUBDIR += libticables
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
new file mode 100644
index 000000000000..19ac211ee77a
--- /dev/null
+++ b/comms/libimobiledevice/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: libimobiledevice
+# Date created: 10 June 2010
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= libimobiledevice
+PORTVERSION= 1.0.4
+CATEGORIES= comms
+MASTER_SITES= http://www.${PORTNAME}.org/downloads/
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= A library to communicate with Apple iPhone/iPod Touch devices
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+LIB_DEPENDS= gnutls.40:${PORTSDIR}/security/gnutls \
+ tasn1.4:${PORTSDIR}/security/libtasn1 \
+ gcrypt.17:${PORTSDIR}/security/libgcrypt \
+ plist.1:${PORTSDIR}/devel/libplist \
+ usbmuxd.1:${PORTSDIR}/comms/usbmuxd
+
+USE_BZIP2= yes
+USE_GNOME= glib20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
+CFLAGS+= -I${LOCALBASE}/include
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS NEWS README
+
+MAN1= idevice_id.1 idevicebackup.1 \
+ ideviceimagemounter.1 ideviceinfo.1 \
+ idevicescreenshot.1 idevicesyslog.1
+
+#OPTIONS= PYTHON "Enable Python bindings (needs Swig)" off
+#
+#.include <bsd.port.options.mk>
+#
+#.ifdef(WITH_PYTHON)
+#BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+#USE_PYTHON= yes
+#PLIST_SUB+= PYTHON=""
+#.else
+CONFIGURE_ARGS+= --without-swig
+#PLIST_SUB+= PYTHON="@comment "
+#.endif
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/libimobiledevice/distinfo b/comms/libimobiledevice/distinfo
new file mode 100644
index 000000000000..e29cb6be4547
--- /dev/null
+++ b/comms/libimobiledevice/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libimobiledevice-1.0.4.tar.bz2) = 2b836f09b95c9cf644ac824647b66d823cd135c5e0d4a8fca863d5314734d046
+SIZE (libimobiledevice-1.0.4.tar.bz2) = 413573
diff --git a/comms/libimobiledevice/pkg-descr b/comms/libimobiledevice/pkg-descr
new file mode 100644
index 000000000000..0a4cd845ab1d
--- /dev/null
+++ b/comms/libimobiledevice/pkg-descr
@@ -0,0 +1,11 @@
+libimobiledevice is a software library that talks the protocols to
+support iPhone, iPod Touch and iPad devices on Linux. Unlike other
+projects, it does not depend on using any existing proprietary
+libraries and does not require jailbreaking. It allows other software
+to easily access the device's filesystem, retrieve information about
+the device and its internals, backup/restore the device, manage
+SpringBoard icons, manage installed applications, retrieve
+addressbook/calendars/notes and bookmarks and synchronize music and
+video to the device.
+
+WWW: http://www.libimobiledevice.org
diff --git a/comms/libimobiledevice/pkg-plist b/comms/libimobiledevice/pkg-plist
new file mode 100644
index 000000000000..f9eecb5ee6b8
--- /dev/null
+++ b/comms/libimobiledevice/pkg-plist
@@ -0,0 +1,24 @@
+bin/idevice_id
+bin/idevicebackup
+bin/ideviceimagemounter
+bin/ideviceinfo
+bin/idevicepair
+bin/idevicescreenshot
+bin/idevicesyslog
+include/libimobiledevice/afc.h
+include/libimobiledevice/file_relay.h
+include/libimobiledevice/installation_proxy.h
+include/libimobiledevice/libimobiledevice.h
+include/libimobiledevice/lockdown.h
+include/libimobiledevice/mobile_image_mounter.h
+include/libimobiledevice/mobilebackup.h
+include/libimobiledevice/mobilesync.h
+include/libimobiledevice/notification_proxy.h
+include/libimobiledevice/sbservices.h
+include/libimobiledevice/screenshotr.h
+lib/libimobiledevice.a
+lib/libimobiledevice.la
+lib/libimobiledevice.so
+lib/libimobiledevice.so.1
+libdata/pkgconfig/libimobiledevice-1.0.pc
+@dirrm include/libimobiledevice