aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-02-06 18:36:07 +0000
committerStefan Eßer <se@FreeBSD.org>2022-02-06 18:36:07 +0000
commitbdd2d4af9630fdc1157d49bd193e8195c3240e9e (patch)
treee678e8d84cfdd1c0af32fc60bf714cd79079be63 /comms
parent4212791c42598c6149ca279442c07b918d92bdbf (diff)
downloadports-bdd2d4af9630fdc1157d49bd193e8195c3240e9e.tar.gz
ports-bdd2d4af9630fdc1157d49bd193e8195c3240e9e.zip
Update CONFLICTS definitions in categories a* to c*
Update the CONFLICTS definitions of ports in the following categories: - accessibility - archivers - audio - benchmarks - biology - cad - chinese - comms - converters An attempt has been made to use generic conflicts patterns that do not have to be updated whenever a new version of a conflicting port is added to the ports system. There is a misunderstanding that the port being built/installed has to be omitted from the conflicts pattern. This is not true - the port being built is implicitly non-conflicting due to logic in bsd.port.mk. Approved by: portmgr (implicit)
Diffstat (limited to 'comms')
-rw-r--r--comms/libfec/Makefile2
-rw-r--r--comms/lrzsz/Makefile2
-rw-r--r--comms/openzwave-devel/Makefile2
-rw-r--r--comms/openzwave/Makefile2
-rw-r--r--comms/predict/Makefile2
-rw-r--r--comms/qico/Makefile2
-rw-r--r--comms/scmxx/Makefile2
-rw-r--r--comms/smstools3/Makefile2
-rw-r--r--comms/yagiuda/Makefile2
9 files changed, 17 insertions, 1 deletions
diff --git a/comms/libfec/Makefile b/comms/libfec/Makefile
index dc034926b6ff..81fa8674cf90 100644
--- a/comms/libfec/Makefile
+++ b/comms/libfec/Makefile
@@ -30,6 +30,8 @@ PLIST_FILES= include/fec.h \
# makefile tries to create libfec.so from object files compiled without -fPIC.
CFLAGS+= -fPIC
+CONFLICTS_INSTALL= reed-solomon simd-viterbi # man/man3/rs.3.gz man/man3/simd-viterbi.3.gz
+
post-patch:
@${CP} ${FILESDIR}/cpu_mode.c ${WRKSRC}
diff --git a/comms/lrzsz/Makefile b/comms/lrzsz/Makefile
index 3138d1365005..2e77798112c1 100644
--- a/comms/lrzsz/Makefile
+++ b/comms/lrzsz/Makefile
@@ -18,6 +18,8 @@ CPE_VENDOR= lrzsz_project
GNU_CONFIGURE= yes
ALL_TARGET= all # vcheck
+CONFLICTS_INSTALL= lrzip # bin/lrz
+
OPTIONS_DEFINE= NLS
NLS_USES= gettext
diff --git a/comms/openzwave-devel/Makefile b/comms/openzwave-devel/Makefile
index f10c134fb7a8..265ce076b0e2 100644
--- a/comms/openzwave-devel/Makefile
+++ b/comms/openzwave-devel/Makefile
@@ -24,6 +24,8 @@ GH_PROJECT= open-zwave
GH_TAGNAME= 14f2ba74
MAKE_ARGS= VERSION_REV=${VERSION_REV} LIBDIR=${WRKSRC} docdir=${DOCSDIR} CXX=${CXX}
+CONFLICTS_INSTALL= openzwave # bin/MinOZW
+
OPTIONS_DEFINE= DOXYGEN DOCS
OPTIONS_SUB= yes
diff --git a/comms/openzwave/Makefile b/comms/openzwave/Makefile
index 001c75e8ed4c..7603e155651a 100644
--- a/comms/openzwave/Makefile
+++ b/comms/openzwave/Makefile
@@ -21,6 +21,8 @@ GH_TAGNAME= f339aa6
CFLAGS+= -Wno-error
MAKE_ARGS= VERSION_REV=${PORTVERSION:E} LIBDIR=${WRKSRC}
+CONFLICTS_INSTALL= openzwave-devel # bin/MinOZW
+
OPTIONS_DEFINE= DOCS DOXYGEN
OPTIONS_SUB= yes
diff --git a/comms/predict/Makefile b/comms/predict/Makefile
index 7212cf4a9822..e31f0b4e7674 100644
--- a/comms/predict/Makefile
+++ b/comms/predict/Makefile
@@ -16,6 +16,8 @@ USES= ncurses
INSTALL_TARGET= install install.man
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" STAGEDIR="${STAGEDIR}"
+CONFLICTS_INSTALL= liblinear # bin/predict
+
post-patch:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/predict.h > ${WRKSRC}/predict.h
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/vocalizer.h > ${WRKSRC}/vocalizer/vocalizer.h
diff --git a/comms/qico/Makefile b/comms/qico/Makefile
index 117e0f064871..81c0444c826f 100644
--- a/comms/qico/Makefile
+++ b/comms/qico/Makefile
@@ -28,6 +28,8 @@ CONFIGURE_ARGS+= --with-config=${CONFDIR}/qico.conf \
--with-default-speed=115200
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFLICTS_INSTALL= qcc # bin/qcc
+
DOCS= Changes FAQ README
EXAMPLES= koi8r_866.cp onchat qhistory qico.xpm qlinks sfreq \
stat.run synctime test.pl tossing
diff --git a/comms/scmxx/Makefile b/comms/scmxx/Makefile
index 811d215455c2..106d8b824cc9 100644
--- a/comms/scmxx/Makefile
+++ b/comms/scmxx/Makefile
@@ -15,6 +15,8 @@ CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFLICTS_INSTALL= smi # bin/smi
+
DOCS= README docs/*.txt
EXAMPLES= sms.txt vCalendar.vcs vCard.vcf
diff --git a/comms/smstools3/Makefile b/comms/smstools3/Makefile
index 17475a3d9996..214f536a7b2a 100644
--- a/comms/smstools3/Makefile
+++ b/comms/smstools3/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libinotify.so:devel/libinotify
-CONFLICTS= gnokii smstools-2.* sendsms
+CONFLICTS_INSTALL= gnokii sendsms # bin/sendsms
OPTIONS_DEFINE= STATS UTF8 EXAMPLES DOCS
OPTIONS_DEFAULT= STATS UTF8
diff --git a/comms/yagiuda/Makefile b/comms/yagiuda/Makefile
index ffc810407e9d..7f6d6cf75d17 100644
--- a/comms/yagiuda/Makefile
+++ b/comms/yagiuda/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
+CONFLICTS_INSTALL= 4ti2 # bin/output
+
OPTIONS_DEFINE= DOCS
do-install: