aboutsummaryrefslogtreecommitdiff
path: root/converters/ascii2binary/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-03-05 08:29:04 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-03-05 08:29:04 +0000
commit6b1772db94efb5ad489d4a9f6b5dc801a1d3aeb1 (patch)
tree4bc49aa30b5b8baf857e94d79121d2c82dde40b8 /converters/ascii2binary/Makefile
parentd23d52d501a24b8047bd067dc3d507c974f074d7 (diff)
downloadports-6b1772db94efb5ad489d4a9f6b5dc801a1d3aeb1.tar.gz
ports-6b1772db94efb5ad489d4a9f6b5dc801a1d3aeb1.zip
Notes
Diffstat (limited to 'converters/ascii2binary/Makefile')
-rw-r--r--converters/ascii2binary/Makefile30
1 files changed, 6 insertions, 24 deletions
diff --git a/converters/ascii2binary/Makefile b/converters/ascii2binary/Makefile
index 66ff43f3a6a9..bc8d31cd3ff7 100644
--- a/converters/ascii2binary/Makefile
+++ b/converters/ascii2binary/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ascii2binary
-PORTVERSION= 2.8.1
+PORTVERSION= 2.9
CATEGORIES= converters
MASTER_SITES= http://billposer.org/Software/Downloads/
DISTNAME= ${PORTNAME}
@@ -16,33 +16,15 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Convert between textual representations of numbers and binary
-HAS_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- LIBS="-lintl"
-MAKE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- LIBS="-lintl"
-USE_GETTEXT= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PLIST_FILES= bin/ascii2binary bin/binary2ascii \
- %%NLS%%share/locale/fr/LC_MESSAGES/ascii2binary.mo
+PLIST_FILES= bin/ascii2binary bin/binary2ascii
MAN1= ascii2binary.1 binary2ascii.1
-.if defined(WITHOUT_NLS)
-PLIST_SUB= NLS="@comment "
-.else
-PLIST_SUB= NLS=""
-.endif
-
pre-configure:
-.if defined(WITHOUT_NLS)
- ${REINPLACE_CMD} -e 's|cp -r locale|#cp -r locale|' ${WRKSRC}/Makefile
-.endif
-
-post-install:
- @${FIND} ${PREFIX}/share/locale -name ascii2binary.po -delete
+ ${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" ${WRKSRC}/Makefile.in
.include <bsd.port.mk>