aboutsummaryrefslogtreecommitdiff
path: root/converters/cl-babel-clisp
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 15:01:08 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 15:01:08 +0000
commitcc174825618eb501afc021bea333e0ab2f0191d7 (patch)
treeec091baee488a130274074daf024ef869e39fc91 /converters/cl-babel-clisp
parentc7131cd5e3945056a93068b259fb6fb765eaac50 (diff)
downloadports-cc174825618eb501afc021bea333e0ab2f0191d7.tar.gz
ports-cc174825618eb501afc021bea333e0ab2f0191d7.zip
Notes
Diffstat (limited to 'converters/cl-babel-clisp')
-rw-r--r--converters/cl-babel-clisp/Makefile29
-rw-r--r--converters/cl-babel-clisp/pkg-descr6
2 files changed, 35 insertions, 0 deletions
diff --git a/converters/cl-babel-clisp/Makefile b/converters/cl-babel-clisp/Makefile
new file mode 100644
index 000000000000..e9fff7b015f6
--- /dev/null
+++ b/converters/cl-babel-clisp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: cl-babel-clisp
+# Date created: 20 January 2010
+# Whom: Jimmy Olgeni <olgeni@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= babel
+PORTVERSION= 2010.01.16
+CATEGORIES= converters lisp
+PKGNAMEPREFIX= cl-
+DISTFILES= # none
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A charset encoding/decoding library written in Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/babel/babel.asd:${PORTSDIR}/devel/cl-babel \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/clispfasl/src/tf-clisp.fasl:${PORTSDIR}/devel/cl-trivial-features-clisp \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-gray-streams/clispfasl/package.fasl:${PORTSDIR}/devel/cl-trivial-gray-streams-clisp
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/babel/babel.asd:${PORTSDIR}/devel/cl-babel \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/clispfasl/src/tf-clisp.fasl:${PORTSDIR}/devel/cl-trivial-features-clisp \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-gray-streams/clispfasl/package.fasl:${PORTSDIR}/devel/cl-trivial-gray-streams-clisp
+
+USE_ASDF_FASL= yes
+FASL_TARGET= clisp
+FASL_BUILD= yes
+ASDF_MODULES= babel babel-streams
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+.include <bsd.port.mk>
diff --git a/converters/cl-babel-clisp/pkg-descr b/converters/cl-babel-clisp/pkg-descr
new file mode 100644
index 000000000000..5f427f3b1a4d
--- /dev/null
+++ b/converters/cl-babel-clisp/pkg-descr
@@ -0,0 +1,6 @@
+Babel is a charset encoding/decoding library, not unlike GNU libiconv,
+but completely written in Common Lisp.
+
+This package is compiled with CLISP.
+
+WWW: http://www.cliki.net/Babel