aboutsummaryrefslogtreecommitdiff
path: root/converters/iconv
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 09:43:25 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 09:43:25 +0000
commit0b31d075bc0e27d93cf260d6dda0f3fbe47654e6 (patch)
treecc417f6c1e09adfeacf163534c572adfc3e479f7 /converters/iconv
parentfae245e621a47d9b5a1f044892b638c72a369b48 (diff)
downloadports-0b31d075bc0e27d93cf260d6dda0f3fbe47654e6.tar.gz
ports-0b31d075bc0e27d93cf260d6dda0f3fbe47654e6.zip
Notes
Diffstat (limited to 'converters/iconv')
-rw-r--r--converters/iconv/Makefile6
-rw-r--r--converters/iconv/files/patch-ai54
-rw-r--r--converters/iconv/files/patch-ces::Makefile14
-rw-r--r--converters/iconv/files/patch-util::Makefile24
-rw-r--r--converters/iconv/pkg-plist12
5 files changed, 98 insertions, 12 deletions
diff --git a/converters/iconv/Makefile b/converters/iconv/Makefile
index 22c19191a0e2..f1840e47df97 100644
--- a/converters/iconv/Makefile
+++ b/converters/iconv/Makefile
@@ -7,7 +7,7 @@
PORTNAME= iconv
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters
MASTER_SITES= http://www.dante.net/staff/konstantin/FreeBSD/iconv/
@@ -17,8 +17,8 @@ USE_PERL5= yes
INSTALLS_SHLIB= yes
MANCOMPRESSED= yes
-MAN1= iconv.1
-MAN3= iconv.3 iconv_open.3 iconv_close.3
+MAN1= biconv.1
+MAN3= biconv.3 biconv_open.3 biconv_close.3
.if defined(NOPROFILE)
PLIST_SUB= PROFILE:="@comment "
diff --git a/converters/iconv/files/patch-ai b/converters/iconv/files/patch-ai
index 14534137b3d2..07ee8b05b37e 100644
--- a/converters/iconv/files/patch-ai
+++ b/converters/iconv/files/patch-ai
@@ -1,6 +1,20 @@
---- lib/Makefile.orig Mon Nov 27 23:33:49 2000
-+++ lib/Makefile Thu Dec 7 15:23:52 2000
-@@ -10,8 +10,8 @@
+
+$FreeBSD$
+
+--- lib/Makefile.orig Tue Nov 28 01:33:49 2000
++++ lib/Makefile Sun Mar 17 13:12:04 2002
+@@ -1,27 +1,27 @@
+-LIB = iconv
++LIB = biconv
+ SHLIB_MAJOR = 2
+ SHLIB_MINOR = 0
+
+ SRCS = aliases.c ccs.c ces.c ces_euc.c ces_iso2022.c ces_table.c \
+- converter.c iconv.c utils.c
++ converter.c iconv.c utils.c biconv.h
+
+ BUILTIN_CCS != cd ${.CURDIR}/../ccs && make lib >/dev/null && ${AR} t libccs.a
+ BUILTIN_CES != cd ${.CURDIR}/../ces && make lib >/dev/null && ${AR} t libces.a
BUILTIN_CES_STATIC != cd ${.CURDIR}/../ces && make libces_static.a \
>/dev/null && ${AR} t libces_static.a
@@ -11,3 +25,37 @@
LIBDIR = ${PREFIX}/lib
+ INCDIR = ${PREFIX}/include
+-INCS = iconv.h
++INCS = biconv.h
+
+ CFLAGS += -DICONV_MODULE_PATH=\"${MODULEDIR}\" \
+ -DICONV_TABLE_PATH=\"${TABLEDIR}\"
+
+-MAN3 = iconv.3 iconv_open.3 iconv_close.3
++MAN3 = biconv.3 biconv_open.3 biconv_close.3
+
+ ALIASES = ${.CURDIR}/../ccs/charset.aliases \
+ ${.CURDIR}/../ces/charset.aliases
+@@ -32,13 +32,19 @@
+ cat ${.ALLSRC} | ${.CURDIR}/../iconv_builtin ${BUILTIN_CCS} \
+ ${BUILTIN_CES} PIC ${BUILTIN_CES_STATIC} > ${.TARGET}
+
+-iconv.3: iconv.3.in
++biconv.3: iconv.3.in
+ sed -e "s|@@TABLE_DIR@@|${TABLEDIR}|" \
+ -e "s|@@MODULE_DIR@@|${MODULEDIR}|" ${.ALLSRC} > ${.TARGET}
+
+-iconv_open.3: iconv_open.3.in
++biconv_open.3: iconv_open.3.in
+ sed -e "s|@@TABLE_DIR@@|${TABLEDIR}|" \
+ -e "s|@@MODULE_DIR@@|${MODULEDIR}|" ${.ALLSRC} > ${.TARGET}
++
++biconv_close.3: iconv_close.3
++ cp ${.ALLSRC} ${.TARGET}
++
++biconv.h: iconv.h
++ cp ${.ALLSRC} ${.TARGET}
+
+ CLEANFILES= ${.CURDIR}/../ccs/libccs.a ${.CURDIR}/../ces/libces*.a \
+ aliases.h iconv.3 iconv_open.3
diff --git a/converters/iconv/files/patch-ces::Makefile b/converters/iconv/files/patch-ces::Makefile
new file mode 100644
index 000000000000..0a5f39d11207
--- /dev/null
+++ b/converters/iconv/files/patch-ces::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ces/Makefile 2002/03/17 11:07:44 1.1
++++ ces/Makefile 2002/03/17 11:07:56
+@@ -10,7 +10,7 @@
+ LIB= ces
+ SRCS= ces_builtin.c ${CHARSETS_C}
+
+-LDADD = -L${.CURDIR}/../lib -liconv
++LDADD = -L${.CURDIR}/../lib -lbiconv
+
+ INTERNALLIB =
+
diff --git a/converters/iconv/files/patch-util::Makefile b/converters/iconv/files/patch-util::Makefile
new file mode 100644
index 000000000000..a57ae2b5bdd1
--- /dev/null
+++ b/converters/iconv/files/patch-util::Makefile
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- util/Makefile.orig Sun Sep 3 22:33:15 2000
++++ util/Makefile Sun Mar 17 13:08:59 2002
+@@ -1,11 +1,14 @@
+-PROG= iconv
++PROG= biconv
+ SRCS= iconv.c iconv_stream.c
+
+-LDADD= -L../lib -liconv
+-DPADD+= ../lib/libiconv.a
++LDADD= -L../lib -lbiconv
++DPADD+= ../lib/libbiconv.a
+
+ BINDIR= ${PREFIX}/bin
+
+-MAN1= iconv.1
++MAN1= biconv.1
++
++biconv.1: iconv.1
++ cp ${.ALLSRC} ${.TARGET}
+
+ .include <bsd.prog.mk>
diff --git a/converters/iconv/pkg-plist b/converters/iconv/pkg-plist
index bccf37e8f3de..8ac582dbe6d0 100644
--- a/converters/iconv/pkg-plist
+++ b/converters/iconv/pkg-plist
@@ -1,10 +1,10 @@
-bin/iconv
+bin/biconv
bin/iconv_mktbl
-include/iconv.h
-lib/libiconv.a
-lib/libiconv.so
-lib/libiconv.so.2
-%%PROFILE:%%lib/libiconv_p.a
+include/biconv.h
+lib/libbiconv.a
+lib/libbiconv.so
+lib/libbiconv.so.2
+%%PROFILE:%%lib/libbiconv_p.a
libexec/iconv/euc-jp.so
libexec/iconv/euc-kr.so
libexec/iconv/euc-tw.so