aboutsummaryrefslogtreecommitdiff
path: root/converters/o3read
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-21 19:25:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-21 19:25:30 +0000
commit96454e54504fbeb94970aa27f9b85dd2ebeca224 (patch)
tree98ec49d7564a38472894e417b71df09f56a06987 /converters/o3read
parentb2ead3a669c4de12b1883520bfd0adb68e2bbf63 (diff)
downloadports-96454e54504fbeb94970aa27f9b85dd2ebeca224.tar.gz
ports-96454e54504fbeb94970aa27f9b85dd2ebeca224.zip
Notes
Diffstat (limited to 'converters/o3read')
-rw-r--r--converters/o3read/Makefile37
-rw-r--r--converters/o3read/distinfo3
-rw-r--r--converters/o3read/files/patch-Makefile13
-rw-r--r--converters/o3read/pkg-descr10
4 files changed, 63 insertions, 0 deletions
diff --git a/converters/o3read/Makefile b/converters/o3read/Makefile
new file mode 100644
index 000000000000..7cb79068df29
--- /dev/null
+++ b/converters/o3read/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# New ports collection makefile for: o3read
+# Date created: Aug 07, 2008
+# Whom: samm
+#
+# $FreeBSD$
+
+PORTNAME= o3read
+PORTVERSION= 0.0.4
+CATEGORIES= converters
+MASTER_SITES= http://siag.nu/pub/o3read/ \
+ ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= Standalone converter for the OpenOffice.org writer and scalc formats
+
+MAN1= o3read.1 utf8tolatin1.1
+MLINKS= o3read.1 o3totxt.1 o3read.1 o3tohtml.1
+PORTDOCS= README COPYING ChangeLog
+PLIST_FILES= bin/o3read bin/o3totxt bin/o3tohtml bin/utf8tolatin1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/o3read ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/o3totxt ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/o3tohtml ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/utf8tolatin1 ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/o3read.1 ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/utf8tolatin1.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/converters/o3read/distinfo b/converters/o3read/distinfo
new file mode 100644
index 000000000000..7b2c1f8d61af
--- /dev/null
+++ b/converters/o3read/distinfo
@@ -0,0 +1,3 @@
+MD5 (o3read-0.0.4.tar.gz) = 583361b559ccf5a764edb586795d1b06
+SHA256 (o3read-0.0.4.tar.gz) = 3704b448099d3396bec4cf503c298628c815703aae12bfcddbac4444bc786430
+SIZE (o3read-0.0.4.tar.gz) = 21075
diff --git a/converters/o3read/files/patch-Makefile b/converters/o3read/files/patch-Makefile
new file mode 100644
index 000000000000..a2e81fb87ef7
--- /dev/null
+++ b/converters/o3read/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2005-01-07 11:28:47.000000000 +0300
++++ Makefile 2008-08-21 20:27:37.000000000 +0400
+@@ -2,9 +2,7 @@
+ PACKAGE = o3read
+ VERSION = 0.0.4
+
+-CC = gcc
+-CFLAGS = -Wall -ansi -pedantic -O -g
+-PREFIX = /usr/local
++CFLAGS += -Wall -ansi -pedantic
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/man/man1
+ DOCS = COPYING INSTALL README TODO ChangeLog filformat.sxw
diff --git a/converters/o3read/pkg-descr b/converters/o3read/pkg-descr
new file mode 100644
index 000000000000..ebfc39981909
--- /dev/null
+++ b/converters/o3read/pkg-descr
@@ -0,0 +1,10 @@
+This is a standalone converter for the OpenOffice.org swriter (*.sxw,*.odt)
+and scalc (*.sxc) formats.
+It doesn't depend on Open Office or any other external tools or libraries.
+There are three output modules:
+ * o3read displays a dump of the parse tree
+ * o3totxt creates plain text
+ * o3tohtml creates html code
+Example: unzip -p document.odt content.xml | o3totxt
+
+WWW: http://siag.nu/o3read/