aboutsummaryrefslogtreecommitdiff
path: root/converters/osm2mp/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 15:42:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 15:42:18 +0000
commit68ed39eeefdb013edeec2f589b10d15aca013667 (patch)
tree10947ec1336b0d9f160d370a739bb76929d9724d /converters/osm2mp/Makefile
parent13155c7415341bef8cab0f69e9b62e00050c09b4 (diff)
downloadports-68ed39eeefdb013edeec2f589b10d15aca013667.tar.gz
ports-68ed39eeefdb013edeec2f589b10d15aca013667.zip
Notes
Diffstat (limited to 'converters/osm2mp/Makefile')
-rw-r--r--converters/osm2mp/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/converters/osm2mp/Makefile b/converters/osm2mp/Makefile
index 1a6b582d26ed..fe628adc67fe 100644
--- a/converters/osm2mp/Makefile
+++ b/converters/osm2mp/Makefile
@@ -27,14 +27,15 @@ NO_BUILD= yes
SUB_FILES= pkg-message
-NO_STAGE= yes
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= *
+
post-patch:
@${REINPLACE_CMD} -e 's|garmin.yml|${DATADIR}/&|' ${WRKSRC}/osm2mp.pl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/osm2mp.pl ${PREFIX}/bin/osm2mp
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} '*.cmap *.yml *.txt *.typ polish-mp' ${DATADIR}/
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+ ${INSTALL_SCRIPT} ${WRKSRC}/osm2mp.pl ${STAGEDIR}${PREFIX}/bin/osm2mp
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} '*.cmap *.yml *.txt *.typ polish-mp' ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>