aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-Encode-compat/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-14 07:00:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-14 07:00:45 +0000
commit1c841e8918df53f48a18bf2f0e878c93d4a68fc7 (patch)
tree864b51f3e6ce454fe2dfb7dfe9cf1c9e9cb87ce7 /converters/p5-Encode-compat/Makefile
parent7fcc8327fa0d4948d00a6a8eacc540ffcf15e4a7 (diff)
downloadports-1c841e8918df53f48a18bf2f0e878c93d4a68fc7.tar.gz
ports-1c841e8918df53f48a18bf2f0e878c93d4a68fc7.zip
Notes
Diffstat (limited to 'converters/p5-Encode-compat/Makefile')
-rw-r--r--converters/p5-Encode-compat/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/converters/p5-Encode-compat/Makefile b/converters/p5-Encode-compat/Makefile
new file mode 100644
index 000000000000..4b552404b4f2
--- /dev/null
+++ b/converters/p5-Encode-compat/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Encode-compat
+# Date created: Mon April 14th, 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Encode-compat
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Encode
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+COMMENT= Compatibility interfaces for Encode.pm on Perl < 5.7.1
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Encode::compat.3 Encode::compat::Alias.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} != 500601
+IGNORE= This module only support perl 5.6.1
+.endif
+
+.include <bsd.port.post.mk>