aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-Encode/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-28 14:35:41 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-28 14:35:41 +0000
commitce5e56bc7eed7a6f95a1118b87d5f1d617344a45 (patch)
tree44fc18c4256518fc43442fc076c03f6cb7c47c8f /converters/p5-Encode/Makefile
parente0de789fb87700ea17236c06be81607ab311a0a2 (diff)
downloadports-ce5e56bc7eed7a6f95a1118b87d5f1d617344a45.tar.gz
ports-ce5e56bc7eed7a6f95a1118b87d5f1d617344a45.zip
Notes
Diffstat (limited to 'converters/p5-Encode/Makefile')
-rw-r--r--converters/p5-Encode/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/converters/p5-Encode/Makefile b/converters/p5-Encode/Makefile
new file mode 100644
index 000000000000..313b363d1029
--- /dev/null
+++ b/converters/p5-Encode/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Encode
+# Date created: Jul 24, 2005
+# Whom: Rong-En Fan <rafan@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Encode
+PORTVERSION= 2.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Encode
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rafan@infor.org
+COMMENT= Provides interfaces between strings and the rest of the system
+
+PERL_CONFIGURE= yes
+
+MAN1= piconv.1 enc2xs.1
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Requires Perl 5.8.0 or above.
+.elif ${PERL_LEVEL} > 500806
+IGNORE= Perl above 5.8.7 has Encode ${PORTVERSION}.
+.endif
+
+.include <bsd.port.post.mk>