aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-11-21 18:43:01 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-11-21 18:43:01 +0000
commita9e58000b37824943d7a08a4af24de42a19d03ab (patch)
treee993071f93299d97dee6067b2ce7f2a3c568af98 /converters/p5-JSON-XS-VersionOneAndTwo/Makefile
parent0ab87100448d1cc4d933ea40d3afcaeb3ddd05a6 (diff)
downloadports-a9e58000b37824943d7a08a4af24de42a19d03ab.tar.gz
ports-a9e58000b37824943d7a08a4af24de42a19d03ab.zip
Notes
Diffstat (limited to 'converters/p5-JSON-XS-VersionOneAndTwo/Makefile')
-rw-r--r--converters/p5-JSON-XS-VersionOneAndTwo/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/converters/p5-JSON-XS-VersionOneAndTwo/Makefile b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
new file mode 100644
index 000000000000..cd70333fffb8
--- /dev/null
+++ b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-JSON-XS-VersionOneAndTwo
+# Date created: 21 Nov 2008
+# Whom: Denis Pokataev <catone@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-XS-VersionOneAndTwo
+PORTVERSION= 0.31
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= catone@cpan.org
+COMMENT= Support versions 1 and 2 of JSON::XS
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/JSON/XS.pm:${PORTSDIR}/converters/p5-JSON-XS
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= JSON::XS::VersionOneAndTwo.3
+
+.include <bsd.port.mk>