aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-Number-Nary/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-01-05 08:53:52 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-01-05 08:53:52 +0000
commit458cc5f453f5292301a830c5806a72c551d4d0c5 (patch)
treeb9cb873d850b76f8ff4429341cb804d1e7d3d12f /converters/p5-Number-Nary/Makefile
parent3af50e783dff41c5dcc958f16606bda16a77006f (diff)
downloadports-458cc5f453f5292301a830c5806a72c551d4d0c5.tar.gz
ports-458cc5f453f5292301a830c5806a72c551d4d0c5.zip
Notes
Diffstat (limited to 'converters/p5-Number-Nary/Makefile')
-rw-r--r--converters/p5-Number-Nary/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/converters/p5-Number-Nary/Makefile b/converters/p5-Number-Nary/Makefile
new file mode 100644
index 000000000000..f976c78e019a
--- /dev/null
+++ b/converters/p5-Number-Nary/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: converters/p5-Number-Nary
+# Date created: 05 January 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Number-Nary
+PORTVERSION= 0.102
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Number
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Encode and decode numbers as n-ary strings
+
+BUILD_DEPENDS= ${SITE_PERL}/Sub/Exporter.pm:${PORTSDIR}/devel/p5-Sub-Exporter \
+ ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Number::Nary.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>