aboutsummaryrefslogtreecommitdiff
path: root/converters/pdf2djvu
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-08-08 16:04:51 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-08-08 16:04:51 +0000
commit92c6c27d8e000c87a0fbba371e627614ac91e789 (patch)
tree502ccefb73616511bd12bafef371f2248a5f878c /converters/pdf2djvu
parent4011c3fb1812951a982c12adf80371621bedac3c (diff)
downloadports-92c6c27d8e000c87a0fbba371e627614ac91e789.tar.gz
ports-92c6c27d8e000c87a0fbba371e627614ac91e789.zip
Notes
Diffstat (limited to 'converters/pdf2djvu')
-rw-r--r--converters/pdf2djvu/Makefile13
-rw-r--r--converters/pdf2djvu/distinfo6
-rw-r--r--converters/pdf2djvu/files/patch-configure24
3 files changed, 33 insertions, 10 deletions
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index 45b79da72db1..f3eba38db94a 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pdf2djvu
-PORTVERSION= 0.4.12
-PORTREVISION= 4
+PORTVERSION= 0.5.10
CATEGORIES= converters
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFFIX}
@@ -17,14 +16,14 @@ COMMENT= Pdf2djvu creates DjVu files from PDF files
BUILD_DEPENDS= ${LOCALBASE}/include/pstreams/pstream.h:${PORTSDIR}/devel/pstreams
LIB_DEPENDS= poppler.4:${PORTSDIR}/graphics/poppler
+LIB_DEPENDS+= djvulibre.22:${PORTSDIR}/graphics/djvulibre-nox11
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS=${PTHREAD_LIBS}
USE_GMAKE= yes
-PLIST_FILES= bin/pdf2djvu
-LIB_DEPENDS+= djvulibre.22:${PORTSDIR}/graphics/djvulibre-nox11
-
-MAKE_ENV= LDLIBS="${LDFLAGS} ${PTHREAD_LIBS}"
-MAN1= pdf2djvu.1
+PLIST_FILES= bin/pdf2djvu
+MAN1= pdf2djvu.1
MANCOMPRESSED= no
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/converters/pdf2djvu/distinfo b/converters/pdf2djvu/distinfo
index 1743850165df..f531bbd2826f 100644
--- a/converters/pdf2djvu/distinfo
+++ b/converters/pdf2djvu/distinfo
@@ -1,3 +1,3 @@
-MD5 (pdf2djvu_0.4.12.tar.gz) = af325766614f58e7373c26c6d45f04e4
-SHA256 (pdf2djvu_0.4.12.tar.gz) = 819b1427a74d90ebda8971b670a9f03d6fd5d8a9ae03dbf48c91ebaf5a769a19
-SIZE (pdf2djvu_0.4.12.tar.gz) = 55798
+MD5 (pdf2djvu_0.5.10.tar.gz) = 83f43a712a7c560d484045c3e791b104
+SHA256 (pdf2djvu_0.5.10.tar.gz) = dde12c8f4af0c7cc78eef28fcc810b055ca1c74761786bce482a307a9b1dce70
+SIZE (pdf2djvu_0.5.10.tar.gz) = 213490
diff --git a/converters/pdf2djvu/files/patch-configure b/converters/pdf2djvu/files/patch-configure
new file mode 100644
index 000000000000..38ea1c8e1387
--- /dev/null
+++ b/converters/pdf2djvu/files/patch-configure
@@ -0,0 +1,24 @@
+--- configure.orig 2009-07-12 12:59:06.000000000 +0200
++++ configure 2009-07-26 09:04:22.000000000 +0200
+@@ -2971,9 +2971,9 @@
+ printf 'P1 3 3 0 0 0 0 0 0 0 0 0 0' > conftest.458086.pbm
+ "$djvulibre_bin_path/cjb2" conftest.458086.pbm conftest.458086.p1.djvu
+ "$djvulibre_bin_path/cjb2" conftest.458086.pbm conftest.458086.p2.djvu
+-printf 'AT&TFORM\0\0\0\x35DJVMDIRM\0\0\0\x29\x01\0\x02\xff\xff\xc6\xbf\x8a' > conftest.458086.djvu
+-printf '\x1f\xeb\x4b\xff\x40\x8e\x37\x86\x3f\x6c\xbe\x78\x02\x3c\x93\x9b' >> conftest.458086.djvu
+-printf '\x17\x57\x16\x67\x1d\x7a\xeb\x57\xf8\xf3\x7e\x64\x32\x42\x88\xd2\x4f' >> conftest.458086.djvu
++printf 'AT&TFORM\0\0\0\065DJVMDIRM\0\0\0\051\001\0\002\377\377\306\277\212' > conftest.458086.djvu
++printf '\037\353\113\377\100\216\067\206\077\154\276\170\002\074\223\233' >> conftest.458086.djvu
++printf '\027\127\026\147\035\172\353\127\370\363\176\144\062\102\210\322\117' >> conftest.458086.djvu
+ printf '(bookmarks ("" ""))' > conftest.458086.outline
+ "$djvulibre_bin_path/djvused" -s -e 'set-outline conftest.458086.outline' conftest.458086.djvu
+ if ! "$djvulibre_bin_path/djvused" -e print-outline conftest.458086.djvu | grep '(bookmarks' > /dev/null
+@@ -3173,7 +3173,7 @@
+ fi
+
+
+-
++pkg_failed=untried; echo "disabled"
+ if test $pkg_failed = yes; then
+
+ if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then