aboutsummaryrefslogtreecommitdiff
path: root/converters/pdf2djvu
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-22 17:59:22 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-22 17:59:22 +0000
commit90a4ed701a4a68d4ed2c54b96f8f5371dbfd9ffb (patch)
treeb78dc987b5630ee8fd0fcabe9d02b299721bed32 /converters/pdf2djvu
parentb3f15f1bc762df52e33fc20b9e42fc97b3b36a67 (diff)
downloadports-90a4ed701a4a68d4ed2c54b96f8f5371dbfd9ffb.tar.gz
ports-90a4ed701a4a68d4ed2c54b96f8f5371dbfd9ffb.zip
graphics/poppler: update to 0.84.0
Release 0.84.0: core: * Fix crash when converting from Unicode to ASCII-7 * Splash::scaleImageYdXu: Protect against crash if srcWidth is too big * JBIG2Stream: fix potential crash in malformed documents * JBIG2Stream: fix leak in reset() if called several times * Internal code improvements utils: * pdfimages: Add error message if first page is larger then number of pages. * pdfinfo: Improved paper size recognition * pdfsig: Fix exit code when dumping signatures * pdftocairo: Error out when even/odd selects 0 pages * pdftohtml: Fix memory leak * pdftoppm: Add an option to scale before rotate * pdftoppm: Add -hide-annotations option * pdftoppm: Error out when even/odd selects 0 pages * pdftops: Improve -optimizecolorspace qt5: * Code cleanups glib: * Fix compiler warnings Release 0.83.0 core: * Improve when a file is recognized as Linearized * Improve const-ness of the code * Make code a bit more readable/maintanable * Fix uninitialized memory uses in broken files utils: * pdffonts: Make code a bit more readable/maintanable * pdftohtml: Make code a bit more readable/maintanable qt5: * Remove a bunch of unused internal functions * trUtf8 -> tr (less warnings) build system: * make-glib-api-docs: switch to python3 PR: 243433 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=523824
Diffstat (limited to 'converters/pdf2djvu')
-rw-r--r--converters/pdf2djvu/Makefile2
-rw-r--r--converters/pdf2djvu/files/patch-pdf-backend.cc26
2 files changed, 27 insertions, 1 deletions
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index 2a5ecf662a5e..edbed3001bef 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pdf2djvu
PORTVERSION= 0.9.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters
MASTER_SITES= https://github.com/jwilk/${PORTNAME}/releases/download/${PORTVERSION}/
diff --git a/converters/pdf2djvu/files/patch-pdf-backend.cc b/converters/pdf2djvu/files/patch-pdf-backend.cc
new file mode 100644
index 000000000000..7e967b6c7210
--- /dev/null
+++ b/converters/pdf2djvu/files/patch-pdf-backend.cc
@@ -0,0 +1,26 @@
+--- pdf-backend.cc.orig 2019-06-10 17:06:44 UTC
++++ pdf-backend.cc
+@@ -103,7 +103,7 @@ static void poppler_error_handler(void *data, ErrorCat
+
+ pdf::Environment::Environment()
+ {
+- globalParams = new GlobalParams();
++ globalParams = std::unique_ptr<GlobalParams>(new GlobalParams);
+ setErrorCallback(poppler_error_handler, nullptr);
+ }
+
+@@ -499,12 +499,11 @@ bool pdf::get_glyph(splash::Splash *splash, splash::Fo
+ void pdf::Renderer::convert_path(pdf::gfx::State *state, splash::Path &splash_path)
+ {
+ /* Source was copied from <poppler/SplashOutputDev.c>. */
+- pdf::gfx::Subpath *subpath;
+- pdf::gfx::Path *path = state->getPath();
++ auto path = state->getPath();
+ int n_subpaths = path->getNumSubpaths();
+ for (int i = 0; i < n_subpaths; i++)
+ {
+- subpath = path->getSubpath(i);
++ auto subpath = path->getSubpath(i);
+ if (subpath->getNumPoints() > 0)
+ {
+ double x1, y1, x2, y2, x3, y3;