aboutsummaryrefslogtreecommitdiff
path: root/converters/php55-mbstring
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
commit7fe96c109332ecdb411ceef911efd11085a88346 (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /converters/php55-mbstring
parent47b48988aa7fe1c1c0f221ce9cb124af07f62a16 (diff)
downloadports-7fe96c109332ecdb411ceef911efd11085a88346.tar.gz
ports-7fe96c109332ecdb411ceef911efd11085a88346.zip
Notes
Diffstat (limited to 'converters/php55-mbstring')
-rw-r--r--converters/php55-mbstring/Makefile10
-rw-r--r--converters/php55-mbstring/files/patch-config.m451
2 files changed, 61 insertions, 0 deletions
diff --git a/converters/php55-mbstring/Makefile b/converters/php55-mbstring/Makefile
new file mode 100644
index 000000000000..0cc3d45751b5
--- /dev/null
+++ b/converters/php55-mbstring/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -mbstring
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php55-mbstring/files/patch-config.m4 b/converters/php55-mbstring/files/patch-config.m4
new file mode 100644
index 000000000000..026798f26a5a
--- /dev/null
+++ b/converters/php55-mbstring/files/patch-config.m4
@@ -0,0 +1,51 @@
+--- config.m4.orig 2009-11-25 02:30:06.000000000 +0100
++++ config.m4 2010-04-12 09:59:54.000000000 +0200
+@@ -43,6 +43,30 @@
+ PHP_ADD_INCLUDE([$ext_builddir/$dir])
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$ext_shared" = "no"; then
+ PHP_ADD_SOURCES(PHP_EXT_DIR(mbstring), $PHP_MBSTRING_BASE_SOURCES)
+ out="php_config.h"
+@@ -80,7 +104,6 @@
+ int foo(int x, ...) {
+ va_list va;
+ va_start(va, x);
+- va_arg(va, int);
+ va_arg(va, char *);
+ va_arg(va, double);
+ return 0;
+@@ -347,6 +370,9 @@
+ [ --with-onig[=DIR] MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
+ If DIR is not set, the bundled oniguruma will be used], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
++
+ if test "$PHP_MBSTRING" != "no"; then
+ AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
+