aboutsummaryrefslogtreecommitdiff
path: root/converters/php74-mbstring
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
commit7aca2531e2d785929c4477143e265a8d9b0b516b (patch)
tree5eb143508ff1769e64395b54d8a3b09e1576fba0 /converters/php74-mbstring
parent2a5ef470852066fb4e7c665bc1bb5be0b206d82b (diff)
downloadports-7aca2531e2d785929c4477143e265a8d9b0b516b.tar.gz
ports-7aca2531e2d785929c4477143e265a8d9b0b516b.zip
Notes
Diffstat (limited to 'converters/php74-mbstring')
-rw-r--r--converters/php74-mbstring/Makefile11
-rw-r--r--converters/php74-mbstring/files/patch-config.m444
2 files changed, 55 insertions, 0 deletions
diff --git a/converters/php74-mbstring/Makefile b/converters/php74-mbstring/Makefile
new file mode 100644
index 000000000000..9245c771f620
--- /dev/null
+++ b/converters/php74-mbstring/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -mbstring
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php74-mbstring/files/patch-config.m4 b/converters/php74-mbstring/files/patch-config.m4
new file mode 100644
index 000000000000..a3e5c14477a3
--- /dev/null
+++ b/converters/php74-mbstring/files/patch-config.m4
@@ -0,0 +1,44 @@
+--- config.m4.orig 2019-08-06 06:54:10 UTC
++++ config.m4
+@@ -37,6 +37,31 @@ AC_DEFUN([PHP_MBSTRING_EXTENSION], [
+
+ out="php_config.h"
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
++
+ if test "$ext_shared" != "no" && test -f "$ext_builddir/config.h.in"; then
+ out="$abs_builddir/config.h"
+ fi
+@@ -200,6 +225,9 @@ PHP_ARG_ENABLE([mbregex],
+ [yes],
+ [no])
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
++
+ if test "$PHP_MBSTRING" != "no"; then
+ AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
+