aboutsummaryrefslogtreecommitdiff
path: root/converters/py-bsdconv
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-10-14 14:21:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-10-14 14:21:58 +0000
commit5af7bc41cb0f09f0a2388af0c3751aca20a50ad8 (patch)
tree01d8e0fc98030592b65ffbafd757fb46d1b3787e /converters/py-bsdconv
parentc32781752419de0d95e9f4c20c35369e93cd9efa (diff)
downloadports-5af7bc41cb0f09f0a2388af0c3751aca20a50ad8.tar.gz
ports-5af7bc41cb0f09f0a2388af0c3751aca20a50ad8.zip
BSD licensed charset/encoding converter library with more function than
libiconv. (Currently, only a few codecs are supported) This port is a python wrapper for bsdconv. WWW: http://github.com/buganini/bsdconv/ PR: ports/139524 Submitted by: buganini at gmail.com
Notes
Notes: svn path=/head/; revision=242844
Diffstat (limited to 'converters/py-bsdconv')
-rw-r--r--converters/py-bsdconv/Makefile30
-rw-r--r--converters/py-bsdconv/distinfo3
-rw-r--r--converters/py-bsdconv/pkg-descr5
-rw-r--r--converters/py-bsdconv/pkg-plist1
4 files changed, 39 insertions, 0 deletions
diff --git a/converters/py-bsdconv/Makefile b/converters/py-bsdconv/Makefile
new file mode 100644
index 000000000000..033844aab7ae
--- /dev/null
+++ b/converters/py-bsdconv/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-bsdconv
+# Date created: 11 Oct 2009
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdconv
+PORTVERSION= 3.5
+CATEGORIES= converters python
+MASTER_SITES= http://security-hole.info/distfile/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= buganini-bsdconv-c14ef1b
+
+MAINTAINER= buganini@gmail.com
+COMMENT= Python wrapper for bsdconv
+
+LIB_DEPENDS= bsdconv.3:${PORTSDIR}/converters/bsdconv
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/wrapper/python
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/converters/py-bsdconv/distinfo b/converters/py-bsdconv/distinfo
new file mode 100644
index 000000000000..fdf674089c38
--- /dev/null
+++ b/converters/py-bsdconv/distinfo
@@ -0,0 +1,3 @@
+MD5 (buganini-bsdconv-c14ef1b.tar.gz) = 2a17209dee54f03a0df5c6f465555a8d
+SHA256 (buganini-bsdconv-c14ef1b.tar.gz) = 06119b773c1c9e6b1f48cd12ab568d0f3eab255544581c18a83aa98d39d2157c
+SIZE (buganini-bsdconv-c14ef1b.tar.gz) = 1824149
diff --git a/converters/py-bsdconv/pkg-descr b/converters/py-bsdconv/pkg-descr
new file mode 100644
index 000000000000..fae77f85b8f7
--- /dev/null
+++ b/converters/py-bsdconv/pkg-descr
@@ -0,0 +1,5 @@
+BSD licensed charset/encoding converter library with more function than
+libiconv. (Currently, only a few codecs are supported)
+This port is a python wrapper for bsdconv.
+
+WWW: http://github.com/buganini/bsdconv/
diff --git a/converters/py-bsdconv/pkg-plist b/converters/py-bsdconv/pkg-plist
new file mode 100644
index 000000000000..998e0a9db912
--- /dev/null
+++ b/converters/py-bsdconv/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/bsdconv.so