aboutsummaryrefslogtreecommitdiff
path: root/converters/recode/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2002-04-17 07:16:33 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2002-04-17 07:16:33 +0000
commit452ed87c7a2b48c28a6a8bdac522bdcaee0bdd7b (patch)
tree3897efd31d7618bc73c19014976860b2e1f640fa /converters/recode/Makefile
parent9346fa76390fdb90ad4bdfef57bdea3712da6b59 (diff)
downloadports-452ed87c7a2b48c28a6a8bdac522bdcaee0bdd7b.tar.gz
ports-452ed87c7a2b48c28a6a8bdac522bdcaee0bdd7b.zip
Notes
Diffstat (limited to 'converters/recode/Makefile')
-rw-r--r--converters/recode/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index 3fc960fafd28..19113199bc34 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -14,28 +14,22 @@ MASTER_SITE_SUBDIR= recode
MAINTAINER= demon@FreeBSD.org
-BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --without-included-gettext
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="-lintl" \
- MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
- XGETTEXT="${LOCALBASE}/bin/xgettext-old"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= recode.1
-post-extract: copy-po-files remove-info-files
-
-copy-po-files:
- @${CP} ${FILESDIR}/ru.po ${WRKSRC}/i18n
+post-extract: remove-info-files
remove-info-files:
@${RM} -f ${WRKSRC}/doc/${PORTNAME}.info*
-post-patch: patch-po-files patch-configure patch-makeinfo
+post-patch: patch-po-files patch-makeinfo
patch-po-files:
@${PERL} -pi -e '\
@@ -45,10 +39,6 @@ patch-po-files:
} \
' ${WRKSRC}/i18n/*.po
-patch-configure:
- @${PERL} -pi -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
- ${WRKSRC}/configure
-
patch-makeinfo:
@${PERL} -pi.fbsd -e 's|\@MAKEINFO\@|\@MAKEINFO\@ --no-split|g' \
${WRKSRC}/doc/Makefile.in