aboutsummaryrefslogtreecommitdiff
path: root/converters/recode
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2003-03-23 08:17:26 +0000
committerMartin Blapp <mbr@FreeBSD.org>2003-03-23 08:17:26 +0000
commit4184495efa15c76ab0bd7910eeffb4c23f8a9568 (patch)
treee8b9738853cd536e86dde8de115174bdf490c679 /converters/recode
parent42ef59a923637d8b2b1926fd6bcdfeac545b8be5 (diff)
downloadports-4184495efa15c76ab0bd7910eeffb4c23f8a9568.tar.gz
ports-4184495efa15c76ab0bd7910eeffb4c23f8a9568.zip
Notes
Diffstat (limited to 'converters/recode')
-rw-r--r--converters/recode/files/patch-lib-error.c33
-rw-r--r--converters/recode/files/patch-src-Makefile.in (renamed from converters/recode/files/patch-aa)11
2 files changed, 43 insertions, 1 deletions
diff --git a/converters/recode/files/patch-lib-error.c b/converters/recode/files/patch-lib-error.c
new file mode 100644
index 000000000000..f98aed77d339
--- /dev/null
+++ b/converters/recode/files/patch-lib-error.c
@@ -0,0 +1,33 @@
+--- lib/error.c.orig Mon Mar 10 10:57:22 2003
++++ lib/error.c Mon Mar 10 11:02:12 2003
+@@ -25,6 +25,18 @@
+ # include <config.h>
+ #endif
+
++# ifdef __FreeBSD__
++# include <sys/types.h>
++# include <sys/exec.h>
++# include <vm/vm.h>
++# include <vm/vm_param.h>
++# include <vm/pmap.h>
++# include <vm/swap_pager.h>
++# include <machine/param.h>
++# include <machine/vmparam.h>
++# include <machine/pmap.h>
++# endif
++
+ #include <stdio.h>
+
+ #if HAVE_VPRINTF || HAVE_DOPRNT || _LIBC
+@@ -80,7 +92,11 @@
+
+ /* The calling program should define program_name and set it to the
+ name of the executing program. */
++# ifdef __FreeBSD__
++# define program_name *((struct ps_strings *)PS_STRINGS)->ps_argvstr
++# else
+ extern char *program_name;
++# endif
+
+ # ifdef HAVE_STRERROR_R
+ # define __strerror_r strerror_r
diff --git a/converters/recode/files/patch-aa b/converters/recode/files/patch-src-Makefile.in
index f8e7784ba6a7..e168d585198b 100644
--- a/converters/recode/files/patch-aa
+++ b/converters/recode/files/patch-src-Makefile.in
@@ -1,5 +1,5 @@
--- src/Makefile.in.orig Mon Jan 22 19:14:16 2001
-+++ src/Makefile.in Thu Sep 6 11:21:43 2001
++++ src/Makefile.in Mon Mar 10 10:17:54 2003
@@ -131,7 +131,7 @@
librecode_la_SOURCES = argmatch.c charname.c combine.c fr-charname.c hash.c iconv.c libiconv.c localcharset.c merged.c names.c outer.c quotearg.c recode.c request.c strip-pool.c task.c xmalloc.c $(C_STEPS)
@@ -9,3 +9,12 @@
INCLUDES = -I.. -I$(srcdir) -I$(top_srcdir)/lib -I$(top_srcdir)/libiconv
DEFS = -DLIBDIR=\"$(libdir)\" @DEFS@
+@@ -153,7 +153,7 @@
+
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ ../lib/libreco.a
+ ANSI2KNR = @ANSI2KNR@
+ librecode_la_LIBADD =
+ librecode_la_OBJECTS = argmatch$U.lo charname$U.lo combine$U.lo \