aboutsummaryrefslogtreecommitdiff
path: root/converters/uudx/files/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-06-10 01:49:45 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-06-10 01:49:45 +0000
commitfa29b4acb846dc124e91ddad66bc19fba4430909 (patch)
tree86ee76371c8fdda53c5cd3b6fbdc4f86a1b37fcb /converters/uudx/files/Makefile
parentd68269f2b0f29488ec8c9a20a8011a625a79dbf0 (diff)
Notes
Diffstat (limited to 'converters/uudx/files/Makefile')
-rw-r--r--converters/uudx/files/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/converters/uudx/files/Makefile b/converters/uudx/files/Makefile
new file mode 100644
index 000000000000..39fe22189d1c
--- /dev/null
+++ b/converters/uudx/files/Makefile
@@ -0,0 +1,24 @@
+#
+# makefile of uudx
+#
+
+CFLAGS += -DBSD=1 -DEUC=1 -DUTIME_EXIST -DMKDIR_HAS_MODE
+PROGRAM = uudx
+MANPAGE = uudx.1
+MANDIR = ${PREFIX}/man/ja_JP.sjis/man1
+SRC = uudx.c
+OBJ = uudx.o
+
+all: ${PROGRAM}
+
+${PROGRAM}: ${OBJ}
+ ${CC} ${CFLAGS} -o ${PROGRAM} ${OBJ}
+
+install: ${PROGRAM}
+ ${INSTALL} -c -s ${PROGRAM} ${PREFIX}/bin
+ mkdir -p ${MANDIR}
+ ${INSTALL} -c ${MANPAGE} ${MANDIR}
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${MANDIR}/${MANPAGE}
+
+.endif