aboutsummaryrefslogtreecommitdiff
path: root/converters/uudx
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-06-10 01:49:45 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-06-10 01:49:45 +0000
commitfa29b4acb846dc124e91ddad66bc19fba4430909 (patch)
tree86ee76371c8fdda53c5cd3b6fbdc4f86a1b37fcb /converters/uudx
parentd68269f2b0f29488ec8c9a20a8011a625a79dbf0 (diff)
downloadports-fa29b4acb846dc124e91ddad66bc19fba4430909.tar.gz
ports-fa29b4acb846dc124e91ddad66bc19fba4430909.zip
Notes
Diffstat (limited to 'converters/uudx')
-rw-r--r--converters/uudx/Makefile28
-rw-r--r--converters/uudx/distinfo1
-rw-r--r--converters/uudx/files/Makefile24
-rw-r--r--converters/uudx/files/patch-aa14
-rw-r--r--converters/uudx/pkg-comment1
-rw-r--r--converters/uudx/pkg-descr2
-rw-r--r--converters/uudx/pkg-plist2
7 files changed, 72 insertions, 0 deletions
diff --git a/converters/uudx/Makefile b/converters/uudx/Makefile
new file mode 100644
index 000000000000..4e58aac3bb86
--- /dev/null
+++ b/converters/uudx/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: uudx
+# Version required: 2.99
+# Date created: 2 June 1996
+# Whom: ABURAYER Rewsirow <pcs51674@asciinet.or.jp>
+#
+#
+#
+
+DISTNAME= uudx_299
+PKGNAME= uudx-2.99
+CATEGORIES+= archivers
+MASTER_SITES= ftp://ftp.ae.keio.ac.jp/pub/msdos/archivers/uu/
+
+MAINTAINER= pcs51674@asciinet.or.jp
+
+BUILD_DEPENDS= lha:${PORTSDIR}/archivers/lha
+
+EXTRACT_CMD= lha
+EXTRACT_SUFX= .lzh
+EXTRACT_BEFORE_ARGS= xw=${WRKDIR}
+NO_WRKSUBDIR= yes
+PATCH_STRIP= -p1
+
+pre-patch:
+ @echo "===> Installing custom Makefile for ${DISTNAME}"
+ @(cp ${FILESDIR}/Makefile ${WRKSRC})
+
+.include <bsd.port.mk>
diff --git a/converters/uudx/distinfo b/converters/uudx/distinfo
new file mode 100644
index 000000000000..b2fa05d34eaa
--- /dev/null
+++ b/converters/uudx/distinfo
@@ -0,0 +1 @@
+MD5 (uudx_299.lzh) = 001f493bbdb0ee8583f91ce8ac648e9a
diff --git a/converters/uudx/files/Makefile b/converters/uudx/files/Makefile
new file mode 100644
index 000000000000..39fe22189d1c
--- /dev/null
+++ b/converters/uudx/files/Makefile
@@ -0,0 +1,24 @@
+#
+# makefile of uudx
+#
+
+CFLAGS += -DBSD=1 -DEUC=1 -DUTIME_EXIST -DMKDIR_HAS_MODE
+PROGRAM = uudx
+MANPAGE = uudx.1
+MANDIR = ${PREFIX}/man/ja_JP.sjis/man1
+SRC = uudx.c
+OBJ = uudx.o
+
+all: ${PROGRAM}
+
+${PROGRAM}: ${OBJ}
+ ${CC} ${CFLAGS} -o ${PROGRAM} ${OBJ}
+
+install: ${PROGRAM}
+ ${INSTALL} -c -s ${PROGRAM} ${PREFIX}/bin
+ mkdir -p ${MANDIR}
+ ${INSTALL} -c ${MANPAGE} ${MANDIR}
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${MANDIR}/${MANPAGE}
+
+.endif
diff --git a/converters/uudx/files/patch-aa b/converters/uudx/files/patch-aa
new file mode 100644
index 000000000000..9ed9b053d296
--- /dev/null
+++ b/converters/uudx/files/patch-aa
@@ -0,0 +1,14 @@
+--- uudx-299.orig/uudx.c Sun Jan 29 16:44:42 1995
++++ uudx-299/uudx.c Sun Jun 2 16:04:27 1996
+@@ -89,7 +89,11 @@
+ #else
+ #define strchr index
+ extern char *strchr();
++#ifndef __FreeBSD__
+ extern char *sprintf();
++#else
++extern int sprintf();
++#endif
+ extern char *strcpy();
+ #endif /* BSD */
+
diff --git a/converters/uudx/pkg-comment b/converters/uudx/pkg-comment
new file mode 100644
index 000000000000..f0328f1cebd8
--- /dev/null
+++ b/converters/uudx/pkg-comment
@@ -0,0 +1 @@
+Extractor from uuencoded files.
diff --git a/converters/uudx/pkg-descr b/converters/uudx/pkg-descr
new file mode 100644
index 000000000000..669b122b8cb7
--- /dev/null
+++ b/converters/uudx/pkg-descr
@@ -0,0 +1,2 @@
+uudx decodes files containing uuencoded text. It can handle split
+and out-of-order pieces.
diff --git a/converters/uudx/pkg-plist b/converters/uudx/pkg-plist
new file mode 100644
index 000000000000..2831d04b678e
--- /dev/null
+++ b/converters/uudx/pkg-plist
@@ -0,0 +1,2 @@
+bin/uudx
+man/ja_JP.sjis/man1/uudx.1.gz