aboutsummaryrefslogtreecommitdiff
path: root/converters/wkhtmltopdf
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /converters/wkhtmltopdf
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'converters/wkhtmltopdf')
-rw-r--r--converters/wkhtmltopdf/Makefile1
-rw-r--r--converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test11
-rw-r--r--converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp11
-rw-r--r--converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp39
4 files changed, 62 insertions, 0 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index 1ca2144333fe..a32636c47b8d 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wkhtmltopdf
PORTVERSION= 0.12.2.1
+PORTREVISION= 1
CATEGORIES= converters
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
diff --git a/converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test b/converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test
new file mode 100644
index 000000000000..2046425ad53c
--- /dev/null
+++ b/converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test
@@ -0,0 +1,11 @@
+--- config.tests/unix/compile.test.orig
++++ config.tests/unix/compile.test
+@@ -13,7 +13,7 @@
+ shift 7
+ LFLAGS="$SYSROOT_FLAG"
+ INCLUDEPATH=""
+-CXXFLAGS="$SYSROOT_FLAG"
++CXXFLAGS="$CXXFLAGS $SYSROOT_FLAG"
+ MAC_ARCH_CXXFLAGS=""
+ MAC_ARCH_LFLAGS=""
+ while [ "$#" -gt 0 ]; do
diff --git a/converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp b/converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp
new file mode 100644
index 000000000000..5f5c16ea37f5
--- /dev/null
+++ b/converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp
@@ -0,0 +1,11 @@
+--- config.tests/unix/gnu-libiconv/gnu-libiconv.cpp.orig 2015-01-03 18:06:12 UTC
++++ config.tests/unix/gnu-libiconv/gnu-libiconv.cpp
+@@ -48,7 +48,7 @@ int main(int, char **)
+ {
+ iconv_t x = iconv_open("", "");
+
+- const char *inp;
++ char *inp;
+ char *outp;
+ size_t inbytes, outbytes;
+ iconv(x, &inp, &inbytes, &outp, &outbytes);
diff --git a/converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp b/converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp
new file mode 100644
index 000000000000..99bfac114be0
--- /dev/null
+++ b/converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp
@@ -0,0 +1,39 @@
+--- src/corelib/codecs/qiconvcodec.cpp.orig 2015-01-03 18:06:52 UTC
++++ src/corelib/codecs/qiconvcodec.cpp
+@@ -219,12 +219,7 @@ QString QIconvCodec::convertToUnicode(co
+ IconvState *state = *pstate;
+ size_t inBytesLeft = len;
+ // best case assumption, each byte is converted into one UTF-16 character, plus 2 bytes for the BOM
+-#ifdef GNU_LIBICONV
+- // GNU doesn't disagree with POSIX :/
+- const char *inBytes = chars;
+-#else
+ char *inBytes = const_cast<char *>(chars);
+-#endif
+
+ QByteArray in;
+ if (remainingCount) {
+@@ -318,11 +313,7 @@ static bool setByteOrder(iconv_t cd)
+ size_t outBytesLeft = sizeof buf;
+ size_t inBytesLeft = sizeof bom;
+
+-#if defined(GNU_LIBICONV)
+- const char **inBytesPtr = const_cast<const char **>(&inBytes);
+-#else
+ char **inBytesPtr = &inBytes;
+-#endif
+
+ if (iconv(cd, inBytesPtr, &inBytesLeft, &outBytes, &outBytesLeft) == (size_t) -1) {
+ return false;
+@@ -338,11 +329,7 @@ QByteArray QIconvCodec::convertFromUnico
+ char *outBytes;
+ size_t inBytesLeft;
+
+-#if defined(GNU_LIBICONV)
+- const char **inBytesPtr = const_cast<const char **>(&inBytes);
+-#else
+ char **inBytesPtr = &inBytes;
+-#endif
+
+ IconvState *temporaryState = 0;
+ QThreadStorage<QIconvCodec::IconvState *> *ts = fromUnicodeState();