aboutsummaryrefslogtreecommitdiff
path: root/converters/xdeview
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-27 09:00:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-27 09:00:43 +0000
commitd6afd5625099914922be8563648de8382c96688a (patch)
treeb71ed4408f8fa3bb6495fba53bafe9d70273e6bc /converters/xdeview
parent49278d150d8ac3afec5696b5f87bc8ecedcfe883 (diff)
downloadports-d6afd5625099914922be8563648de8382c96688a.tar.gz
ports-d6afd5625099914922be8563648de8382c96688a.zip
Notes
Diffstat (limited to 'converters/xdeview')
-rw-r--r--converters/xdeview/Makefile2
-rw-r--r--converters/xdeview/files/patch-configure8
-rw-r--r--converters/xdeview/files/patch-tcl_Makefile.in12
-rw-r--r--converters/xdeview/files/patch-tcl_uutcl.c4
4 files changed, 13 insertions, 13 deletions
diff --git a/converters/xdeview/Makefile b/converters/xdeview/Makefile
index 2063c44fe03c..2b79cd298080 100644
--- a/converters/xdeview/Makefile
+++ b/converters/xdeview/Makefile
@@ -42,6 +42,6 @@ post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${FILESDIR}/porting.notes ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/porting.notes ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/converters/xdeview/files/patch-configure b/converters/xdeview/files/patch-configure
index cc5839b6b958..27dd8339f6ee 100644
--- a/converters/xdeview/files/patch-configure
+++ b/converters/xdeview/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Thu Jan 9 08:22:00 1997
-+++ configure Thu Nov 4 11:29:23 1999
-@@ -3148,7 +3148,7 @@
+--- configure.orig 2004-03-01 23:06:18 UTC
++++ configure
+@@ -2447,7 +2447,7 @@ EOF
fi
-for ac_hdr in fcntl.h unistd.h memory.h malloc.h errno.h direct.h
+for ac_hdr in fcntl.h unistd.h memory.h errno.h direct.h
do
- ac_safe=`echo "$ac_hdr" | tr './\055' '___'`
+ ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
diff --git a/converters/xdeview/files/patch-tcl_Makefile.in b/converters/xdeview/files/patch-tcl_Makefile.in
index 4f1a3519637c..c2f18a263b7b 100644
--- a/converters/xdeview/files/patch-tcl_Makefile.in
+++ b/converters/xdeview/files/patch-tcl_Makefile.in
@@ -1,7 +1,7 @@
---- tcl/Makefile.in.orig Thu Jun 6 13:09:05 1996
-+++ tcl/Makefile.in Wed Apr 2 00:06:10 1997
-@@ -95,8 +95,8 @@
- rm -f uuwish [Xx]deview gif2gfp
+--- tcl/Makefile.in.orig 2001-06-04 16:26:57 UTC
++++ tcl/Makefile.in
+@@ -95,8 +95,8 @@ new: clean
+ rm -f uuwish
make all
-uuwish: $(OBJ) ../uulib/libuu.a
@@ -9,5 +9,5 @@
+uuwish: $(OBJ)
+ $(CC) -o $@ $(OBJ) -luu $(LIBS)
- xdeview: xdeview.head tk_MFSbox.tcl xdeview.tail
- rm -f $@
+ xdeview:
+ chmod 755 $@
diff --git a/converters/xdeview/files/patch-tcl_uutcl.c b/converters/xdeview/files/patch-tcl_uutcl.c
index 9113510834a3..2142387b2b59 100644
--- a/converters/xdeview/files/patch-tcl_uutcl.c
+++ b/converters/xdeview/files/patch-tcl_uutcl.c
@@ -1,5 +1,5 @@
---- tcl/uutcl.c.orig Sat Feb 19 18:56:55 2005
-+++ tcl/uutcl.c Sat Feb 19 18:57:08 2005
+--- tcl/uutcl.c.orig 2002-03-06 13:52:45 UTC
++++ tcl/uutcl.c
@@ -48,14 +48,6 @@
#include <tcl.h>
#endif