aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-07-09 08:40:17 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-07-09 08:40:17 +0000
commitf6d56007b984e83ebda7162c99abc18d5bde982e (patch)
treeaa20f69168c1d6c9e0dbf200cc417eb6ea9147ca /converters
parentbd0d393e807d8d13fca4ce0ff12e4497385e3e24 (diff)
downloadports-f6d56007b984e83ebda7162c99abc18d5bde982e.tar.gz
ports-f6d56007b984e83ebda7162c99abc18d5bde982e.zip
Remove all := from BUILD_DEPENDS, here are never needed.
While there, cleanup, and sort depends. When build and run dependencies are the same, there are three ways to avoid duplicating the list while not adding the framework added BUILD_DEPENDS to the RUN_DEPENDS. In order of preference, they are: 1) use RUN_DEPENDS to set BUILD_DEPENDS: BUILD_DEPENDS= ${RUN_DEPENDS} RUN_DEPENDS= foo:bar/baz 2) create another variable and use it: MY_DEPENDS= foo:bar/baz BUILD_DEPENDS= ${MY_DEPENDS} RUN_DEPENDS= ${MY_DEPENDS} 3) use BUILD_DEPENDS to set RUN_DEPENDS and force evaluation: BUILD_DEPENDS= foo:bar/baz RUN_DEPENDS:= ${BUILD_DEPENDS} Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=474242
Diffstat (limited to 'converters')
-rw-r--r--converters/p5-Convert-PEM/Makefile2
-rw-r--r--converters/p5-Data-AMF/Makefile2
-rw-r--r--converters/p5-Encode-Punycode/Makefile4
-rw-r--r--converters/p5-JSON-XS-VersionOneAndTwo/Makefile2
-rw-r--r--converters/p5-JSON1/Makefile2
-rw-r--r--converters/p5-MIME-Base64-URLSafe/Makefile2
-rw-r--r--converters/p5-Net-IDN-Nameprep/Makefile4
7 files changed, 9 insertions, 9 deletions
diff --git a/converters/p5-Convert-PEM/Makefile b/converters/p5-Convert-PEM/Makefile
index 8b1beb32d9c6..06a656d763cd 100644
--- a/converters/p5-Convert-PEM/Makefile
+++ b/converters/p5-Convert-PEM/Makefile
@@ -11,10 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Read/write access to ASN.1-encoded PEM files with optional encryption
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Class-ErrorHandler>=0:devel/p5-Class-ErrorHandler \
p5-Convert-ASN1>=0.10:converters/p5-Convert-ASN1 \
p5-Crypt-DES_EDE3>=0:security/p5-Crypt-DES_EDE3
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/converters/p5-Data-AMF/Makefile b/converters/p5-Data-AMF/Makefile
index 424daac6caac..de6f499cbb30 100644
--- a/converters/p5-Data-AMF/Makefile
+++ b/converters/p5-Data-AMF/Makefile
@@ -10,12 +10,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to serialize, deserialize AMF data
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= \
p5-DateTime>0:devel/p5-DateTime \
p5-Any-Moose>0:devel/p5-Any-Moose \
p5-UNIVERSAL-require>0:devel/p5-UNIVERSAL-require \
p5-XML-LibXML>0:textproc/p5-XML-LibXML
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/converters/p5-Encode-Punycode/Makefile b/converters/p5-Encode-Punycode/Makefile
index fb42b2ea3560..16484eaa9f35 100644
--- a/converters/p5-Encode-Punycode/Makefile
+++ b/converters/p5-Encode-Punycode/Makefile
@@ -12,9 +12,9 @@ COMMENT= Encode plugin for Punycode
LICENSE= GPLv1
-RUN_DEPENDS= p5-Net-IDN-Encode>=0:textproc/p5-Net-IDN-Encode
-BUILD_DEPENDS:= ${RUN_DEPENDS} \
+BUILD_DEPENDS= ${RUN_DEPENDS} \
p5-Test-NoWarnings>=0:devel/p5-Test-NoWarnings
+RUN_DEPENDS= p5-Net-IDN-Encode>=0:textproc/p5-Net-IDN-Encode
USES= perl5
USE_PERL5= modbuild
diff --git a/converters/p5-JSON-XS-VersionOneAndTwo/Makefile b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
index bd4047cad702..32f5a3c6fa73 100644
--- a/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
+++ b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= culot@FreeBSD.org
COMMENT= Support versions 1 and 2 of JSON::XS
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-JSON-XS>=0:converters/p5-JSON-XS
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/converters/p5-JSON1/Makefile b/converters/p5-JSON1/Makefile
index cc868940c4a3..20ab2a6583c4 100644
--- a/converters/p5-JSON1/Makefile
+++ b/converters/p5-JSON1/Makefile
@@ -11,8 +11,8 @@ PKGNAMESUFFIX= 1
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to convert to JSON (JavaScript Object Notation)
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-libwww>=0:www/p5-libwww
-BUILD_DEPENDS:= ${RUN_DEPENDS}
CONFLICTS= p5-JSON-2.*
USES= perl5
diff --git a/converters/p5-MIME-Base64-URLSafe/Makefile b/converters/p5-MIME-Base64-URLSafe/Makefile
index c2e15ed87330..40972dc2a308 100644
--- a/converters/p5-MIME-Base64-URLSafe/Makefile
+++ b/converters/p5-MIME-Base64-URLSafe/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= Perl version of Python's URL-safe base64 codec
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-MIME-Base64>=0:converters/p5-MIME-Base64
-BUILD_DEPENDS:= ${RUN_DEPENDS}
WRKSRC= ${WRKDIR}/${DISTNAME:S/00//}
diff --git a/converters/p5-Net-IDN-Nameprep/Makefile b/converters/p5-Net-IDN-Nameprep/Makefile
index 86ea601b3c76..eb7fc1bd2e15 100644
--- a/converters/p5-Net-IDN-Nameprep/Makefile
+++ b/converters/p5-Net-IDN-Nameprep/Makefile
@@ -10,9 +10,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= bofh@FreeBSD.org
COMMENT= Normalization of domain names (Nameprep, RFC 3491)
-RUN_DEPENDS= p5-Unicode-Stringprep>=0:converters/p5-Unicode-Stringprep
-BUILD_DEPENDS:= ${RUN_DEPENDS} \
+BUILD_DEPENDS= ${RUN_DEPENDS} \
p5-Test-NoWarnings>=0:devel/p5-Test-NoWarnings
+RUN_DEPENDS= p5-Unicode-Stringprep>=0:converters/p5-Unicode-Stringprep
USES= perl5
USE_PERL5= modbuild