aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-26 01:39:09 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-26 01:39:09 +0000
commitd260b2acdf1731472b88a52160589239dc032c71 (patch)
tree16b8c5727f4ad0e0751bc84ff18b707c6541085e /converters
parent6a6f5225cab41a6f84c3a78e4f59c2190a91c748 (diff)
downloadports-d260b2acdf1731472b88a52160589239dc032c71.tar.gz
ports-d260b2acdf1731472b88a52160589239dc032c71.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-JSON-XS/Makefile27
-rw-r--r--converters/p5-JSON-XS/distinfo3
-rw-r--r--converters/p5-JSON-XS/pkg-descr11
-rw-r--r--converters/p5-JSON-XS/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 7204b56ef266..6f89d8982edc 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -58,6 +58,7 @@
SUBDIR += p5-Encode-compat
SUBDIR += p5-JSON
SUBDIR += p5-JSON-DWIW
+ SUBDIR += p5-JSON-XS
SUBDIR += p5-MIME-Base32
SUBDIR += p5-MIME-Base64
SUBDIR += p5-Number-Nary
diff --git a/converters/p5-JSON-XS/Makefile b/converters/p5-JSON-XS/Makefile
new file mode 100644
index 000000000000..11ee820b1046
--- /dev/null
+++ b/converters/p5-JSON-XS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: JSON-XS
+# Date created: 25 Mar 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-XS
+PORTVERSION= 0.8
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/ML/MLEHMANN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= JSON serialising/deserialising, done correctly and fast
+
+PERL_CONFIGURE= yes
+MAN3= JSON::XS.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/converters/p5-JSON-XS/distinfo b/converters/p5-JSON-XS/distinfo
new file mode 100644
index 000000000000..ec67d9067bb1
--- /dev/null
+++ b/converters/p5-JSON-XS/distinfo
@@ -0,0 +1,3 @@
+MD5 (JSON-XS-0.8.tar.gz) = 30f7bcca3048999c5b6b9fc7b80f2a76
+SHA256 (JSON-XS-0.8.tar.gz) = 030ab74b96914871e7210c9e39a61b77a3cd6c35805857e72ec4cb379c1d0dd0
+SIZE (JSON-XS-0.8.tar.gz) = 30066
diff --git a/converters/p5-JSON-XS/pkg-descr b/converters/p5-JSON-XS/pkg-descr
new file mode 100644
index 000000000000..bfee60f2f894
--- /dev/null
+++ b/converters/p5-JSON-XS/pkg-descr
@@ -0,0 +1,11 @@
+This module converts Perl data structures to JSON and vice versa.
+Its primary goal is to be correct and its secondary goal is to be fast.
+To reach the latter goal it was written in C.
+
+As this is the n-th-something JSON module on CPAN, what was the reason
+to write yet another JSON module? While it seems there are many JSON
+modules, none of them correctly handle all corner cases, and in most
+cases their maintainers are unresponsive, gone missing, or not listening
+to bug reports for other reasons.
+
+WWW: http://search.cpan.org/dist/JSON-XS/
diff --git a/converters/p5-JSON-XS/pkg-plist b/converters/p5-JSON-XS/pkg-plist
new file mode 100644
index 000000000000..5a325d7e7b4c
--- /dev/null
+++ b/converters/p5-JSON-XS/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/JSON/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/XS/XS.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/JSON