aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-07-26 15:44:15 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-07-26 15:44:15 +0000
commit5eb1381a24f03d08b1f0a1c9d8966da186c20c2e (patch)
tree80d06bbd8e13fb5888512a6e94f9016b6b6a7ef8 /converters
parent1bd446561d121576eeb00d326fe8f73605e22a97 (diff)
downloadports-5eb1381a24f03d08b1f0a1c9d8966da186c20c2e.tar.gz
ports-5eb1381a24f03d08b1f0a1c9d8966da186c20c2e.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/p5-Unicode-MapUTF8/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/converters/p5-Unicode-MapUTF8/Makefile b/converters/p5-Unicode-MapUTF8/Makefile
index 8e9b08199a85..fe4b4d35a363 100644
--- a/converters/p5-Unicode-MapUTF8/Makefile
+++ b/converters/p5-Unicode-MapUTF8/Makefile
@@ -17,7 +17,7 @@ COMMENT= Perl class that implements conversion between arbitrary charsets
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/Map.pm:${PORTSDIR}/converters/p5-Unicode-Map \
${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
${SITE_PERL}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-Map8 \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,4 +25,12 @@ PERL_CONFIGURE= yes
MAN3= Unicode::MapUTF8.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>