aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-27 21:12:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-27 21:12:27 +0000
commita1b1321d98a74d6d1f1a9ed19e51542a4578af1e (patch)
tree426ced2cacd4343988070b562fce50ff7a4c9301 /converters
parent5c18a76486d0923bccac4b5b253df79310516bb9 (diff)
downloadports-a1b1321d98a74d6d1f1a9ed19e51542a4578af1e.tar.gz
ports-a1b1321d98a74d6d1f1a9ed19e51542a4578af1e.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/convmv/Makefile21
-rw-r--r--converters/convmv/distinfo2
-rw-r--r--converters/convmv/files/patch-Makefile24
-rw-r--r--converters/convmv/pkg-descr16
5 files changed, 64 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 0ae885a24540..8052246ed5e0 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -10,6 +10,7 @@
SUBDIR += chmview
SUBDIR += cmios9
SUBDIR += cn2jp
+ SUBDIR += convmv
SUBDIR += dosunix
SUBDIR += dumpasn1
SUBDIR += enca
diff --git a/converters/convmv/Makefile b/converters/convmv/Makefile
new file mode 100644
index 000000000000..68c9e069217d
--- /dev/null
+++ b/converters/convmv/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: convmv
+# Date created: 27 October 2004
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= convmv
+PORTVERSION= 1.08
+CATEGORIES= converters perl5
+MASTER_SITES= http://j3e.de/linux/convmv/
+
+MAINTAINER= kcwu@csie.org
+COMMENT= Convert filenames from one encoding to another
+
+USE_PERL5= yes
+PLIST_FILES= bin/convmv
+
+MAN1= convmv.1
+
+.include <bsd.port.mk>
diff --git a/converters/convmv/distinfo b/converters/convmv/distinfo
new file mode 100644
index 000000000000..bfc699f00c62
--- /dev/null
+++ b/converters/convmv/distinfo
@@ -0,0 +1,2 @@
+MD5 (convmv-1.08.tar.gz) = 40707f82b1a9631fe715f68f94431d3a
+SIZE (convmv-1.08.tar.gz) = 20657
diff --git a/converters/convmv/files/patch-Makefile b/converters/convmv/files/patch-Makefile
new file mode 100644
index 000000000000..a26c9b1a0e1d
--- /dev/null
+++ b/converters/convmv/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig Wed Oct 27 16:52:11 2004
++++ Makefile Wed Oct 27 16:51:52 2004
+@@ -1,17 +1,17 @@
+ DESTDIR=
+-PREFIX=/usr/local
+-MANDIR=$(PREFIX)/share/man
++PREFIX?=/usr/local
++MANDIR=$(PREFIX)/man
+
+ all: manpage
+
+ install: all
+ mkdir -p $(DESTDIR)$(MANDIR)/man1/
+ mkdir -p $(DESTDIR)$(PREFIX)/bin/
+- cp convmv.1.gz $(DESTDIR)$(MANDIR)/man1/
++ cp convmv.1 $(DESTDIR)$(MANDIR)/man1/
+ install -m 755 convmv $(DESTDIR)$(PREFIX)/bin/
+
+ manpage:
+- pod2man --section 1 --center=" " convmv | gzip > convmv.1.gz
++ pod2man --section 1 --center=" " convmv > convmv.1
+
+ clean:
+ rm -f convmv.1.gz convmv-*.tar.gz MD5sums .files .name
diff --git a/converters/convmv/pkg-descr b/converters/convmv/pkg-descr
new file mode 100644
index 000000000000..cfdfe3b80d9a
--- /dev/null
+++ b/converters/convmv/pkg-descr
@@ -0,0 +1,16 @@
+convmv is meant to help convert a single filename, a directory tree and the
+contained files or a whole filesystem into a different encoding. It just
+converts the filenames, not the content of the files. A special feature of
+convmv is that it also takes care of symlinks, also converts the symlink target
+pointer in case the symlink target is being converted, too.
+
+All this comes in very handy when one wants to switch over from old 8-bit
+locales to UTF-8 locales. It is also possible to convert directories to UTF-8
+which are already partly UTF-8 encoded. convmv is able to detect if certain
+files are UTF-8 encoded and will skip them by default. To turn this smartness
+off use the --nosmart switch.
+
+WWW: http://j3e.de/linux/convmv/man/
+
+- Kuang-che Wu
+ kcwu@csie.org