aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-12-05 15:46:02 +0000
committerRene Ladan <rene@FreeBSD.org>2018-12-05 15:46:02 +0000
commit1aaf1022212ac028c4fe22853aa76969437039ee (patch)
tree5737ff9d04cf33dfa35a21f4ffa1df3be2880c55 /converters
parentc4337bad81ecca634781b10f30df668da053cdde (diff)
downloadports-1aaf1022212ac028c4fe22853aa76969437039ee.tar.gz
ports-1aaf1022212ac028c4fe22853aa76969437039ee.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile3
-rw-r--r--converters/php70-iconv/Makefile10
-rw-r--r--converters/php70-mbstring/Makefile10
-rw-r--r--converters/php70-mbstring/files/patch-config.m451
-rw-r--r--converters/php70-mbstring/files/patch-php__mbregex.c11
-rw-r--r--converters/php70-recode/Makefile10
6 files changed, 0 insertions, 95 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 03d607ece55f..27c5a276f3ec 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -143,9 +143,6 @@
SUBDIR += php56-iconv
SUBDIR += php56-mbstring
SUBDIR += php56-recode
- SUBDIR += php70-iconv
- SUBDIR += php70-mbstring
- SUBDIR += php70-recode
SUBDIR += php71-iconv
SUBDIR += php71-mbstring
SUBDIR += php71-recode
diff --git a/converters/php70-iconv/Makefile b/converters/php70-iconv/Makefile
deleted file mode 100644
index 89058d3eefa4..000000000000
--- a/converters/php70-iconv/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# Created by: Alex Dupre <ale@FreeBSD.org>
-# $FreeBSD$
-
-CATEGORIES= converters
-
-MASTERDIR= ${.CURDIR}/../../lang/php70
-
-PKGNAMESUFFIX= -iconv
-
-.include "${MASTERDIR}/Makefile"
diff --git a/converters/php70-mbstring/Makefile b/converters/php70-mbstring/Makefile
deleted file mode 100644
index 634120319c67..000000000000
--- a/converters/php70-mbstring/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# Created by: Alex Dupre <ale@FreeBSD.org>
-# $FreeBSD$
-
-CATEGORIES= converters
-
-MASTERDIR= ${.CURDIR}/../../lang/php70
-
-PKGNAMESUFFIX= -mbstring
-
-.include "${MASTERDIR}/Makefile"
diff --git a/converters/php70-mbstring/files/patch-config.m4 b/converters/php70-mbstring/files/patch-config.m4
deleted file mode 100644
index 026798f26a5a..000000000000
--- a/converters/php70-mbstring/files/patch-config.m4
+++ /dev/null
@@ -1,51 +0,0 @@
---- config.m4.orig 2009-11-25 02:30:06.000000000 +0100
-+++ config.m4 2010-04-12 09:59:54.000000000 +0200
-@@ -43,6 +43,30 @@
- PHP_ADD_INCLUDE([$ext_builddir/$dir])
- done
-
-+ dnl This is PECL build, check if bundled PCRE library is used
-+ old_CPPFLAGS=$CPPFLAGS
-+ CPPFLAGS=$INCLUDES
-+ AC_EGREP_CPP(yes,[
-+#include <main/php_config.h>
-+#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
-+yes
-+#endif
-+ ],[
-+ PHP_PCRE_REGEX=yes
-+ ],[
-+ AC_EGREP_CPP(yes,[
-+#include <main/php_config.h>
-+#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
-+yes
-+#endif
-+ ],[
-+ PHP_PCRE_REGEX=pecl
-+ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
-+ ],[
-+ PHP_PCRE_REGEX=no
-+ ])
-+ ])
-+
- if test "$ext_shared" = "no"; then
- PHP_ADD_SOURCES(PHP_EXT_DIR(mbstring), $PHP_MBSTRING_BASE_SOURCES)
- out="php_config.h"
-@@ -80,7 +104,6 @@
- int foo(int x, ...) {
- va_list va;
- va_start(va, x);
-- va_arg(va, int);
- va_arg(va, char *);
- va_arg(va, double);
- return 0;
-@@ -347,6 +370,9 @@
- [ --with-onig[=DIR] MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
- If DIR is not set, the bundled oniguruma will be used], no, no)
-
-+PHP_ARG_WITH(pcre-dir, pcre install prefix,
-+[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
-+
- if test "$PHP_MBSTRING" != "no"; then
- AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
-
diff --git a/converters/php70-mbstring/files/patch-php__mbregex.c b/converters/php70-mbstring/files/patch-php__mbregex.c
deleted file mode 100644
index c7bbf8b00f0b..000000000000
--- a/converters/php70-mbstring/files/patch-php__mbregex.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- php_mbregex.c.orig 2018-02-27 13:16:12 UTC
-+++ php_mbregex.c
-@@ -452,7 +452,7 @@ static php_mb_regex_t *php_mbregex_compi
- OnigUChar err_str[ONIG_MAX_ERROR_MESSAGE_LEN];
-
- rc = zend_hash_str_find_ptr(&MBREX(ht_rc), (char *)pattern, patlen);
-- if (!rc || rc->options != options || rc->enc != enc || rc->syntax != syntax) {
-+ if (!rc || onig_get_options(rc) != options || onig_get_encoding(rc) != enc || onig_get_syntax(rc) != syntax) {
- if ((err_code = onig_new(&retval, (OnigUChar *)pattern, (OnigUChar *)(pattern + patlen), options, enc, syntax, &err_info)) != ONIG_NORMAL) {
- onig_error_code_to_str(err_str, err_code, &err_info);
- php_error_docref(NULL, E_WARNING, "mbregex compile err: %s", err_str);
diff --git a/converters/php70-recode/Makefile b/converters/php70-recode/Makefile
deleted file mode 100644
index 5534d7173f41..000000000000
--- a/converters/php70-recode/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# Created by: Alex Dupre <ale@FreeBSD.org>
-# $FreeBSD$
-
-CATEGORIES= converters
-
-MASTERDIR= ${.CURDIR}/../../lang/php70
-
-PKGNAMESUFFIX= -recode
-
-.include "${MASTERDIR}/Makefile"