aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2010-12-10 01:08:12 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2010-12-10 01:08:12 +0000
commit9727cb19d813baace760f76779225e8b309b5ba8 (patch)
treef8c2e786a0ad80f78ea48190b70c5ea202d43696 /converters
parent3f94eeab0792c082103566b2eca9f13347731ea5 (diff)
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-Net-IDN-Nameprep/Makefile25
-rw-r--r--converters/p5-Net-IDN-Nameprep/distinfo2
-rw-r--r--converters/p5-Net-IDN-Nameprep/pkg-descr9
-rw-r--r--converters/p5-Net-IDN-Nameprep/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 7c28e32a82dc..a102317cb20d 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -83,6 +83,7 @@
SUBDIR += p5-MIME-Base32
SUBDIR += p5-MIME-Base64
SUBDIR += p5-MIME-Base64-URLSafe
+ SUBDIR += p5-Net-IDN-Nameprep
SUBDIR += p5-Number-Nary
SUBDIR += p5-Number-RecordLocator
SUBDIR += p5-Storable-AMF
diff --git a/converters/p5-Net-IDN-Nameprep/Makefile b/converters/p5-Net-IDN-Nameprep/Makefile
new file mode 100644
index 000000000000..d91603634fcc
--- /dev/null
+++ b/converters/p5-Net-IDN-Nameprep/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-IDN-Nameprep
+# Date created: 10 Dec 2010
+# Whom: Timur Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IDN-Nameprep
+PORTVERSION= 1.100
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= timur@FreeBSD.org
+COMMENT= normalization of domain names (Nameprep, RFC 3491)
+
+RUN_DEPENDS= ${SITE_PERL}/Unicode/Stringprep.pm:${PORTSDIR}/converters/p5-Unicode-Stringprep
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
+
+PERL_MODBUILD= yes
+
+MAN3= Net::IDN::Nameprep.3
+
+.include <bsd.port.mk>
diff --git a/converters/p5-Net-IDN-Nameprep/distinfo b/converters/p5-Net-IDN-Nameprep/distinfo
new file mode 100644
index 000000000000..028545c674dc
--- /dev/null
+++ b/converters/p5-Net-IDN-Nameprep/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-IDN-Nameprep-1.100.tar.gz) = 5d58aa05e09ff629493bcda2f25496d1980cf35673488c21ac1caa2607760d00
+SIZE (Net-IDN-Nameprep-1.100.tar.gz) = 14475
diff --git a/converters/p5-Net-IDN-Nameprep/pkg-descr b/converters/p5-Net-IDN-Nameprep/pkg-descr
new file mode 100644
index 000000000000..002bbe97ad0f
--- /dev/null
+++ b/converters/p5-Net-IDN-Nameprep/pkg-descr
@@ -0,0 +1,9 @@
+This module implements the nameprep specification, which describes how
+to prepare internationalized domain name (IDN) labels in order to
+increase the likelihood that name input and name comparison work in
+ways that make sense for typical users throughout the world. Nameprep
+is a profile of the stringprep protocol and is used as part of a suite
+of on-the-wire protocols for internationalizing the Domain Name System
+(DNS).
+
+WWW: http://search.cpan.org/dist/Net-IDN-Nameprep/
diff --git a/converters/p5-Net-IDN-Nameprep/pkg-plist b/converters/p5-Net-IDN-Nameprep/pkg-plist
new file mode 100644
index 000000000000..181b803210dd
--- /dev/null
+++ b/converters/p5-Net-IDN-Nameprep/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Net/IDN/Nameprep.pm
+@dirrmtry %%SITE_PERL%%/Net/IDN
+@dirrmtry %%SITE_PERL%%/Net